add a user into samba windows file sharing.

J

james_ptg

Guest
Hi people,

I'm actually testing SoGo ZEG

So it's based on

Ubuntu 12.04 With Webmin as interface

So I have enabled Samba Windows File Sharing

now I try to create a account to let a windows user have acces to the sharing. but I don't understand how create this account ?

I have follow this guide
Samba Configuration:

but I'm stuck at the point 22
Open up a virtual terminal if you're running X windows or log into your Samba Server if you're running Webmin remotely. Type in: “smbpasswd” username where username is a valid user on your samba server. You'll be prompted for a password and to re-authenticate the password by retyping it. It's recommended that you use the same password that you would to log into the server to keep things easier to manage, but it isn't necessary. Running “smbpasswd” will create an authentication file for Samba to check when you log in to the server from a Windows computer.
so where can I type this command
Code:
“smbpasswd” username
I have try inside the webmin Command Shell but with no succes


James.
 


A

arochester

Guest
Have you put "“smbpasswd” username" here because you do not want to show the username?

In my case it would be: “smbpasswd” alan

"Type in: “smbpasswd” username where username is a valid user on your samba server."

At this point, experimentation needed, I am not sure about the quote marks "". If the distro is based on Ubuntu I would also wonder about sudo.
 
J

james_ptg

Guest
Thank arochester,

so trough the web interface (webmin) with the command shell panel I have put this ->

“smbpasswd” test
and i have as a return
bash: $'\223smbpasswd\224': command not found
I have success to login locally to this SoGo machine ->


but he tell me that command cannot be found.
 
S

sivashankar

Guest
For samba sharing we should have the same user name in linux and window AD side

create samba user and make sure smb user and linux user should same
smbpasswd -a username
pdbedit -l --> to show samba users
testparm - to check if any errors
restart the smb service

Go to windows servers and go to network and give the ip
 
M

MikeyD

Guest
The main problem is the command isn't the whole word password, just passwd. You also don't need the quotes although it should still work

sivashankar is right as general a rule of thumb you want to make a user on the system itself first (or your user if you're doing that) and then use smbpasswd with -a to relate the samba password to the actual system user.

So if your user is "test" and they aren't in the system:

useradd -m -k test (look at the useradd man page for all options)
passwd test (to set the system password)
smbpasswd -a test (to set the samba password)


I was too lazy to look at that link, but make sure you have a share created in smb.conf and the user (or their group) is added to the valid users column.

This is one of my shares on my home server:

Code:
[Mike]
        comment = Mike Home Directory
        path = /home/mike
        browseable = yes
        writable = yes
        guest ok = no
        read only = no
        valid users = @mdehart
 
Last edited:

Members online


Latest posts

Top