Wireless speed capped?

Discussion in 'Linux Networking' started by ryanvade, Jul 23, 2013.

  1. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    Hello. I have a question about wireless speed. I am using a new Intel 7260 wireless AC nic. In windows the connection speed to my Netgear R6300v2 router is usually above 400 Mb/s. However, in Linux the speed NEVER goes above 150 Mb/s. What could be causing that? Is it possible that NetworkManager is capping the connection speed? I would not think so, but I have no idea. I am using kernel 3.11-rc2 with the newest firmware. The distribution is Diamond II-B.


    Does anyone have any suggestions?

    Thanks,
    ryanvade
    DevynCJohnson likes this.
  2. Peter Jones

    Peter Jones New Member

    Messages:
    12
    Likes Received:
    8
    Trophy Points:
    3
    I think the test your using makes a difference?
    When I check my connection with ISP test it shows crazy high speed up and down, but, using independent tests it's around 1/10 the speed
    ryanvade and Rob like this.
  3. Rob

    Rob Administrator Staff Member

    Messages:
    573
    Likes Received:
    183
    Trophy Points:
    43
    True -
    True..

    Try a test with wget to another local machine..
    Code:
    wget --output-document=/dev/null http://192.168.0.X/blah.iso
    See if you get above the 150mb/s number?
    DevynCJohnson likes this.
  4. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    Sorry for not responding sooner. I setup a ready share on the router. And downloaded a Fedora ISO to /dev/null (no reason to keep a copy on my laptop) The max speed was 12 Mb/s. NetworkManager is reporting a speed of 150 Mb/s still.
  5. ShonnaDeem

    ShonnaDeem New Member

    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    3
    The speed is definitely not slow..the test you are using must have been showing wrong results..try speedbit.net..i guess that is a good speed checker.
    DevynCJohnson likes this.
  6. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    So, an odd development. On campus I am getting a wireless a connection (channel 36, 5180 MHz) of 300 mbits/s. When at my house I get a speed of 150 mbits/s at wireless ac. Any ideas?
  7. Codypy1

    Codypy1 Member

    Messages:
    85
    Likes Received:
    32
    Trophy Points:
    18
    Hmm I noticed on my home network. I was getting 150 mbs as well. Could be the provider? You don't use Comcast by any chance do you?
  8. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    Frontier...about the same..
  9. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    60
    Trophy Points:
    18
    It may be that 802.11ac is not well supported as yet by some drivers. It may be stepping down to 802.11n speeds for various reasons such as router configuration.

    You should have a look in your router config and temporarily force it to ac speeds instead of allowing it to run in "mixed mode" and then see if the nic can associate with the AP.
  10. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    Here is Windows:
    wireless_speed_windows.png

    in a second I will upload a snapshot of Network Manager
    wireless_speed_linux.png

    So, I upgraded network-manager and you can see the results. Power management is disabled also.
    Last edited: Oct 4, 2013
  11. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    60
    Trophy Points:
    18
    You can see that iwconfig reports 802.11abgn, instead of 802.11ac

    Yet network connections correctly assumes 802.11ac ("WiFi")

    You build your own kernels if I recall correctly? Did you ensure that you installed the new kernel firmware for iwlwifi?
  12. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    Actually, to use my wifi card I had to update the firmware files. My wifi card uses firmware API lvl 7. I upgraded the firmware from
    https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/

    The firmware for my wireless card is also available here
    http://wireless.kernel.org/en/users/Drivers/iwlwifi

    and placed it in /lib/firmware.

    Perhaps I missed something?
    Last edited: Oct 5, 2013
  13. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    I am going to try iwlwifi-next. And I set CONFIG_PREVENT_FIRMWARE_BUILD to =n

    Maybe that will fix something...
  14. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    I finally got a response from Intel
  15. cybercritter

    cybercritter New Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    Based on the information is this thread, my first guess, at least for RX, there is a bug in the driver that handles the high speed packet processing.
    i would expect, if the device can handle the rates and it has properly negotiated with router as 802.11ac then the incoming packet handling should not be effected by the linux stack. TX packets are a different story since the kernel meters those based on the driver.

    of course this is all conjecture as I have not looked at this driver.
    ryanvade likes this.
  16. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,135
    Likes Received:
    382
    Trophy Points:
    83
    Or this really could be Network Manager reporting the speed wrong. Either one seems plausible. I guess I need to keep trying new kernels...

Share This Page