problem with sudo apt get update

Discussion in 'General Linux' started by vansh, Sep 11, 2013.

  1. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    hello all,
    i am trying to update sudo apt get using :sudo apt-get update
    but getting following error:
    any help regarding same ..
    Ign http://in.archive.ubuntu.com quantal InRelease
    Ign http://in.archive.ubuntu.com quantal-security InRelease
    Ign http://in.archive.ubuntu.com quantal-security Release.gpg
    Ign http://in.archive.ubuntu.com quantal-security Release
    Err http://in.archive.ubuntu.com quantal-security/multiverse i386 Packages


    Err http://in.archive.ubuntu.com quantal-security/multiverse i386 Packages
    Undetermined Error
    W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/quantal-security/multiverse/binary-i386/Packages Undetermined Error

    E: Some index files failed to download. They have been ignored, or old ones used instead.
    Last edited: Sep 11, 2013
  2. Rob

    Rob Administrator Staff Member

    Messages:
    575
    Likes Received:
    229
    Trophy Points:
    43
  3. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
  4. Rob

    Rob Administrator Staff Member

    Messages:
    575
    Likes Received:
    229
    Trophy Points:
    43
    This will solve your csh issue also.. your repos are pointing to old/bad links so it can't go and download the software..
  5. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    hey can you please suggest me what and how to make changes in the repository..
    ]
  6. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    61
    Trophy Points:
    18
  7. arochester

    arochester Well-Known Member

    Messages:
    896
    Likes Received:
    293
    Trophy Points:
    63
  8. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    attached is the souce list after using $ gksu gedit /etc/apt/sources.list

    please suggest required changes..

    # deb cdrom:[Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5)]/ quantal main restricted

    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://in.archive.ubuntu.com/ubuntu/ quantal main restricted
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal main restricted

    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates main restricted
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-updates main restricted

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://in.archive.ubuntu.com/ubuntu/ quantal universe
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal universe
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates universe
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-updates universe

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://in.archive.ubuntu.com/ubuntu/ quantal multiverse
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal multiverse
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates multiverse
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-updates multiverse

    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse

    deb http://in.archive.ubuntu.com/ubuntu/ quantal-security main restricted
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-security main restricted
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-security universe
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-security universe
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-security multiverse
    deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-security multiverse

    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu quantal partner
    deb-src http://archive.canonical.com/ubuntu quantal partner

    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu quantal main
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-proposed restricted main multiverse universe
    deb-src http://extras.ubuntu.com/ubuntu quantal main
  9. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    61
    Trophy Points:
    18
    What a mess...

    This is your sources simplified - there was a lot of needless duplication and I have disabled source repos:

    Code:
    deb http://in.archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
    #deb-src http://in.archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse
    
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
    #deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse
    
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse
    #deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-backports main restricted universe multiverse
    
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
    #deb-src http://in.archive.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse
    
    deb http://archive.canonical.com/ubuntu quantal partner
    #deb-src http://archive.canonical.com/ubuntu quantal partner
    
    deb http://extras.ubuntu.com/ubuntu quantal main
    #deb-src http://extras.ubuntu.com/ubuntu quantal main
    
    deb http://in.archive.ubuntu.com/ubuntu/ quantal-proposed restricted main universe multiverse
    #deb http://in.archive.ubuntu.com/ubuntu/ quantal-proposed restricted main universe multiverse

    Do the following:

    Back up existing sources:
    Code:
    # mv /etc/apt/sources.list /etc/apt/sources.list.old
    Code:
    # nano /etc/apt/sources.list
    Copy and paste the above tidied up sources, save the file (or use gedit if you must).

    Then

    Code:
    # apt-get clean && apt-get update
    Post the output, if there's still a problem then it's likely to be with the repository mirror itself, as syntactically that looks correct (I am not a buntu user).
  10. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    hi...thanks it worked ...apt-get got updated..but mow as i am trying to install csh using:
    code:
    # sudo apt-get install csh

    it shows as follows...

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package csh

    kindly suggest...
  11. arochester

    arochester Well-Known Member

    Messages:
    896
    Likes Received:
    293
    Trophy Points:
    63
  12. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    can you pleae suggest which file has to be selected as i belong to asia region..
    shall i select all ????
  13. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    when i opened these files its showing an error message:
    deepndency is not satisfiable:libbsd0 (>=0.2.0)
    and this error is for all files
  14. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    61
    Trophy Points:
    18
    Post the output
    Code:
    $ apt-cache policy libbsd0 csh
  15. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    libbsd0:
    Installed: 0.4.2-1
    Candidate: 0.4.2-1
    Version table:
    *** 0.4.2-1 0
    100 /var/lib/dpkg/status
    N: Unable to locate package csh
  16. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    61
    Trophy Points:
    18
    libbsd0 is installed and meets the dependency requirements...

    But csh doesn't exist at all...

    Yet csh is in that repo for both architectures:

    http://in.archive.ubuntu.com/ubuntu/pool/universe/c/csh/

    Post the following output:
    Code:
    $ apt-cache policy
    Can you also run
    Code:
    # apt-get update
    and post full ouput
    Last edited: Sep 12, 2013
    Rob likes this.
  17. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    output after applying apt-cache policy:

    Package files:
    100 /var/lib/dpkg/status
    release a=now
    Pinned packages:

    after revising the source files i was able to run apt-get update but nw it is showing following error
    Ign http://extras.ubuntu.com quantal InRelease
    Ign http://in.archive.ubuntu.com quantal-proposed InRelease
    Ign http://in.archive.ubuntu.com quantal-proposed Release.gpg
    Ign http://in.archive.ubuntu.com quantal-proposed Release
    Err http://in.archive.ubuntu.com quantal-proposed/restricted amd64 Packages

    Err http://in.archive.ubuntu.com quantal-proposed/restricted amd64 Packages

    Err http://in.archive.ubuntu.com quantal-proposed/restricted amd64 Packages
    Undetermined Error
    W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/quantal-proposed/restricted/binary-amd64/Packages Undetermined Error

    E: Some index files failed to download. They have been ignored, or old ones used inste
  18. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,333
    Likes Received:
    443
    Trophy Points:
    83
    Make sure to use the best server for your location.
    Open Software Sources
    Press Alt+F2, type gksu software-properties-gtk, and enter your password. (Alternatively, select Settings... at the lower left corner of the Update Manager, or go to Settings > Repositories in Synaptic).

    • That's for Ubuntu 10.04 LTS, which you are not running. In later releases, you can just run software-properties-gtk and when you make changes, PolicyKit will authenticate you.
    • Most people using newer releases have the Software Center and not Synaptic. In the Software Center, you would go to Edit > Software Sources....
    • The Update Manager is unchanged, but in new releases is called the Software Updater.
    Change the Download Server
    In the Ubuntu Software tab of the Software Sources window, there is a drop-down menu labeled Download from. Select your regional server. For example, I'm in the United States and it looks like this on my 11.10 machine:

    [​IMG]
    Software Sources window showing Sever for United States being selected in the "Download from" drop-down menu.

    You may see other servers listed in that short list (like the server you currently have set up).

    You can use the Main server too but it is almost always considerably slower than using your regional server. (At least in the United States, anyway.)

    If you want to use another mirror, you can look through a list of mirrors by clicking Other....

    Source: ask ubuntu
    Last edited: Sep 12, 2013
    Rob likes this.
  19. flunwyc

    flunwyc Member

    Messages:
    99
    Likes Received:
    61
    Trophy Points:
    18
    I'm not convinced that you even have an active network connection...

    Can you post these outputs
    Code:
    $ /sbin/ifconfig
    Code:
    $ cat /etc/resolv.conf
  20. vansh

    vansh Member

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    output for the code: /sbin/ifconfig

    eth0 Link encap:Ethernet HWaddr c8:60:00:cc:51:01
    inet addr:172.141.102.232 Bcast:172.141.255.255 Mask:255.255.0.0
    inet6 addr: 2002:ac8d:6ee8:a:c1d:17f9:9cbb:14b0/64 Scope:Global
    inet6 addr: 2002:ac8d:6ee8:a:ca60:ff:fecc:5101/64 Scope:Global
    inet6 addr: fec0::a:ca60:ff:fecc:5101/64 Scope:Site
    inet6 addr: 2002:ac8d:6c35:a:ca60:ff:fecc:5101/64 Scope:Global
    inet6 addr: fec0::c:ca60:ff:fecc:5101/64 Scope:Site
    inet6 addr: 2002:ac8d:79ca:c:ca60:ff:fecc:5101/64 Scope:Global
    inet6 addr: fe80::ca60:ff:fecc:5101/64 Scope:Link
    inet6 addr: 2002:ac8d:6ee8:a:5d65:defa:15bb:f094/64 Scope:Global
    inet6 addr: fec0::a:5d65:defa:15bb:f094/64 Scope:Site
    inet6 addr: 2002:ac8d:6c35:a:5d65:defa:15bb:f094/64 Scope:Global
    inet6 addr: fec0::c:5d65:defa:15bb:f094/64 Scope:Site
    inet6 addr: 2002:ac8d:79ca:c:5d65:defa:15bb:f094/64 Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:6730526 errors:0 dropped:32923 overruns:0 frame:0
    TX packets:329010 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:673366716 (673.3 MB) TX bytes:40403519 (40.4 MB)
    Interrupt:18 Memory:f9100000-f9120000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:10368 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10368 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:811296 (811.2 KB) TX bytes:811296 (811.2 KB)

Share This Page