How do I enable multiple cores in my virtual enviroment?

Discussion in 'General Linux' started by hasse, Oct 25, 2013.

  1. hasse

    hasse New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I've installed Ubuntu in a virtual enviroment using Oracle VM VirtualBox Manager and it works great.

    However I'd like to enable multiple cores - as seen in the image below my Windows machine has 2 cores:
    [align=center][​IMG][/align]

    Now when I run the
    Code:
    lscpu
    in Ubunto I get the following info revealing that only 1 core is being utilized:
    [align=center][​IMG][/align]

    I've tried changing the settings of the virtual box to enable multiple processors but it won't allow me to do so as shown in the image below:
    [align=center][​IMG][/align]


    How do I enable multiple cores (processors) in my virtual enviroment?
  2. Machin Shin

    Machin Shin Member

    Messages:
    59
    Likes Received:
    48
    Trophy Points:
    18
    I'm suspecting your problem is not having VT-x enabled. It is a processor feature for visualization that allows virtual machines better access to the processor. Look under the Acceleration tab in Virtual Box in your VM settings. You should see a check box there for it.

    If the check box is also greyed out then the VT-x is turned off. That is common for consumer computers. To turn it on you will have to go into your BIOS settings and activate it. You should then be able to activate all the features.

    One thing to keep in mind though is that once that is active you still want to be sure about committing two cores to the VM. Your computer only has two cores and by giving them both to the VM it becomes possible to starve your host operating system.
    DevynCJohnson likes this.

Share This Page