Black Screen on Kali

Discussion in 'Getting Started' started by enesdikme, Sep 5, 2013.

  1. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Yes , I was thinking about using Pyrit . That's why I want to install the driver :) To be able to use GPU power :) And , May you look at the attachment photo ? I , actually , asked my friend how he did it , he told me but I am just a noob :(

    Attached Files:

  2. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    This is Wheezy (I think it's like custimized Kali )
    But he was able to install the GPU driver . I think he doesn't have also an integrated intel Gpu :(
  3. Jeremy

    Jeremy Member

    Messages:
    34
    Likes Received:
    18
    Trophy Points:
    8
    Almost all laptops have the integrated Graphics cards, chances are he does. Did you do my fix for it?
    enesdikme likes this.
  4. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    I was just gonna try it :)
  5. Jeremy

    Jeremy Member

    Messages:
    34
    Likes Received:
    18
    Trophy Points:
    8
    Any luck?
    enesdikme likes this.
  6. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    I think I did something wrong ; I can't edit it properly . :(
  7. Jeremy

    Jeremy Member

    Messages:
    34
    Likes Received:
    18
    Trophy Points:
    8
    Mmm, more details please? What did it do or say?
    enesdikme likes this.
  8. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
  9. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Ok , I 'll give more details , thank you for dealing with my problem :)
    Just one last try ...
  10. Jeremy

    Jeremy Member

    Messages:
    34
    Likes Received:
    18
    Trophy Points:
    8
    It basically says make sure your system is compatible with that driver, in some cases like you said the integrated needs turned off. But what I said is a work around that should work.
    enesdikme likes this.
  11. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Well I think I typed the command wrong :( And also I think It might be about nouveau or gdm3 startup ; I mean , I wrote a command while I was installing nivida , like 'stop gdm3 ' I think I haven't start it up :) It might be ? :)
    Jeremy likes this.
  12. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
  13. Jeremy

    Jeremy Member

    Messages:
    34
    Likes Received:
    18
    Trophy Points:
    8
    Try starting gdm3.. lol
    enesdikme likes this.
  14. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    :) :D
  15. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,341
    Likes Received:
    447
    Trophy Points:
    83
    Jeremy and enesdikme like this.
  16. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3
    Well, according to this , Can I make my Nvidia work on Kali Linux ? Or Won't I be able to disable my integrated Intel HD Graphics , ryanvade ?

    I did a proper installation , paid attention in every instruction here
    < http://docs.kali.org/general-use/install-nvidia-drivers-on-kali-linux >

    While I was installing the driver , program asked me a couple of questions ( 3 I guess ) I typed 'Yes' them all . And it asked me if I wanted 32-bit libraries. on my 64 -bit system , and I typed Yes to this , too . I am nearly sure I did this installation with complete successful though.

    Then , it said on the document , type reboot , then I typed reboot .
    I chose Kali from GRUB as always , but there was a blank screen with a cursor instead of GUI .

    ctrl+alt+F1 and after login , I should type in something to make things better , or to be able to use Nvidia , what would you suggest me to type in ?

    Still afraid if I do something wrong , Still can't get into my Desktop :(
  17. ryanvade

    ryanvade Administrator Staff Member Staff Writer

    Messages:
    1,341
    Likes Received:
    447
    Trophy Points:
    83
    Using Bumblebee and the Nvidia drivers from Nvidia.com is not recommended. For debian, using the X-swats or X-edgers PPA is a good idea. So, follow my article as much as possible. Using Ubuntu as a guide, Ubuntu is based on Debian.

    Basically, undo what you did, use the Intel graphics and install Bumblebee. Then only use the Nvidia card when you need to. That is how the laptop is designed. The integrated Intel card is designed to be used more than the Nvidia card.
    enesdikme likes this.
  18. Cristal Skull

    Cristal Skull Member

    Messages:
    44
    Likes Received:
    23
    Trophy Points:
    8
    enesdikme likes this.
  19. enesdikme

    enesdikme New Member

    Messages:
    26
    Likes Received:
    2
    Trophy Points:
    3

    Well, I am really confused now :confused: :D

    Still I haven't been able to touch anything on Kali . What should I do ?
  20. Cristal Skull

    Cristal Skull Member

    Messages:
    44
    Likes Received:
    23
    Trophy Points:
    8
    enesdikme likes this.
  21. Chas Henry

    Chas Henry New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Jeremy,

    I have been following this discussion because I also have the "black screen" problem. I entered the following command: mv /etc/x11/xorg.conf /etc/x11/xorg.conf.blah resulting in the following response: "mv: cannot stat mv /etc/x11/xorg.conf : No such file or directory". Start X resulted in : "-bash: start: command not found."

    I am at root@kali
    running on VB.

    I am running 64 bit and have ATI radeon HD 4550 graphics card

    Any ideas?
    Last edited: Sep 21, 2013

Share This Page