yum update failing

ashintoms

New Member
trying a yum update and its not happening.
I've tried pretty much everything i could.
Can someone tell me what to do to fix this one ?

yum list libgpg-error --noplugins --showdupli
Installed Packages
libgpg-error.i686 1.12-3.el7 @rhel-7-desktop-rpms
libgpg-error.x86_64 1.12-3.el7 @anaconda/7.6
Available Packages
libgpg-error.i686 1.12-3.el7 rhel-7-desktop-rpms
libgpg-error.x86_64 1.12-3.el7 rhel-7-desktop-rpms
[[email protected] thomasa]#


[email protected] thomasa]# yum update -y
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check

---> Package selinux-policy.noarch 0:3.13.1-229.el7_6.9 will be erased
--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for java-1.8.0-openjdk-headless which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of java-1.8.0-openjdk-headless of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude java-1.8.0-openjdk-headless.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of java-1.8.0-openjdk-headless installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of java-1.8.0-openjdk-headless installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: 1:java-1.8.0-openjdk-headless-1.8.0.212.b04-0.el7_6.i686 != 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-2.el7_6.x86_64



[email protected] thomasa]# yum repolist
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id repo name status
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 13,283
google-chrome google-chrome 3
packages-microsoft-com-prod packages-microsoft-com-prod 338
playonlinux PlayOnLinux Official repository 53
rhel-7-desktop-rpms/7Client/x86_64 Red Hat Enterprise Linux 7 Desktop (RPMs) 19,626
rpmfusion-free-updates/x86_64 RPM Fusion for EL 7 - Free - Updates 247
rpmfusion-nonfree-updates/x86_64 RPM Fusion for EL 7 - Nonfree - Updates 75
skype-stable skype (stable) 5
sublime-text Sublime Text - x86_64 - Stable 2
veeam Veeam Backup for GNU/Linux - x86_64 23
repolist: 33,655
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day @ashintoms and welcome to linux.org :)

1. Are you using RHEL 7 and do you have current support?

2. I would be inclined to install dnf and use it over yum, which is being deprecated.

3. A Google search under

"rhel 7" install dnf

will assist.

That being said, I do not know a lot about Red Hat, so I am moving this Thread to where you will get more qualified help.

Good Luck

Chris Turner
wizardfromoz
 

dos2unix

Member
It looks like you have conflicts with i686 and x86_64 (32bit and 64bit)
dnf only works on Fedora and Redhat 8, not redhat 7.

Since you have rpmfusion installed, I am assuming this is Fedora?

I would try uninstalling java-1.8.0-openjdk-headless (at least the i686 version)

Then re-install the x86_64 version only.
 

Members online

No members online now.

Top