wpa_supplicant can't be used to connect to mobile hotspots

WiseKind

Member
Joined
May 17, 2020
Messages
39
Reaction score
7
Credits
436
I have recently switched from using iwd to connect to wireless networks and am now using wpa_supplicant. However, I quickly noticed a problem, that for some reason, it's impossible to use wpa_supplicant to connect to a mobile hotspot. There are no problems connecting to other types of networks.

STDOUT from attempting to connect to a normal WiFi access point
Code:
> enable_network 1
OK
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with ee:ee:ee:ee:ee:ee (SSID='Normal Network' freq=5765 MHz)
<3>Trying to associate with ee:ee:ee:ee:ee:ee (SSID='Normal Network' freq=5765 MHz)
<3>Associated with ee:ee:ee:ee:ee:ee
<3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
<3>WPA: Key negotiation completed with ee:ee:ee:ee:ee:ee [PTK=CCMP GTK=CCMP]
<3>CTRL-EVENT-CONNECTED - Connection to ee:ee:ee:ee:ee:ee completed [id=1 id_str=]
<3>CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-49 noise=9999 txrate=6000
<3>CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-48 noise=9999 txrate=433300
<3>CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-48 noise=9999 txrate=433300
<3>CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-49 noise=9999 txrate=433300
>
STDOUT from attempting to connect to a mobile hotspot
Code:
> disable_network 1
OK
> add_network
2
> scan_results
bssid / frequency / signal level / flags / ssid
ee:ee:ee:ee:ee:ee       5765    -49     [WPA2-PSK-CCMP][WPS][ESS]       Normal Network
bb:bb:bb:bb:bb:bb       5765    -59     [WPA2-PSK-CCMP][ESS]    Mobile Hotspot
> set_network 2 ssid "Mobile Hotspot"
OK
> password 2 "password"
OK
> list_networks
network id / ssid / bssid / flags
0       Some random normal network     any
1       Normal Network     any     [DISABLED]
2       Mobile Hotspot   any     [DISABLED]
> enable_network 2
OK
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
>

Unfortunately, I can't really find documentation on what error messages like <3>CTRL-EVENT-NETWORK-NOT-FOUND actually mean. This problem may be caused by me not having enough knowledge on wpa_supplicant and wpa_cli.
 


OP
W

WiseKind

Member
Joined
May 17, 2020
Messages
39
Reaction score
7
Credits
436
Hello. I am on Arch Linux, and I am only using command-line tools (wpa_cli) to interface with wpa_supplicant. Can you find where this option is in a config file or something?
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,463
Reaction score
3,169
Credits
32,384
Not try it but according to the archwiki this should work.
Tip: To configure a network block to a hidden wireless SSID, which by definition will not turn up in a regular scan, the option scan_ssid=1 has to be defined in the network block.
 
OP
W

WiseKind

Member
Joined
May 17, 2020
Messages
39
Reaction score
7
Credits
436
I thought I was talking about mobile hotspots, not hidden networks, but surprisingly adding scan_ssid=1 to the config file for the mobile hotspot's information actually allowed me to connect to the network. Do you know how to enable scan_ssid using wpa_cli instead of editing it in the config file?
 
OP
W

WiseKind

Member
Joined
May 17, 2020
Messages
39
Reaction score
7
Credits
436
Not try it but according to the archwiki this should work.

I thought I was talking about mobile hotspots, not hidden networks, but surprisingly adding scan_ssid=1 to the config file for the mobile hotspot's information actually allowed me to connect to the network. Do you know how to enable scan_ssid using wpa_cli instead of editing it in the config file? I don't need to know this, but it would make my life easier.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top