Wifi requires username

theprob

New Member
Credits
38
Hello, so I have installed Ubuntu on my dad's laptop, since windows was slow, he only wants it for internet browsing.
He works abroad and I can't really try many things so I'm asking for (hopefully) simple advice.

problem: when he wants to connect to the wifi he has where he lives, it requires a username AND password - and he has no username, he didnt need any when he tried to connect via android or windows. I told him to try different settings, to change the wpa2 enterprise (? or business not sure) for personal, but even when he got rid of the username option it won't connect him to the internet.

thanks
 


Condobloke

Well-Known Member
Credits
5,108
G'day theprob (not the solution ?)....and Welcome to linux.org

AS we are not sure of the exact situatiion there, a few details would be good.

Is the wifi supplied by an ISP (internet service provider)...or other ?

If the username and password is being asked for by the wifi provider (ISP) then this should be provided to your dad by the ISP

On the other hand, if the username and password is being asked for by Ubuntu, then he can make his own username and also his own password. MAKE SURE HE WRITES THEM DOWN.
 

theprob

New Member
Credits
38
Hey, thanks for the reply.
Well, it is being asked by the ubuntu network settings (like the one at the picture)
I know he tried some random usernames but it didn't work.
1603313881288.png

Like is it possible that different OS requires different data? as I have mentioned, he is connected to the wifi on his phone without the username and it works
 

Condobloke

Well-Known Member
Credits
5,108

Condobloke

Well-Known Member
Credits
5,108
Just an afterthought....take the laptop close to the router/modem, and connect it directly via an ethernet cable. Hopefully that wil tell Ubuntu what it needs to know.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
7,721
If you click on Security you should get a drop down menu, select WPA & WPA2 Personal instead. Then you have to only enter a password for the wifi you are trying to connect to. Enterprise is more for more complicated setups with your connection being encrypted and validated by using certificates and other advanced features for Enterprise configurations.

**edit**
So it seems you already tried WPA & WPA2 Personal which I missed. Can you try connecting to the wifi with the Personal option again. What exactly happens then? Does it say it's connected but then you are unable to access the internet or does it refuse to connect to the wifi as well? Just for your understanding wifi is a local network which then gets translated to the ip adress your ISP assigned to your router, then from there your router is routed to your ISP's network and from there to the Internet. You can be connected to your wifi and still not have internet access.
 
Last edited:

theprob

New Member
Credits
38
Just an afterthought....take the laptop close to the router/modem, and connect it directly via an ethernet cable. Hopefully that wil tell Ubuntu what it needs to know.
yeah the ehternet cable was like the first thing that came to my mind, thankfully he has one so he tried but it didn't work

If you click on Security you should get a drop down menu, select WPA & WPA2 Personal instead. Then you have to only enter a password for the wifi you are trying to connect to. Enterprise is more for more complicated setups with your connection being encrypted and validated by using certificates and other advanced features for Enterprise configurations.

**edit**
So it seems you already tried WPA & WPA2 Personal which I missed. Can you try connecting to the wifi with the Personal option again. What exactly happens then? Does it say it's connected but then you are unable to access the internet or does it refuse to connect to the wifi as well? Just for your understanding wifi is a local network which then gets translated to the ip adress your ISP assigned to your router, then from there your router is routed to your ISP's network and from there to the Internet. You can be connected to your wifi and still not have internet access.
so after changing the WPA&WPA 2 enterprise to personal and entering the password, then clicking on connect, nothing happens. It always just shows all the available networks.
 

Condobloke

Well-Known Member
Credits
5,108
Is one of the available networks the wifi your father pays for ?
 

theprob

New Member
Credits
38
Hello, I would like to say that theprob(haha)lem is solved!

Looks like one of the ethernet ports just wasn't working, switching it for a different one helped, so it has to be connected through the cable. I still don't understand what's wrong with the wifi, since it works on a phone and before I installed Ubuntu it worked on windows as well, but it works and that's important.
So thank you all for the advice :)
 


Staff online

Members online


Top