Wifi not working in latest ver 2020.3

slythno

New Member
Joined
Oct 6, 2020
Messages
1
Reaction score
0
Credits
26
rtlwifi-next-master rtlwifi-next-master.zip
[email protected]:/home/slythno/Downloads# cd rtlwifi-next-master
[email protected]:/home/slythno/Downloads/rtlwifi-next-master# ls
base.c debug.c LICENSE pwrseqcmd.h rtl8192ce rtl8723com wifi.h
base.h debug.h Makefile rc.c rtl8192cu rtl8821ae
btcoexist efuse.c pci.c rc.h rtl8192de rtl8822be
cam.c efuse.h pci.h regd.c rtl8192ee stats.c
cam.h firmware phydm regd.h rtl8192se stats.h
core.c halmac ps.c rtl8188ee rtl8723ae usb.c
core.h Kconfig ps.h rtl8192c rtl8723be usb.h
[email protected]:/home/slythno/Downloads/rtlwifi-next-master# make
make -C /lib/modules/5.8.0-kali2-amd64/build M=/home/slythno/Downloads/rtlwifi-next-master modules
make[1]: Entering directory '/usr/src/linux-headers-5.8.0-kali2-amd64'
CC [M] /home/slythno/Downloads/rtlwifi-next-master/rtl8192c/main.o
In file included from /home/slythno/Downloads/rtlwifi-next-master/rtl8192c/main.c:26:
/home/slythno/Downloads/rtlwifi-next-master/rtl8192c/../wifi.h:1664:2: error: unknown type name ‘__kernel_time_t’
1664 | __kernel_time_t last_suspend_sec;
| ^~~~~~~~~~~~~~~
make[4]: *** [/usr/src/linux-headers-5.8.0-kali2-common/scripts/Makefile.build:286: /home/slythno/Downloads/rtlwifi-next-master/rtl8192c/main.o] Error 1
make[3]: *** [/usr/src/linux-headers-5.8.0-kali2-common/scripts/Makefile.build:502: /home/slythno/Downloads/rtlwifi-next-master/rtl8192c] Error 2
make[2]: *** [/usr/src/linux-headers-5.8.0-kali2-common/Makefile:1764: /home/slythno/Downloads/rtlwifi-next-master] Error 2
make[1]: *** [/usr/src/linux-headers-5.8.0-kali2-common/Makefile:185: __sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.8.0-kali2-amd64'
make: *** [Makefile:100: all] Error 2

i hope you help me through this thanks
 


arochester

Moderator
Staff member
Gold Supporter
Joined
Apr 25, 2017
Messages
1,659
Reaction score
1,322
Credits
3,260
I don't recognise rtlwifi-next-master.

What is the output of
Code:
lspci |grep Network
and
Code:
lsusb

Have you tried installing firmware-realtek and rebooting?
 

Alter

New Member
Joined
Nov 8, 2020
Messages
5
Reaction score
0
Credits
38
oie_wirCfZyfkZ5m (1).png

That's my output for those commands.
@arochester can you help me please?
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top