WiFi help

Good thinking, 99 ... sweet.

Your inxi output at #10 indicates you are currently on Linux kernel 4.15.0-20

You also said in your first Post that you had run updates, were they successfully completed?

First I'll show you my output from inxi - nz (the z option filters out your MAC addresses, for privacy)

Code:
[email protected]:~$ inxi -nz
Network:   Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           driver: ath10k_pci
           IF: wlp3s0 state: up mac: <filter>
           Card-3: Atheros
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
I have Realtek on the Ethernet, but Qualcomm on the WiFi. Some of the Realtek wifi drivers can be problematic, your rtl8723be included, so it seems.

This may be most easily remedied by a Kernel substitution, as a workaround.

So put on your pith helmet, have your elephant gun handy, and do an exercise for us.

Reboot your computer, and when the grub menu comes up (you will usually have 5 - 10 seconds to choose, 10 in Mint), choose the 2nd entry if it says Advanced Options or Recovery, and enter.

There may be one or more lines there, you can either write them down or take a good phone picture and upload it to us.

I am using 'Tara' 19 and you 'Tessa' 19.1 but they should be similar. I'm off to check something and then I'll add a BTW (by the way) at bottom.

Cheers

Wiz

BTW - so I am currently running kernel 4.15.0-42 , but in that Advanced Options page I also have older entries such as 4.15.0-38 and 4.15.0-39. It is any entries that do not say "Recovery" that we may focus on.
So I'm at work and it's funny but I can use my phone as a hotspot and it works perfect
 

Attachments



wizardfromoz

Super Moderator
Staff member
Gold Supporter
So I'm at work and it's funny but I can use my phone as a hotspot and it works perfect
Yes, that does not really surprise me, given what we are unravelling :)

Thanks for those pix, the one I was keen to see was the Advanced Options one that features Linux kernel 4.15.0-20 only. You haven't answered yet about the updates.

Do you have Ethernet at home, to run the updates, or have you done so?

Linux kernel 4.15.0-20 is apparently the one 'Tessa' ships with, I put on the MATE edition last night and found similarly.

There is a newer version available, as you can see here.




SCREENSHOT 1 - WIZARD'S 'TESSA' MATE UPDATES PENDING

It is possible that if you update to the newer kernel, the wifi will work.

I have to go out for a couple of hours but I'll be back with more.

Cheers

Wizard

Thanks for your help
Always welcome, it's what we do here :D

I want to look into those classes for Linux.
I can recommend at least one.
 
Yes, that does not really surprise me, given what we are unravelling :)

Thanks for those pix, the one I was keen to see was the Advanced Options one that features Linux kernel 4.15.0-20 only. You haven't answered yet about the updates.

Do you have Ethernet at home, to run the updates, or have you done so?

Linux kernel 4.15.0-20 is apparently the one 'Tessa' ships with, I put on the MATE edition last night and found similarly.

There is a newer version available, as you can see here.




SCREENSHOT 1 - WIZARD'S 'TESSA' MATE UPDATES PENDING

It is possible that if you update to the newer kernel, the wifi will work.

I have to go out for a couple of hours but I'll be back with more.

Cheers

Wizard



Always welcome, it's what we do here :D



I can recommend at least one.
I thought I did but I will verify. Some of them didn't update.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
So don't keep us in suspense :Do_O:rolleyes:

What's the status on the wifi?

Cheers

Chris
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Damn' shame, that :(

On your Ethernet, try this:

Code:
wget https://github.com/lwfinger/rtlwifi_new/blob/master/firmware/rtlwifi/rtl8723befw.bin
If that is successful, then

Code:
sudo cp rtl8723befw.bin /lib/firmware/
Reboot.

Report back.

Cheers

Chris
 
Damn' shame, that :(

On your Ethernet, try this:

Code:
wget https://github.com/lwfinger/rtlwifi_new/blob/master/firmware/rtlwifi/rtl8723befw.bin
If that is successful, then

Code:
sudo cp rtl8723befw.bin /lib/firmware/
Reboot.

Report back.

Cheers

Chris
I connected to my WiFi and then I turned it off. I have been out of town for a bit. My next couple of questions, what now. You think it's good now? Also is there a way I can have it boot up before window or going into the boot menu and booting from my USB?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Hang on a sec, let's back it up a little bit.

Are you saying that that command line exercise worked, and that the wifi is working now?

Wiz
 
Hang on a sec, let's back it up a little bit.

Are you saying that that command line exercise worked, and that the wifi is working now?

Wiz
I'm going to verify tomorrow but I unplugged the Ethernet after I did the reboot. It took only a moment and it connected to my network
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter


If it sustains a couple of warm boots and a couple of cold boots, you should be good to go on with.

My next couple of questions, what now. You think it's good now? Also is there a way I can have it boot up before window or going into the boot menu and booting from my USB?
If the wifi is good and you'll bear with me a little longer, I'd like to lock into place a snapshot of your system, so that if anything goes wrong in future, you can roll back to a working environment.

You have a utility in place already, on your Linux Mint 19.1 that can do that, and that is Timeshift. You may have already seen a reference to it if you ran your updates from Update Manager, which looks like this when up-to-date.




It might have had a "nag" message about setting up scheduled snapshots.

If you haven't come across it, you can read about it at my Tutorial HERE, or else Linux Distro Linux Lite have a good little guide HERE.

Cheers

Wizard
 
Just ried to boot up this morning and everything was good but I couldn't connect to my network. I honestly thought you fixed it.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Yeah, I guess it was too early to break out the champagne :(. We are making ground, though, and I thank you for your patience.

I'll send out a ping to @JasKinasis and @Lazydog and any others whom know more about wifi than I (which is many) and hope they have some good value.

Chris, in your menu is Synaptic Package Manager, we may be making use of that to see if some packages are installed or not.

Meantime, can you give me the output of

Code:
apt-cache policy network-manager
?

Mine looks like this

Code:
[email protected]:~$ apt-cache policy network-manager
network-manager:
  Installed: 1.10.6-2ubuntu1.1
  Candidate: 1.10.6-2ubuntu1.1
  Version table:
 *** 1.10.6-2ubuntu1.1 500
        500 http://mirror.as24220.net/pub/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.10.6-2ubuntu1 500
        500 http://mirror.as24220.net/pub/ubuntu bionic/main amd64 Packages
The 500 means it is installable, the 100 means it is installed.

Wizard
 
Yeah, I guess it was too early to break out the champagne :(. We are making ground, though, and I thank you for your patience.

I'll send out a ping to @JasKinasis and @Lazydog and any others whom know more about wifi than I (which is many) and hope they have some good value.

Chris, in your menu is Synaptic Package Manager, we may be making use of that to see if some packages are installed or not.

Meantime, can you give me the output of

Code:
apt-cache policy network-manager
?

Mine looks like this

Code:
[email protected]:~$ apt-cache policy network-manager
network-manager:
  Installed: 1.10.6-2ubuntu1.1
  Candidate: 1.10.6-2ubuntu1.1
  Version table:
 *** 1.10.6-2ubuntu1.1 500
        500 http://mirror.as24220.net/pub/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.10.6-2ubuntu1 500
        500 http://mirror.as24220.net/pub/ubuntu bionic/main amd64 Packages
The 500 means it is installable, the 100 means it is installed.

Wizard
Working on it now.
Yeah, I guess it was too early to break out the champagne :(. We are making ground, though, and I thank you for your patience.

I'll send out a ping to @JasKinasis and @Lazydog and any others whom know more about wifi than I (which is many) and hope they have some good value.

Chris, in your menu is Synaptic Package Manager, we may be making use of that to see if some packages are installed or not.

Meantime, can you give me the output of

Code:
apt-cache policy network-manager
?

Mine looks like this

Code:
[email protected]:~$ apt-cache policy network-manager
network-manager:
  Installed: 1.10.6-2ubuntu1.1
  Candidate: 1.10.6-2ubuntu1.1
  Version table:
 *** 1.10.6-2ubuntu1.1 500
        500 http://mirror.as24220.net/pub/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.10.6-2ubuntu1 500
        500 http://mirror.as24220.net/pub/ubuntu bionic/main amd64 Packages
The 500 means it is installable, the 100 means it is installed.

Wizard[/
This is what I got
 

Attachments

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Thanks for that, now might be a good time to make the acquaintance of

Code:
nano
Nano is a command-line Text Editor a number of us use (there are others). Have a read through this Post before trying this.

At Terminal, you will be issuing the following command (when I place a # it is me making a comment, not a command to type)

Code:
sudo nano /etc/NetworkManager/NetworkManager.conf

#note the capital N and M
You may get something like this




Navigation is by your direction keys, up down, left,right

Change "false" to "true" like so





Saving and exiting is performed as follows - the little "carets" (^) at bottom represent the Ctrl key. So ^X (small x will do) leads to





... and then it is capital Y to save, which leads to





At this point, if you wished to employ a "Save As" action on a file, you could change the name, but we won't, and so it is just Enter and will leave the nano shell and be back in Terminal.


Finally, unplug your Ethernet and enter the following

Code:
sudo /etc/init.d/network-manager restart

#note lowercase letters and the dash (hyphen)
See how you go

Wiz
 
Thanks for that, now might be a good time to make the acquaintance of

Code:
nano
Nano is a command-line Text Editor a number of us use (there are others). Have a read through this Post before trying this.

At Terminal, you will be issuing the following command (when I place a # it is me making a comment, not a command to type)

Code:
sudo nano /etc/NetworkManager/NetworkManager.conf

#note the capital N and M
You may get something like this




Navigation is by your direction keys, up down, left,right

Change "false" to "true" like so





Saving and exiting is performed as follows - the little "carets" (^) at bottom represent the Ctrl key. So ^X (small x will do) leads to





... and then it is capital Y to save, which leads to





At this point, if you wished to employ a "Save As" action on a file, you could change the name, but we won't, and so it is just Enter and will leave the nano shell and be back in Terminal.


Finally, unplug your Ethernet and enter the following

Code:
sudo /etc/init.d/network-manager restart

#note lowercase letters and the dash (hyphen)
See how you go

Wiz
It didn't work. Should I start over from scratch?
 

Attachments

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Are you familiar with Murphy's Law? Basically, it says, what can go wrong, will go wrong :)

From all the research I have done over the last week, it seems that the rtl8723be card/driver is one of the most "problematic" with LInux. And a User such as yourself cannot be expected to know that when they try to take up Linux.

I can see one further option at the moment, and that is -

at #35 above you had the pic of the kernels screen from Update Manager, at the top is kernel 4.18.0 -13, this is a short-term kernel supported until August 2019.

If you click the line it is on, you will get a choice to install.

Install it, reboot and report back.

If that doesn't work, you may have to try another Distro (using Live USB sticks to see that wifi is working), or consider replacing the wifi card - I know, a PITA:(

Cheers

Wizard
 
Are you familiar with Murphy's Law? Basically, it says, what can go wrong, will go wrong :)

From all the research I have done over the last week, it seems that the rtl8723be card/driver is one of the most "problematic" with LInux. And a User such as yourself cannot be expected to know that when they try to take up Linux.

I can see one further option at the moment, and that is -

at #35 above you had the pic of the kernels screen from Update Manager, at the top is kernel 4.18.0 -13, this is a short-term kernel supported until August 2019.

If you click the line it is on, you will get a choice to install.

Install it, reboot and report back.

If that doesn't work, you may have to try another Distro (using Live USB sticks to see that wifi is working), or consider replacing the wifi card - I know, a PITA:(

Cheers

Wizard
Line 35 on using the update manager?
 

Members online

No members online now.

Latest posts

Top