• Important: We recently upgraded our forum software - please let us know if you run into any issues.

WiFi help

Just instaleei linix mint. Love it but couldn't get the wifi to connected. I plugged Ethernet to it and I ioendriver manger to do updates. I unplugged the Ethernet and it worked. I then turned on the laptop the next day and I couldn't connect to my network.
 


Peer

Active Member
You can mark the text in the terminal and post it here.
You don't have to take a picture of your screen.
 

Peer

Active Member
You have a Realtek RTL8723BE wifi-card and it looks like you have some drivers installed (RTL8723BE) but htey don't work.
I'll watch out for more tomorow. :)
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I like that link, Peer :)

Chris, this is just a holding Post for now, back on deck tomorrow.

Can you go into your BIOS setup and if Secure Boot is on, disable it and reboot and let us know any changes?

Welcome, too to linux.org and Season's Best

Chris Turner
wizardfromoz
(Wizard disappears in a puff of smoke, off to eat more food and expand his waistline)
 
I like that link, Peer :)

Chris, this is just a holding Post for now, back on deck tomorrow.

Can you go into your BIOS setup and if Secure Boot is on, disable it and reboot and let us know any changes?

Welcome, too to linux.org and Season's Best

Chris Turner
wizardfromoz
(Wizard disappears in a puff of smoke, off to eat more food and expand his waistline)
Thanks guys and merry Christmas. I'm going to keep at it. That link you showed me Peer. I could only do the first step .
I like that link, Peer :)

Chris, this is just a holding Post for now, back on deck tomorrow.

Can you go into your BIOS setup and if Secure Boot is on, disable it and reboot and let us know any changes?

Welcome, too to linux.org and Season's Best

Chris Turner
wizardfromoz
(Wizard disappears in a puff of smoke, off to eat more food and expand his waistline)
Thank you guys for your help and Happy Christmas. Its irritating because i want to learn and fix everything myself but I'm so lost. I tried to disable the secure boot. When i did the save changes it took me to a black screen to where I had to type the code and I rebooted. After that linux mint didn't come up. I had to boot from my usb using the boot menu. Also I went back to the BIOS and looked to see about the secure boot and it was enabled. lol. Now, I get wifi access in and out. I did this command the commands to show you guys:

upload_2018-12-26_11-50-18.png


upload_2018-12-26_11-52-58.png


right here, i only got to the past the first step and then I was kind of lost. lol...I'm afraid I'm hopless.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
lol...I'm afraid I'm hopless.
You should have seen me 5 years ago :D

Its irritating because i want to learn and fix everything myself...
That's a good ambition (& one I embraced) as long as you don't set your sights too high or you will be disappointed, we all need help from time to time.

Morning, Chris, Morning all :)

Chris do I take it you have your "Mintie" dualbooting with a Windows, and if so, which?

If so, you will have a Grub Menu at startup, a black and white screen with Mint on top, then a line about Advanced Options, then a line with Windows Boot Manager that takes you into Windows. Is that the case?

Wiz
 
You should have seen me 5 years ago :D



That's a good ambition (& one I embraced) as long as you don't set your sights too high or you will be disappointed, we all need help from time to time.

Morning, Chris, Morning all :)

Chris do I take it you have your "Mintie" dualbooting with a Windows, and if so, which?

If so, you will have a Grub Menu at startup, a black and white screen with Mint on top, then a line about Advanced Options, then a line with Windows Boot Manager that takes you into Windows. Is that the case?

Wiz
Yes that's correct. I didn't want to wipe windows completely until I was confident with Linux.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Good thinking, 99 ... sweet.

Your inxi output at #10 indicates you are currently on Linux kernel 4.15.0-20

You also said in your first Post that you had run updates, were they successfully completed?

First I'll show you my output from inxi - nz (the z option filters out your MAC addresses, for privacy)

Code:
[email protected]:~$ inxi -nz
Network:   Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           driver: ath10k_pci
           IF: wlp3s0 state: up mac: <filter>
           Card-3: Atheros
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
I have Realtek on the Ethernet, but Qualcomm on the WiFi. Some of the Realtek wifi drivers can be problematic, your rtl8723be included, so it seems.

This may be most easily remedied by a Kernel substitution, as a workaround.

So put on your pith helmet, have your elephant gun handy, and do an exercise for us.

Reboot your computer, and when the grub menu comes up (you will usually have 5 - 10 seconds to choose, 10 in Mint), choose the 2nd entry if it says Advanced Options or Recovery, and enter.

There may be one or more lines there, you can either write them down or take a good phone picture and upload it to us.

I am using 'Tara' 19 and you 'Tessa' 19.1 but they should be similar. I'm off to check something and then I'll add a BTW (by the way) at bottom.

Cheers

Wiz

BTW - so I am currently running kernel 4.15.0-42 , but in that Advanced Options page I also have older entries such as 4.15.0-38 and 4.15.0-39. It is any entries that do not say "Recovery" that we may focus on.
 
Last edited:

Members online


Top