Wifi, ethernet connected, but no internet.

ounest

New Member
Joined
Sep 21, 2021
Messages
3
Reaction score
0
Credits
25
Hey! I have a problem with my Ubuntu system. Wifi and ethernet is connected, when I type iwconfig command it displays but the internetdoes not work. Everything worked before. Iknow it's the system's fault, because on theother system (Windows) (dualboot) everythingworks without a problem. This is the secondtimethis has happened, the previous timereinstalling the system helped, but I don't wantto do that again. I searchedthe internet to find asolution, but nothing worked. Please help.
 


deodhar

New Member
Joined
Sep 19, 2021
Messages
13
Reaction score
2
Credits
96
@ounest
what does "ifconfig" show?
It should tell which wired & wireless connections are UP/DOWN/RUNNING, etc.
 

brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,228
Reaction score
946
Credits
9,290
have you done any updates recently ?
in terminal run inxi -fnxz copy and past the whole network section
 
OP
O

ounest

New Member
Joined
Sep 21, 2021
Messages
3
Reaction score
0
Credits
25
Something tempted me to turn on the VPN. From that point on internet started working normally. Why is this happening?
 

Sunil1991

New Member
Joined
Jul 27, 2021
Messages
10
Reaction score
4
Credits
66
Something tempted me to turn on the VPN. From that point on internet started working normally. Why is this happening?
It will happen, if you have connected to VPN and network and your PC turn off due to power failure..


Issue is related to DNS server so internet will stop working untill you connect to VPN network again (this may overwrite the DNS server)

I also faced internet problem when my PC turn off due to power failure when connected to my office VPN network

Just connecting to VPN again will resolve internet problem
 

Sunil1991

New Member
Joined
Jul 27, 2021
Messages
10
Reaction score
4
Credits
66

This can be used for Internet not working issue
 

brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,228
Reaction score
946
Credits
9,290
you may not have the correct drivers loaded.. thats why i asked you to run inxi
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top