Why don't enterprise versions of linux support docker?

LearningTechAndDev

New Member
Joined
Sep 25, 2023
Messages
9
Reaction score
0
Credits
174
I'm looking for insight into something I've noticed. I was told that Docker is very popular. So I built some software that uses Docker as the container system and Docker Swarm as the orchestration system. Ive been using Ubuntu Server LTS on x86 architecture machines and everything works great.

One day, a client asked me to pick an "enterprise" edition of linux and then make my software work on it.

To my surprise, all the enterprise editions of linux that I'm aware of (which are RHEL, SUSE, Oracle Linux) did not support docker on x86 architecture. Instead, all the enterprise editions of linux only suport docker on s390x architecture which is some kind of IBM technology. I think enterprise editions of linux use other container systems over docker.
Why don't enterprise editions of linux like docker on x86 architecture?
 


Podman has taken over as the default container application on RHEL based systems,
as of about 2 years ago. You can still get docker-ce through the normal EPEL channels.

 
Hmm... You should be able to install Docker on RHEL by using the method for CentOS. Have you tried that?
 
At least for the IBM s390x mainframe :)
Are they still making those?

Unless I'm mistaken (and I could easily be mistaken) the CentOS version runs on the usual architectures.


And, yeah, those were still in production last I knew. The mainframe still exists - though it isn't quite what it used to be, such as needing a timeshare to access it for a certain amount of time.

Man, those were the days!

(I say that sort of in jest, the school I went to had access to the mainframe at Dartmouth, but I only used it a few times. At the time, I had no appreciation for computers.)
 

Members online


Top