Why do some effects work in Kubuntu and some do not?

Soundsystem00

New Member
I have all of my Nvidia drivers working and have a top of the line Msi laptop nearly maxed out. The wobbly windows and cube desktop switcher work but the minimization effects and maximization effects do not work. It doesn't even do the simple fade anymore that kubuntu does. This makes no sense and these strange little things are the reason why I always give up on linux. This time I do not want to thought because I am extremely sick of privacy violations on windows and mac.

Okay so how do I do this and what is wrong?

Thanks in advance and for everyone's previous help. I am determined to get better at this OS!
 


JasKinasis

Well-Known Member
It's been a long while since I used KDE, but generally speaking - from what I remember - if a particular effect doesn't work for you - sometimes it means that it uses some functionality that is not available to your graphics card.... But if you have the wobbly windows and cube working - simple things like the minimise and maximise transitions should work.

If you're getting desktop notifications that particular effects will no longer work - this might help:

[EDIT]
NOTE: The above link involves moving/renaming your existing kwinrc file and restarting kwin - which will have the effect of completely resetting all of your customisations - so if it does work and those animations start working again - you'll have to re-apply all of the customisations you made.

But make sure you keep a copy of the original kwinrc in case this measure doesn't re-enable the effects that have stopped working. If it fails to work, restore the old kwinrc and restart kwin again to restore your previous settings.

Thought I'd better add that explanation/disclaimer!
[/EDIT]

Otherwise - in the advanced settings for the effects - have you tried using a different compositor type?
You used to have a choice of using things like xrender, openGL1.x, openGL2.x, openGL3.x etc. etc. as a back-end for the compositor.
If those options are still available - perhaps changing the advanced compositor settings to use a different version of GL, or a different compositing method will fix the issue?!

[EDIT]
I do remember doing an update once - a very long time ago which for some reason changed the KDE compositor settings to use a newer version of GL. My graphics card only supported a tiny sub-set of features from that version of GL and several of my effects stopped working - so I had to change the settings back to use an earlier version of GL. And that fixed things for me!
[/EDIT]

Other than that I don't have any other ideas off the top of my head!

As an aside:
these strange little things are the reason why I always give up on linux
Would a couple of missing desktop animations/effects really make you stop using Linux? If so, that seems a little fickle! You still have your wobbly windows and desktop cube animation. What more do you want?! Ha ha!

When you start using Linux based OSes, there are plenty of small annoyances and quirky things to put up with. But most of us see that as a small price to pay for our software/computing freedom.

If it annoys you and you can't fix it, or find a workaround for it - maybe switch to a different distro, or a different WM or DE.

But for something as minor as a missing minimise/maximise desktop effect - I'd just ignore it and carry on working. It shouldn't be a reason to stop using Linux.

But then, I've always hated all of these pointless desktop-effects. It always felt like they were slowing me and/or my system down - so back when I used KDE, I would just disable all of them!

Nowadays I use dwm - a minimalistic tiling window manager that is almost completely keyboard driven. No desktop icons, no floating windows, hardly any need to use a mouse, no graphical point and click menus. And most importantly no special effects!
It's not for everybody, but it suits me down to the ground! Ha ha!

And regardless of whether or not you manage to fix the minimise/maximise animations - I hope you do stick around. Linux is weird and annoying sometimes, but it's always worth it!
 
Last edited:

Nik-Ken-Bah

Active Member
I am determined to get better at this OS!
That's the spirit, G'day and welcome to the community
I'm a bit like you determined to ditch the OS's that have more back doors than a mouse living in a wheel of Swiss cheese.
As for your dilemma there are more competent people like @arochester , @atanere , @wizardfromoz and @Condobloke that may have a better idea than I do at the moment, but learning.
My thoughts are as follows.
Since you are nearly maxing out your laptop tells me that your also maxing out your ram and swap partition. From what I can gather the swap partition is used to take some of the load off the ram of the system. ( The more knowledgeable ones will tell me should that not be correct. )
So try increasing the size of your swap partition and see how that goes.
 



Staff online



Top