What is the correct way to replace inittab using systemd?

Trenix25

Member
Credits
408
# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp10s8: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:16:36:d1:aa:94 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 00:19:d2:23:09:a4 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.202/24 brd 192.168.0.255 scope global wlp3s0
valid_lft forever preferred_lft forever
#
 


dos2unix

Well-Known Member
Credits
1,057
: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 00:19:d2:23:09:a4 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.202/24 brd 192.168.0.255 scope global wlp3s0
So your Wifi card is recognized. It has an IP address.
You just need to connect to a access point.

Try this...
ifdown wlp3s0
(it's already down, but this will clear out some things)

ifconfig wlp3s0
(you probably won't see anything happen, but this turns on your wifi radio)

iwconfig wlp3s0 [essid name] [key/password]
where essid is the name of your wifi network, and you should know the password.
 

Trenix25

Member
Credits
408
-bash: iwlist: command not found
-bash: ifconfig: command not found
-bash: iwconfig: command not found

They really designed this netinst disc really well didn't they. It is supposed to contain everything a new user could need to get their computer connected to the Internet so they can download more stuff.

I ran ifdown and then ifup which fixed the File exists error. ip still says it's down. It looks like it can't see the broadcast from the wifi router. I checked the router. The 5 GHz wifi is running and the SSID name is correct. I'm using an open wifi connection on channel 40. Windows Vista could not connect with WPA2. Only two people in range of the signal, that I'm aware of, have the hardware to use the 5 GHz access point and both of us are already connecting on 2.4 GHz on channel 1, my tablet does anyway, not the laptop. The laptop was able to connect to the 5 GHz wifi access point when running Windows Vista, but it can't seem to connect when running Linux. Windows said it had a decent signal strength. I'm not sure what to try next. Can someone suggest a good USB wifi adapter, preferably a stick, that can use 2.4 and 5 GHz WPA2 PSK wifi with B/G/N/A/AC and costs <= US$50? I need something that has no known vulnerabilities and works with Linux.
 

Trenix25

Member
Credits
408
~ # cat /etc/network/interfaces
# This file describes the network interfaces on the system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
#
# Configure the local interface
#
allow-hotplug wlp3s0
iface wlp3s0 inet static
wireless-essid Matthews_5G_Wifi_nomap
wireless-keymode open
address 192.168.0.202
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 1.1.1.1 192.168.0.1
#
# EOF
~ #

The subdirectory /etc/network/interfaces.d/ is empty.
 

dos2unix

Well-Known Member
Credits
1,057
It's been a long time since I've used Debian. The fact that ip a shows your interface with an IP address tells me this isn't a linux problem. It may be that your system doesn't have all the network tools installed that you need for wifi to work. No iw tools seems to be a problem. If you don't have those, and you don't have networkManager, there's not much you can do. Many distro also need a wpa-supplicant package which you may not have.

I don't think buying a USB dongle will help you. Linux sees your card. It's an intel card, those are usually the most Linux-friendly ones.

I will say that while 5G is faster, it usually has a shorter range. I don't know how far you are from your wifi router. Does your router/modem has ethernet ports?

Perhaps you could connect it to the ethernet just long enough to download whatever packages you might be missing for wifi to work? Once the wifi is up, move it back.
 

Trenix25

Member
Credits
408
I downloaded the standard live system that includes nonfree stuff. It logged me in as "user" with a uid of 1000 so I can't do anything because I'm not root. What is the default root password for this installation disc? I tried to use su, but it didn't work. This one barely fit on my tablet. The others were too big to fit.

Screenshot_2020-05-27-17-43-35.png
 


Members online


Latest posts

Top