What is the correct way to replace inittab using systemd?


Aug 15, 2017
Reaction score
I am using the current version of Debian Linux. I installed with the netinst CD. I still can't get the network working so I can't finish the installation process. It looks like /etc/inittab is being phased out of Linux and is being replaced with systemd. What is the correct way to set all of this up using systemd instead of inittab and rc?

What is the make and model of your computer, or can you tell us the basic specs?
Can you input either
lspci |grep Network
Can you tell us what your sources list says?
Are you saying that you don't have access to Ethernet?
Last edited:
ifup is demanding access to a firmware package named iwlwifi-3945-2.ucode before it can turn on the built-in wifi adapter. The problem is, it cannot be connected to any kind of network without it and it can't be installed without a network connection thus making the installation process impossible.

It is a Toshiba Satellite P105-S6187 laptop computer. (PSPAAU-01L00S)

It is rather old. It uses an Intel Centrino Duo CPU with an x86 type instruction set.

It is also demanding a firmware package called iwlwifi-3945-1.ucode.

The wifi adapter, so it would seem, cannot use PSK. It is identifying as wlp3s0.
Here's a picture of the information you have requested.


  • P_20200524_214014_HDR.jpg
    1.3 MB · Views: 458
The sources.list file is kind of a moot point at the moment since the computer cannot connect to a network.
You need: firmware-iwlwifi

1) How did you obtain the netinstall disk?
2) Can you connect the laptop temporarily to Ethernet?
3) Your sources list needs to be changed to include: contrib non-free
4) You can download firmware-iwlifi and put it on a USB stick. Use another computer or get a friend to do it?
5) Some people tether their smartphone temporarily to their computer to make it work.
6) You could have used https://cdimage.debian.org/images/unofficial/non-free/images-including-firmware/ - which as it says includes firmware i.e. firmware-iwlwifi
7) Possibly use a LiveCD to download the firware?
I had to have a friend download the netinst CD to his phone along with a web server app so I could get it from there. The browser in Windows Vista wouldn't let me go to debian.org saying it was either down or didn't exist. Perhaps Microsoft doesn't want people switching to Linux. I will have to reboot to Windows to get anything. I will have to download the firmware with my tablet, copy it to Windows, and then write a new DVD for just that one file, and then copy it while in Linux.

I plan to buy a new wifi adapter that can connect to a USB port on the laptop. Can you suggest one that does not have any known vulnerabilities, works with Linux without having to download and install any such special drivers, offers 2.4 and 5 GHz, and offers B, G, N / N, A, and AC along with a connection speed of 72+ Mbps? Being able to control the RF output power would be nice too. The signal doesn't have to go very far and I don't want to run any more RF power than necessary. I want to minimize my exposure along with any likelihood of interference to other users. The laptop also has a 10Base-T connection that might be able to be used to plug into a wifi device, provided that does not require downloading and installing any such special firmware. I'd be looking for something priced at less than US$50.

Is there anything else I might need that I can add to the next DVD that I write? I have a limited number of discs available.
After fighting for each and every step I finally got the wifi firmware package installed. There went another blank disc. I still can't use the wifi.

# ifup -v --force wlp3s0

ifup: configuring interface wlp3s0=wlp3s0 (inet)
/bin/run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
/sbin/ip addr add broadcast dev wlp3s0 label wlp3s0
RTNETLINK answers: File exists
ifup: failed to bring up wlp3s0

All of the subdirectories in /etc/network/ are empty.

Is it possible to use the label eth0 for wlp3s0? It would be easier to remember.
I don't have a USB thumb drive. I do plan on buying one or two of them. dpkg did put the required firmware file in /lib/firmware/ which is actually /usr/lib/firmware/ . I rebooted the system, but the problem persists.

Why are you in tty? Did you choose to go headless? Or did you install a Desktop Environment or Windows Manager? Why do you have to sign in as Root? The netinstall would have given you the opportunity to sign in with a Username and Password. Have you tried to sign in with that? What happens? If you have a Desktop Environment or Windows Manager what happens when you input: startx
Why are you in tty? Did you choose to go headless? Or did you install a Desktop Environment or Windows Manager? Why do you have to sign in as Root?

Some of us prefer to go around as headless zombies :)

Seriously though... on my workstations I install X (MATE or xfce usually).
But on my servers I never do. In fact most places I have worked don't allow it on servers.

g did put the required firmware file in /lib/firmware/ which is actually /usr/lib/firmware/ . I rebooted the system, but the problem persists.

Can you give output of ...
nmcli conn show


nmcli dev show
Why do you have to sign in as Root?

Another point of debate through the ages. Many distro don't have sudo enabled by default.
Many distro's have the root password enabled by default (virtually all SuSE, Redhat, CentOS, Fedora,
Oracle and Scientific distro at least).

I've been using Linux since 94. There was no sudo on many of those old distro's.
Now of course, the argument is always that it's easier to make a mistake if I'm logged in as root.
But is that true? What is the difference between me running a command as root, and me
sudo'ing a bunch of commands. (except I have to type in 4 more characters everytime if I sudo)
I can do everything in sudo, that I can do as root. How does sudo protect me?

I know that it is usual to run servers headless - but not everyone does. I was trying to ascertain what the OP has done...

I know that many distros don't have sudo by default - but the OP is using Debian and has signed in as Root. It is enough to sign in as normal user and then use su or su - to change to Root. Again I was trying to ascertain if the OP had a Username and Password.... and perhaps GUI...

I use Debian and I don't have Network-Manager or have nmcli by default...
I can't install anything else yet because I can't get the network to work. There's really nothing wrong with allowing root to log in or using root to install a system. I'm the only user and no one else has physical access to the console. I haven't set up user directories yet. I need to get the wifi working before I can install all of that stuff. What file is RTNETLINK finding that it is having such a problem with?
I prefer to use root for administrative tasks and another user account for other stuff.
To answer the other question, sudo sets the euid of the process to zero while leaving the rest alone. This makes it possible to detect the use of sudo.
Ok.. lets go the old fashioned way
how about...

ip addr

Members online