Wake UP!

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
I recently upgraded to Ubuntu 21.10 from 20.04 because I was having issues and thought it might help. The main problem was (and still is) that my Asus X510QA would not arouse from sleep. In each instance, whether after a period of inactivity or lid closure, only a reboot can get my system up and running again.

I've done some research and am leaning towards changing the kernel. Before I proceed and very possibly make things worse, can someone please guide me through the process?

Better yet, is there an easier, less risky fix?

Thanks for your help.
 


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,841
Reaction score
1,847
Credits
21,203
Welcome to the forums,
I set my dell lappy to never sleep and disabled snooze in the settings, I just find it a pain in the rear, and the OH would complain if I set it up for her to watch catchup TV it would turn off halfway through her programs as there was no keyboard activity
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
Welcome to the forums,
I set my dell lappy to never sleep and disabled snooze in the settings, I just find it a pain in the rear, and the OH would complain if I set it up for her to watch catchup TV it would turn off halfway through her programs as there was no keyboard activity
Thanks BW. I've already set a long delay before nap time and try to remember not to close the lid.

This helps but does not resolve the issue. I suspect this is only a symptom of a more serious issue. Other symptoms :

  1. Firefox crashing way too often.
  2. Fingerprint reader not working.
Digging around I've found there seems to be not solution for the fingerprint reader on Asus machines. Could it be that Linux developers just haven't quite figured out how to handle Asus?

Still wondering about the kernel.
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,134
Reaction score
950
Credits
8,116
Hello @dodobuntu,
Welcome to the Forum.
The Fingerprint reader problem has been around a long time and usually involves Hardware not supported by the available drivers. The following page may be of help with that.
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
Hello @dodobuntu,
Welcome to the Forum.
The Fingerprint reader problem has been around a long time and usually involves Hardware not supported by the available drivers. The following page may be of help with that.
Thanks. The article is a guide to the settings and does not mention drivers. The settings was the first thing I tried.

Just a friendly reminder: My primary concern is preventing my machine from going into unresponsive hibernation.
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
fprintd is the D-Bus daemon for a fingerprint reader access
Code:
sudo apt install fprintd
Thanks LB. I dug around deeper than that already. This what makes me think there may be no solution for my machine. fprintd is already installed.

Just a friendly reminder: My primary concern is preventing my machine from going into unresponsive hibernation.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,795
Reaction score
1,205
Credits
13,368
To prevent your Ubuntu system from suspending or going into hibernation, you need to disable the following systemd targets

Code:
sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

You get the output similar to shown below:

hybrid-sleep.target
Created symlink /etc/systemd/system/sleep.target → /dev/null.
Created symlink /etc/systemd/system/suspend.target → /dev/null.
Created symlink /etc/systemd/system/hibernate.target → /dev/null.
Created symlink /etc/systemd/system/hybrid-sleep.target → /dev/null

Then reboot

To re-enable the suspend and hibernation modes, run the command:

Code:
sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target

As far as your Fingerprint reader goes also make sure libpam-fprintd is installed

and then update your PAM configuration.

Code:
sudo pam-auth-update
 
Last edited:
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
To prevent your Ubuntu system from suspending or going into hibernation, you need to disable the following systemd targets

Code:
sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

You get the output similar to shown below:

hybrid-sleep.target
Created symlink /etc/systemd/system/sleep.target → /dev/null.
Created symlink /etc/systemd/system/suspend.target → /dev/null.
Created symlink /etc/systemd/system/hibernate.target → /dev/null.
Created symlink /etc/systemd/system/hybrid-sleep.target → /dev/null

Then reboot

To re-enable the suspend and hibernation modes, run the command:

Code:
sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target

As far as your Fingerprint reader goes also make sure libpam-fprintd is installed

and then update your PAM configuration.

Code:
sudo pam-auth-update
Thank you LB. The command you indicated has suspended the sleep/hibernated functions on my system, even when the lid is closed. It's a workaround.

When I try to update the PAM configurations, I can't figure out how to get any thing done on the PAM terminal. I can maneuver around somewhat with the up/down and tab keys, but I cannot actually select anything (Fingerprint authentication) other than OK and cancel. OK does nothing if I haven't selected something (Fingerprint authentication).
 

Attachments

  • Screenshot from 2022-03-26 08-52-29.png
    Screenshot from 2022-03-26 08-52-29.png
    122.8 KB · Views: 66
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
To make a selection you have to use the space bar once selected then reboot
That did it.

Once I rebooted I brought up the PAM terminal again and could see that Fingerprint authentication is indeed now enabled. In Settings -> Users I tried to enable Fingerprint login. The first attempt got me to a choice of which finger to use, but once that selection was made the error msg "Fingertip device not connected" came up. Now when I retry to enable I get "Failed to claim fingerprint device ElanTech Fingerprint Sensor: the device is already claimed by another process"

The long story is that when still running Ubuntu 20 and I first tried to enable fingerprint login I was actually able to register my fingerprint. The sensor actually worked to the extent that I was prompted to do this and that until a good record of my print was achieved. The fingerprint login option became present at bootup, but the sensor would no longer function. I did lots of research and tried various things, but eventually gave it up.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,795
Reaction score
1,205
Credits
13,368
Try stopping the Fingerprint daemon - have you tried to enroll your fingerprints in the terminal before? this error can occur when you use the terminal to register prints then try to use the GUI later
Code:
sudo service fprintd stop
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
Try stopping the Fingerprint daemon - have you tried to enroll your fingerprints in the terminal before? this error can occur when you use the terminal to register prints then try to use the GUI later
Code:
sudo service fprintd stop
Tried stopping the daemon - same difference.

I have not attempted to enroll via the terminal.
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
Lets try to force an upgrade
Code:
fwupd.fwupdmgr enable-remote lvfs-testing
fwupd.fwupdmgr refresh --force
fwupd.fwupdmgr update

reboot and try again
OK, command line suggests I first install:

Code:
sudo snap install fwupd

But when I do so there's further warning:

Code:
error: This revision of snap "fwupd" was published using classic confinement
       and thus may perform arbitrary system changes outside of the security
       sandbox that snaps are usually confined to, which may put your system at
       risk.

       If you understand and want to proceed repeat the command including
       --classic.

?
 

charlie.corder

Active Member
Joined
May 25, 2019
Messages
70
Reaction score
179
Credits
665
@dodobuntu
Greetings and welcome to the forum!
It just so happens that I have that exact same model of ASUS.
Been using it for about 2 to 2 1/2 years with Linux Mint 20.2 uma on it now.
Sorry I can't help with your problems, as I have not had any at all with Mint.
As I recall, it was a little different installing on the ASUS than on a Dell machine.
1648612276533.png

You might want to give Mint a try and see if that corrects your problems.
Just some random, rambling thoughts of an .....
Old Geezer
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,795
Reaction score
1,205
Credits
13,368
OK, command line suggests I first install:

Code:
sudo snap install fwupd

But when I do so there's further warning:

Code:
error: This revision of snap "fwupd" was published using classic confinement
       and thus may perform arbitrary system changes outside of the security
       sandbox that snaps are usually confined to, which may put your system at
       risk.

       If you understand and want to proceed repeat the command including
       --classic.

?
This is telling you that this particular snap package was done "Old School" and fwupd has to use some files outside of the Snap package and were not included in the Snap package - make sure the current fwupd is removed from snap first
Code:
sudo snap remove fwupd
Code:
sudo snap install fwupd --classic

The other option is to remove the "snap" service altogether (which Linux Mint has done) and reinstall fwupd through the synaptic package manager and the make the upgrade as said in #post 14

Kind of why I do not like Snap all that well - it cuts off sharing of internal files between programs and therefore makes those packages larger and runs a bit slower
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
@dodobuntu
Greetings and welcome to the forum!
It just so happens that I have that exact same model of ASUS.
Been using it for about 2 to 2 1/2 years with Linux Mint 20.2 uma on it now.
Sorry I can't help with your problems, as I have not had any at all with Mint.
As I recall, it was a little different installing on the ASUS than on a Dell machine.
View attachment 12179
You might want to give Mint a try and see if that corrects your problems.
Just some random, rambling thoughts of an .....
Old Geezer
I did notice your suggestion CC and am mulling it over. Thank you.
 
OP
D

dodobuntu

New Member
Joined
Mar 25, 2022
Messages
10
Reaction score
2
Credits
83
This is telling you that this particular snap package was done "Old School" and fwupd has to use some files outside of the Snap package and were not included in the Snap package - make sure the current fwupd is removed from snap first
Code:
sudo snap remove fwupd
Code:
sudo snap install fwupd --classic

The other option is to remove the "snap" service altogether (which Linux Mint has done) and reinstall fwupd through the synaptic package manager and the make the upgrade as said in #post 14

Kind of why I do not like Snap all that well - it cuts off sharing of internal files between programs and therefore makes those packages larger and runs a bit slower
Did manage to install fwdup --classic then try the upgrade, but I'm getting the same results.

Think I'll look into Mint, as suggested.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top