VirtualBox 6.0.20 running Mint Cinnamon 19.3 on Windows 10 cant file share... Help!

Drocks

New Member
Joined
Apr 20, 2020
Messages
2
Reaction score
0
Credits
0
My PC is a Windows 10 Pro v1909 Build 18363.778 / i7-8700K 6 core / Asus ROG Strix Z_370e MB / 32 MB RAM

Everything is up to date on the PC including drivers and it is networked as Private on Windows. I have added a rule for port 445 incoming TCP traffic on Windows Firewall.

I have installed Mint 19.3 on Oracles VirtualBox running on my PC. I updated everything that I could and managed to install, connect and use Nord.

Everything is going smoothly for someone brand new to Linux and VirtualBox. The learning curve is steep, and no part steeper than configuring a folder share between W10 Pro and VirtualBox Mint. I configured the download folder on the Mint Desktop to share but cannot see the folder in Windows (Im thinking this doesnt really matter and might not be the thing to do) MINT-VIRTUALBOX shows in my Windows Network tree but I get a Network Error explaining "Windows Cannot Access \\MINT-VIRTUALBOX Error Code 0x80070035 The Network Path was not found.

Im loving Mint but could somebody please provide direction for how to set up a share between Mint Cinnamon 19.3 and W10 Pro? Please
 


Tolkem

Well-Known Member
Joined
Jan 6, 2019
Messages
1,469
Reaction score
1,187
Credits
10,659
Im loving Mint but could somebody please provide direction for how to set up a share between Mint Cinnamon 19.3 and W10 Pro? Please
Did you install guest additions? Unless you do, Vbox won't be able to see your share forlder. To install them:
1. Start Mint VM.
2. From the top menu click on devices, select insert guest additions iso wait till the process finishes, turn off-turn on the VM and the share folder should be available now.

Hope this helps! :)
 

hawkins

New Member
Joined
Apr 16, 2020
Messages
18
Reaction score
11
Credits
59
I just had this exact same problem the other day. You have to get to the directory of the shared folder in the terminal do a long list ls -l and there is gonna be a virtual box group associated to the folder I believe it was vboxsf or something like that. You need to put your username from Mint in that group.
sudo usermod -a -G vboxusers $USER (instead of vboxusers its the vboxsf or whatever it shows, and instead of $USER use your log on name).
 
OP
D

Drocks

New Member
Joined
Apr 20, 2020
Messages
2
Reaction score
0
Credits
0
Thanks, unfortunately I seem to be at least one problem behind as I dont have a menu at the top of the page...Hmmmm More investigation required.

Ill come back to this for sure once I get the other issue sorted. Thanks
 

Tolkem

Well-Known Member
Joined
Jan 6, 2019
Messages
1,469
Reaction score
1,187
Credits
10,659
Thanks, unfortunately I seem to be at least one problem behind as I dont have a menu at the top of the page...Hmmmm More investigation required.

Ill come back to this for sure once I get the other issue sorted. Thanks
Are you starting the VM in full screen resolution? If that's the case, the menu's at the bottom. Hold down right Ctrl + F keys and it'll switch to window mode and you'll see it at the top or, while in full screen, hover the mouse pointer at the botton of the screen and it should appear. It's almost nearly impossible that there's no menu, unless you've explicitely deactivated it from VBox preferences.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top