video works on vlc if opened in brower... but it does not not works if opens in file manager

DRAGSTER_TUNER

New Member
Hi everyone!

Im having a weird problem with vlc...

If i download a video in browser (vivaldi), and open this file by clicking on it, in the download label of the browser, the video opens in the vlc with no issue...

butttt

If i try open the video by clicking on it, in the file manager (thunar), the vlc simply freezes! Just the cursor still working...all the rest of the X hangs and i have to reboot the computer.

So, i cant even open the vlc in terminal to try figure out whats going on...

Even being a debian fresh install, i try delete the .config and .cache vlc folders to restore defaults.....but it does not solved the problem.

Any clue?
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Im having a weird problem with vlc...
Everybody has a weird problem with Linux, that is why sites such as ours exist :):). Life would be boring, otherwise.

(Wizard appears in a puff of smoke, humming Vivaldi's "La Stravaganza", which he doesn't really know, so he opts for Beatles instead)

G'day @DRAGSTER_TUNER and welcome to linux.org :)

I take it it is Stretch you are using? with the Xfce DE (I call Xfce "the little mouse").

I run 60 - 80 Linux spread over a couple of computers and an externall HDD, and I have a Debian MATE on board at the moment, I could cross-reference using that and see if I have any probs. You appear to know your way around Linux a bit, so that is always a plus. Even to finding the best section to place this Thread :eek:

Without invading your privacy, can you give me a URL for an example video, to work with?

Someone else may swing along with a better answer, but meantime there are possibilities with Synaptic Package Manager eg
  • Check for any broken packages that might be related to VLC
  • Have you used VLC on this Distro before with other media than from the Net?
  • Completely remove VLC and then reinstall it
  • other
Cheers

Chris Turner
wizardfromoz
BTW - if you get the time, swing by https://www.linux.org/forums/member-introductions.141/ and say "Hi" and meet a few of the gang :cool:
 

poorguy

Well-Known Member
Hello Dragster Tuner,
.

It is possible that you may be missing needed dependencies for vlc.

Debian doesn't always automatically add / apply needed dependencies to the particular software being downloaded at the time of download.

Here's some links about vlc.

https://www.linuxtechi.com/install-vlc-3-debian-9-ubuntu-16-04-17-10/

https://www.tecmint.com/install-vlc-player-in-ubuntu-debian-linux-mint/


Not all software is compatible with Debian as is the case with other Linux Distros.

I've also found snap software packages don't always work either.
 

DRAGSTER_TUNER

New Member
" take it it is Stretch you are using? "

Actually, testing (buster)

"Without invading your privacy, can you give me a URL for an example video, to work with?"

here is a video i convert from facebook and downloaded:

https://video.xx.fbcdn.net/v/t42.9040-2/42609010_1900320933387855_6313045718265233408_n.mp4?_nc_cat=1&efg=eyJybHIiOjYyOCwicmxhIjoxMDMwLCJ2ZW5jb2RlX3RhZyI6InN2ZV9zZCJ9&rl=628&vabr=349&_nc_ht=video-lga3-1.xx&oh=bd2011322feb8703c7989d8d593567e6&oe=5BD28622

works flawlesly on browser, but if i donwload it to HD and then try to watch on vlc, it hangs all X.


"https://www.linuxtechi.com/install-vlc-3-debian-9-ubuntu-16-04-17-10/"

put unstable on repositories and comment another lines and update it....when i give

sudo apt install vlc -y

it says its the lastest version...


"https://www.tecmint.com/install-vlc-player-in-ubuntu-debian-linux-mint/"

$ sudo snap install vlc

installed lastest vlc, but unfortulatelly it still hangs...
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Thanks for those links, I will check a couple of things out. :)

Wizard
 

poorguy

Well-Known Member
Another thing you might give a try is to remove vlc and install "Gnome MPV".

This can be done through "Synaptic Package Manager".
 

DRAGSTER_TUNER

New Member
"Another thing you might give a try is to remove vlc and install "Gnome MPV"."

Hi, i have MPV and it works all ok, but i dont like it at all.... =)
 

poorguy

Well-Known Member
I would try a different player like "Parole" or "Xplayer" both are really good.

I really don't think vlc is going to work with Debian although I may be wrong.

I believe you are missing some needed dependencies.

Vlc is a good media player although way more than I need and way to heavy imo.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I love that bunny ... he has a fine figure, like me (even down to scratching his arse when he gets up).

Mine is Debian 'Stretch' MATE, and I checked that VLC was available in SPM, then installed with

Code:
sudo apt-get -y install vlc

# followed a little later with

sudo apt-get -y install browser-plugin-vlc
Downloaded the vid and it ran fine.

I have a screenshot of some of the packages, excluding a couple of libraries and the browser plugin.



Version details as per

Code:
apt-cache policy vlc
... are

[email protected]:~$ apt-cache policy vlc
vlc:
Installed: 3.0.3-1-0+deb9u1
Candidate: 3.0.3-1-0+deb9u1
Version table:
*** 3.0.3-1-0+deb9u1 500
500 http://security.debian.org stable/updates/main amd64 Packages
100 /var/lib/dpkg/status
3.0.2-0+deb9u1 500
500 http://mirror.intergrid.com.au/debian stable/main amd64 Packages
500 http://deb.debian.org/debian stretch/main amd64 Packages

Dependencies can be seen, for Buster, here

https://packages.debian.org/buster/vlc

Other than that, I am at a loss.

Wizard
 

DRAGSTER_TUNER

New Member
Well....i have some news...

KAFFEINE happens the same...it freezes X...:mad:

MPV and totem works ok... now im confused!

By the way,:

vlc is already the newest version (1:3.0.4-dmo4).
vlc-bin is already the newest version (1:3.0.4-dmo4).
vlc-data is already the newest version (1:3.0.4-dmo4).
vlc-data configurado para instalar manualmente.
vlc-l10n is already the newest version (1:3.0.4-dmo4).
vlc-l10n configurado para instalar manualmente.
vlc-plugin-base is already the newest version (1:3.0.4-dmo4).
vlc-plugin-notify is already the newest version (1:3.0.4-dmo4).
vlc-plugin-notify configurado para instalar manualmente.
vlc-plugin-qt is already the newest version (1:3.0.4-dmo4).
vlc-plugin-skins2 is already the newest version (1:3.0.4-dmo4).
vlc-plugin-skins2 configurado para instalar manualmente.
vlc-plugin-video-output is already the newest version (1:3.0.4-dmo4).
vlc-plugin-video-splitter is already the newest version (1:3.0.4-dmo4).
vlc-plugin-video-splitter configurado para instalar manualmente.
vlc-plugin-visualization is already the newest version (1:3.0.4-dmo4).


$ apt-cache policy vlc
vlc:
Instalado: 1:3.0.4-dmo4
Candidato: 1:3.0.4-dmo4
Tabela de versão:
*** 1:3.0.4-dmo4 500
500 http://debian.c3sl.ufpr.br/debian-multimedia testing/main amd64 Packages
100 /var/lib/dpkg/status
3.0.4-3+b2 500
500 http://ftp.us.debian.org/debian testing/main amd64 Packages

Unfortunatelly, im quitting...ill try something else as kaffeine, parole xplayer or another.

Thanks for all whos help me out!

Cheers
 
Last edited:





Top