using ipfire with TP-LINK Archer C7 Wireless AC1750 Dual-Band Gigabit Router

noobusinglinux

New Member
hello all
im currently trying to use a TP-LINK Archer C7 Wireless AC1750 Dual-Band Gigabit Router connected to my ipfire blue interface i have addded another gigabit ethernet card to the machine and configured it as blue0 interface in the setup. then connected it to the blue port on the router
when i started the router fedora an ubuntu distributions could not connect to the acces piont but my android phone could connect.

my network ipfire interface is configured with:
red0: (static ip)
netmask 255.255.255.252
dns 8.8.8.8 and 4.4.4.4
green0 192.168.0.1
255.255.255.0
blue0 192.168.1.1
netmask 255.255.255.0
then from the web interface

firewall/blue access
added source ip 192.168.1.2/25 without mac address (supposed to allow all access)
and 192.168.1.2 added from DHCP lease list
both are showing a hostname of wifi.privatedomain

network/DHCP server
green interface enabled
start address:192.168.0.4 end address:192.168.0.50
domain name suffix: privatedomain
primary dns server: 192.168.0.1 secondary 192.168.0.3
blue interface enabled
start address 192.168.1.2 end address 192.168.1.25
domain name suffix privatedomain
primary dns 192.168.1.1 secondary 192.168.1.26

TP-LINK Archer C7 Wireless AC1750 Dual-Band Gigabit Router:

Firmware Version:3.14.3 Build 150520 Rel.44934n
Hardware Version:Archer C7 v2 00000000


LAN
MAC Address:18-D6-C7-6C-D7-85
IP Address:192.168.2.1
Subnet Mask:255.255.255.0

Wireless 2.4GHz
Wireless Radio:Enable
Name (SSID):goaway2.4ghz
Mode:11bgn mixed
Channel:Auto (Current channel 11)
Channel Width:Automatic
MAC Address:18-D6-C7-6C-D7-85
WDS Status:Disable
Wireless 5GHz
Wireless Radio:Enable
Name (SSID):goaway2.4ghz
Mode:11a/n/ac mixed
Channel:Auto (Current channel 36)
Channel Width:Automatic
MAC Address:18-D6-C7-6C-D7-84
WDS Status:Disable

WAN
MAC Address:00-0A-F5-C1-3E-AC
IP Address:192.168.1.2Static IP
Subnet Mask:255.255.255.0
Default Gateway:192.168.1.1
DNS Server:192.168.1.1 , 192.168.1.26
Traffic Statistics
ReceivedSent
Bytes:460978549741
Packets:7866261
in IPTV the IGMP proxy is enabled mode:automatic
DHCP enabled with

Start IP Address:192.168.2.2
End IP Address:192.168.2.25
Address Lease Time: minutes (1~2880 minutes, the default value is 120)
Default Gateway:192.168.2.1 (optional)
Default Domain: (optional)
Primary DNS:192.168.1.1 (optional)
Secondary DNS:192.168.1.26 (optional)

DHCP Clients List
IDClient NameMAC AddressAssigned IPLease Time
1android-966a275f064ac1c500-0A-F5-C1-3E-AC192.168.2.201:52:57
2privatehost-privatedomain18-F4-6A-89-19-BE192.168.2.301:48:42

Current NAT Status: Enabled
Current Hardware NAT Status: Enabled
security:
SPI Firewall:
Disabled

FTP ALG:
Enabled
TFTP ALG:
Enabled
H323 ALG:
Enabled
RTSP ALG:
Enabled
SIP ALG:
Enabled
System routing table:
IDDestination NetworkSubnet MaskGatewayInterface
1192.168.2.0255.255.255.00.0.0.0LAN & WLAN
2192.168.1.0255.255.255.00.0.0.0WAN
3239.0.0.0255.0.0.00.0.0.0LAN & WLAN
40.0.0.00.0.0.0192.168.1.1WAN
its alot of details and im not quite sure how i got it this way but after changing the router network from 192.168.0 to 192.168.2 the linux distrobutions were able to connect to the access point and i cant seem to do anything other thain browse google and the tp-link router configuration

does anybody know how to configure ipfire blue0 interface with a router that can tell me what i do wrong?
thanks
 


noobusinglinux

New Member
so i spoke to customer support and they gave me this tutorial. i onfigured it and now whenever i connect a device to the access point the device appears in the blue access.
i can access the router but i still cant seem to get any internet access
 

Staff online

Members online


Top