Upgrading from Ubuntu 21.10 to Ubuntu 22.04

TheNarbox

New Member
Joined
Jul 28, 2022
Messages
7
Reaction score
0
Credits
46
I have such a problem. I upgraded my server from Ubuntu 21.10 to Ubuntu 22.04 using do-release-upgrade. Everything went well until the end. After the update I restarted the server but no services loaded. When I tried the apt upgrade command I got this error: Does anyone know what to do with it? Thank you
Setting up grub-efi-amd64-signed (1.180+2.06-2ubuntu7) ...
mount: /var/lib/grub/esp: unknown filesystem type 'linux_raid_member'.
dpkg: error processing package grub-efi-amd64-signed (--configure):
installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 32
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of shim-signed:
shim-signed depends on grub-efi-amd64-signed | grub-efi-arm64-signed; however:
Package grub-efi-amd64-signed is not configured yet.
Package grub-efi-arm64-signed is not installed.

dpkg: error processing package shim-signed (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
grub-efi-amd64-signed
shim-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)
 


Looks like efi /boot partition may not have been created or efi was not set up by install correctly.
It says it's missing a dependency so you need to find out what that is and install it.
try to reinstall grub-efi-amd64-signed.
 
Looks like efi /boot partition may not have been created or efi was not set up by install correctly.
It says it's missing a dependency so you need to find out what that is and install it.
try to reinstall grub-efi-amd64-signed.
Hi, you know how? apt-get showing me 2 not fully installed or removed.
root@warmachine ~ # apt install grub-efi-amd64-signed
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
grub-efi-amd64-signed is already the newest version (1.180+2.06-2ubuntu7).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up grub-efi-amd64-signed (1.180+2.06-2ubuntu7) ...
mount: /var/lib/grub/esp: unknown filesystem type 'linux_raid_member'.
dpkg: error processing package grub-efi-amd64-signed (--configure):
installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 32
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of shim-signed:
shim-signed depends on grub-efi-amd64-signed | grub-efi-arm64-signed; however:
Package grub-efi-amd64-signed is not configured yet.
Package grub-efi-arm64-signed is not installed.
dpkg: error processing package shim-signed (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
grub-efi-amd64-signed
shim-signed
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Looks like efi /boot partition may not have been created or efi was not set up by install correctly.
It says it's missing a dependency so you need to find out what that is and install it.
try to reinstall grub-efi-amd64-signed.
At every apt-upgrade, the system asks me this:
hYDY.png
 
Is that partition present in the new install? Or did the disk designation for it get changed so the ID is no longer what it was originally? Seem grub could not find that needed partition.
 
Is that partition present in the new install? Or did the disk designation for it get changed so the ID is no longer what it was originally? Seem grub could not find that needed partition.
We have been using the server for a year, we just used do-release-upgrade because we had the old version
 
We have been using the server for a year, we just used do-release-upgrade because we had the old version
but when you did the upgrade the partition er may have re designated the partition id's check out fstab see what it says.
 
but when you did the upgrade the partition er may have re designated the partition id's check out fstab see what it says.
How to check out fstab. Sorry I don't have profesional expirience with Linux
 
but when you did the upgrade the partition er may have re designated the partition id's check out fstab see what it says.
This is the fstab configuration:

proc /proc proc defaults 0 0
# /dev/md/0
UUID=f8ed7a0c-c319-4974-b297-fc46009c6901 none swap sw 0 0
# /dev/md/1
UUID=fd633ddb-838c-474d-9eb8-5ebbafb4ba8c /boot ext3 defaults 0 0
# /dev/md/2
UUID=8a58809f-c049-42dd-9db8-50c444591e7d / ext4 defaults 0 0
 
Since I have no Idea what the UUID# was for the original install. And if it changed when the upgrade happened then grub would not be able to find the correct file to write too. At this point you could try to reinstall grub and see if that works.
Good luck.
 
Since I have no Idea what the UUID# was for the original install. And if it changed when the upgrade happened then grub would not be able to find the correct file to write too. At this point you could try to reinstall grub and see if that works.
Good luck.
How to reinstall grub properly?
 

Staff online


Latest posts

Top