Upgraded to 21


Well-Known Member
Aug 9, 2020
Reaction score
Well I upgraded my Dual boot "Gaming" rig to Mint 21 "Vanessa", took about 1 1/2 hours. First had to have "required" a TimeStamp for that day. Open Terminal and then... sudo apt install -y mintupgrade then... sudo mintupgrade. Opens a GUI to check system, packages etc.... then does it's thing. I think also I am gonna bite the bullet and take my laziness to my dual Win 8.1 / Mint laptop I use for paying bills from the bank and doing my taxes, and Use the whole drive and DUMP Win 8.1 as all I did was upgrade it a while ago because I missed the DEL key at turn on so it booted into Win. So I upgraded it then almost a year now.

On another note I upgraded the CPU to a Ryzen 5600 on the "Gaming" rig, so I had a 3600 and an Athon 3000g without homes.

I replaced my perfectly good HP tower with a new Termaltake Case, 54 bucks. Had a Thermaltake 120 radiator not used yet. 2 500GB NvMe drives, used 1. A 240 SSD and the old 1TB HDD drive from the HP. So now I have an Intel Core I5 10400 CPU without a home. The MB from this HP is proprietary. so cannot be moved to another case. Even the DVD plugs are HP Sata specials.

So far Vanessa seems to be stable and unlike Win it kept all the settings I have for the desktop. The Icons still worked, the system Temp monitors was still up and running, even the clock, Unlike Win10, the clock is in sync to Eastern Time zone and yet it will sometimes switch to 3 hours ahead and need to re-sync. Windows :mad:

I am most interested to hear from those who have already updated.....either using the newly released Update Manager, or via a Fresh Install
I am most interested to hear from those who have already updated.....either using the newly released Update Manager, or via a Fresh Install

Yes me too...when Mint 20 Cinnamon came out it had a few bugs which were fixed in 20.1...same thing happened with Mint 19...that's why I wait.
I am most interested to hear from those who have already updated.....either using the newly released Update Manager, or via a Fresh Install
sudo apt install -y mintupgrade then sudo mintupgrade it gives you this

It went well, runs fine. When you click on the "Let's Go" above it checks system. As I stated It wants a fresh Timestamp, my last one was days ago. So I did a new one. Then it would give an error with details, and a Fix button appears. Such as, this lib does not exist, it was very thorough. It is detailing all it is doing along the way.

Still have my dual boot menu. Still have all settings, Had Hynotix, at the top it has a dark mode which was clicked on but never worked in 20, It now does.
Well HP has is issues. So does Mint 19. It kept giving me errors as set up timeshift. Which was new, and yet it kept giving error.

So no upgrade to 20, which is no upgrade to 21. So decided to flash a USB and HP kept booting to recovery then no matter that I chose USB it booted to Win Partition. Kept giving errors on the USB Mint 21, went and tried it again with an MX 21 USB which did boot. So Mint 21 may have issues. Will Flash Mint 20, and then upgrade within 20 to 21 if it goes well.

HP's and dual boot always have had issues. On my other HP laptop with MX 19 and 21 there is no windows so it goes straight to MX loader to chose 19 or 21.

If it weren't for problems we would not need solutions. Part of the process sometimes.
I just selected an epub format novel to read.....and attempted to open it with ebook viewer....only to find it has disappeared from my pc.

A new reader is included in the software manager...called Foliate

It can also be downloaded as a ppa from Foliate's website

  • Supports EPUB, Mobipocket, Kindle, FictionBook, and comic book archive formats
This is the longest update in the world!
I have had windows take much longer in the past
I have too I just want to go to bed.
Windows 8.1 is now being formatted outta here by MX. Tried 1 more time for a fresh Mint install no errrors on USB when writing, either Etcher or Rufus, HP continued the Media will not boot thingy. MX USB booted fine.

Did notice one thing also. Mint 19 never did like the WiFi on the older HP, could never get it to work, Bluetooth either. At the MX Live desktop sees my WiFi just fine.

Yet Mint was the only Distro the was happy with the "gaming" rig. MX did not like the M.2 drive Mint would not use it though it came up, It is Dual Win10 and Mint. And no problems at all with the Mint upgrade on that one.
I have too I just want to go to bed.
If you saw my other post, it took 2 hrs 10 mins from starting the iso download to the installation being complete, but I suspect being of a lower power your chromebook will take a fair bit longer
It crashed lol I have to reinstall Linux now. And I gave my back up drive to a friend and now I'm trying to make a copy through android.
Well I made I live boot SD Card from my Android phone by using Etchdriod lol! All my data was destroyed but I still have Linux on the obominated Chromebook lol!
Maybe my time shift is still on the chromebook
correction no data was destroyed time shift saved the day.


  • Screenshot_20220811-045120.png
    143.6 KB · Views: 169
Last edited:
MX running fine and I have WiFi back as it was lost to a Mint upgrade long ago. I only use this HP laptop as a wired connection to bank and do my taxes once a year. It never leaves the desk. it is against the wall and there are the shelves that have Pi stuff on them. For some reason though Mint would not in any way tried Rufus, Etcher, tried 21, 20 then a 19 I had which would boot on another newer HP but not on this one.
Used the upgrade tool to upgrade from 20.3 to 21 on my 8 year old Dell Latitude. Just over an hour in all, hitting the 'FIX' button every time it appeared. Everything worked just fine with, strangely, only the touch pad 'tap to click' needing turning back on.

Members online