UNSOLVED: VirtualBox Guest Additions Not Working on elementaryOS -please help

Meta Master

New Member
Credits
242
I cannot get VirtualBox Guest Additions to work on my elementary OS in my VirtualBox program. I have tried just about all walkthroughs and tutorials online and they have become circular in their reasoning and keep leading me to dead ends insisting things should work when they do not.

This was working until I recently cleared the cache in the terminal. After restarting, the guest additions no longer works.

I just want to be able to resize the resolution but that requires VBox Guest Additions.

Please help with this.

Edit: I am on a Mac Mini 2018 model.
 


Tolkem

Well-Known Member
Credits
1,995
This was working until I recently cleared the cache in the terminal. After restarting, the guest additions no longer works.
Do you mean you cleared cache in the host or in the guest? What OS are you running in VBox? Linux? Windows? MacOS? Which one? Which VBox version? Also, VBox forum might a better place to ask for help since they know better than most people here https://forums.virtualbox.org/
 

Meta Master

New Member
Credits
242
Do you mean you cleared cache in the host or in the guest? What OS are you running in VBox? Linux? Windows? MacOS? Which one? Which VBox version? Also, VBox forum might a better place to ask for help since they know better than most people here https://forums.virtualbox.org/
I cleared cache in the guest, in elementary OS which is Linux, on my host macOS Catalina, in the latest version of VirtualBox.
 

Tolkem

Well-Known Member
Credits
1,995
I cleared cache in the guest, in elementary OS which is Linux, on my host macOS Catalina, in the latest version of VirtualBox.
I see. BTW, looks like I missed that you'd already mentioned the guest on the title as well as in your post, sorry about that. Did you install Vbox guest additions by selecting devices from the menu at the top of the VM window? Did you do it by some other means? Would you mind telling us how you did it? Sorry but I never used macOS, at least not in a regular basis and certainly haven't installed VBox in a macOS pc. Maybe someone else here on the forum has but untill they show up ... I do use VBox and been using for years. For instance, I posted this https://www.linux.org/threads/debian-netinst-in-a-vm.21971/#post-64711 a while ago, you can read it and see if it helps.
 

Meta Master

New Member
Credits
242
I see. BTW, looks like I missed that you'd already mentioned the guest on the title as well as in your post, sorry about that. Did you install Vbox guest additions by selecting devices from the menu at the top of the VM window? Did you do it by some other means? Would you mind telling us how you did it? Sorry but I never used macOS, at least not in a regular basis and certainly haven't installed VBox in a macOS pc. Maybe someone else here on the forum has but untill they show up ... I do use VBox and been using for years. For instance, I posted this https://www.linux.org/threads/debian-netinst-in-a-vm.21971/#post-64711 a while ago, you can read it and see if it helps.
I tried various methods for installing Vbox Guest Additions. The last method I tried was ejecting the VBox iso from VirtualBox, inserting an empty disc into VirtualBox in the optical drive, going through the various instructions for elementary OS involving get-apt, and that resulted in the disc being loaded with guest additions.

Currently, since it is inserted already, selecting "Insert Guest Additions CD Image..." from the Devices menu while elementary OS is open results in the error ""Unable to insert the virtual optical disk /Applications/VirtualBox.app/Contents/MacOS/VboxGuestAdditions.iso into the machine elementary OS." The VboxGuestAdditions.iso is registered by the VirtualBox program as already inserted. elementaryOS also registers it as inserted.

Upon going to the elementaryOS files menu and clicking under Devices on VBox_GAs_5.2.44 I receive the error "Error mounting volume VBox.GAs_5.2.44" which goes on to say "Error mounting /dev/sr0 at /media/meta/VBox_GAs_5.2.44: wrong fs type, bad option, bad superblock on /dev/sr0 missing codepage or helper program, or other error" with "meta" being my username.

However, this program was running just fine the day before yesterday so that error does not make sense.
 

Tolkem

Well-Known Member
Credits
1,995
I tried various methods for installing Vbox Guest Additions. The last method I tried was ejecting the VBox iso from VirtualBox, inserting an empty disc into VirtualBox in the optical drive, going through the various instructions for elementary OS involving get-apt, and that resulted in the disc being loaded with guest additions.

Currently, since it is inserted already, selecting "Insert Guest Additions CD Image..." from the Devices menu while elementary OS is open results in the error ""Unable to insert the virtual optical disk /Applications/VirtualBox.app/Contents/MacOS/VboxGuestAdditions.iso into the machine elementary OS." The VboxGuestAdditions.iso is registered by the VirtualBox program as already inserted. elementaryOS also registers it as inserted.

Upon going to the elementaryOS files menu and clicking under Devices on VBox_GAs_5.2.44 I receive the error "Error mounting volume VBox.GAs_5.2.44" which goes on to say "Error mounting /dev/sr0 at /media/meta/VBox_GAs_5.2.44: wrong fs type, bad option, bad superblock on /dev/sr0 missing codepage or helper program, or other error" with "meta" being my username.

However, this program was running just fine the day before yesterday so that error does not make sense.
Are you (your user) member of the vboxusers group? If you're not, add yourself to it
Code:
sudo usermod -a -G vboxusers your_username
Also, googling took me here https://forums.virtualbox.org/viewtopic.php?f=8&t=98972&p=480925&hilit=guest+additions#p480925 read and see if something there helps.
 

Meta Master

New Member
Credits
242
Are you (your user) member of the vboxusers group? If you're not, add yourself to it
Code:
sudo usermod -a -G vboxusers your_username
Also, googling took me here https://forums.virtualbox.org/viewtopic.php?f=8&t=98972&p=480925&hilit=guest+additions#p480925 read and see if something there helps.
Adding myself did not fix the issue. Following that solution still resulted in the "Error mounting volume VBox.GAs_5.2.44" which goes on to say "Error mounting /dev/sr0 at /media/meta/VBox_GAs_5.2.44: wrong fs type, bad option, bad superblock on /dev/sr0 missing codepage or helper program, or other error"
 

Tolkem

Well-Known Member
Credits
1,995
Adding myself did not fix the issue. Following that solution still resulted in the "Error mounting volume VBox.GAs_5.2.44" which goes on to say "Error mounting /dev/sr0 at /media/meta/VBox_GAs_5.2.44: wrong fs type, bad option, bad superblock on /dev/sr0 missing codepage or helper program, or other error"
You might try downloading guest additions https://download.virtualbox.org/virtualbox/5.2.44/VirtualBox-5.2.44-139111-OSX.dmg and see if that works. It's always a good practice to create snapshots of the VMs in VBox for and when things like this happens, so you can investigate the error before it does by reverting the VM to a previous working state. See here
and here https://www.virtualbox.org/manual/ch01.html#snapshots You could try qemu too https://wiki.qemu.org/Hosts/Mac
 

Meta Master

New Member
Credits
242
I already have that dmg. The VirtualBox forums failed me so I am going to quit using it for Linux and wait to buy a copy of Parallels in the future.
 

Tolkem

Well-Known Member
Credits
1,995
I already have that dmg. The VirtualBox forums failed me so I am going to quit using it for Linux and wait to buy a copy of Parallels in the future.
I meant to download it once again and try with that one.
 


Members online

No members online now.

Latest posts

Top