unknown gentoo issue

Joined
Nov 16, 2021
Messages
81
Reaction score
21
Credits
598
the error appeared when i was running "emerge --ask --verbose --update --deep --newuse @World" during install

Total: 85 packages (80 new, 5 reinstalls), Size of downloads: 929330 KiB

* Error: circular dependencies:

(dev-libs/double-conversion-3.2.0:0/3::gentoo, ebuild scheduled for merge) depends on
(dev-util/cmake-3.22.2:0/0::gentoo, ebuild scheduled for merge) (buildtime)
(dev-qt/qtcore-5.15.3:5/5.15.3::gentoo, ebuild scheduled for merge) (buildtime)
(dev-libs/double-conversion-3.2.0:0/3::gentoo, ebuild scheduled for merge) (buildtime_slot_op)

It might be possible to break this cycle
by applying the following change:
- dev-util/cmake-3.22.2 (Change USE: -qt5)

Note that this change can be reverted, once the package has been installed.

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option.
 


$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online


Top