• We did not send an email asking for donations - please read this post.

Unexpected Inconsistency

Buzzz

New Member
Joined
Mar 25, 2020
Messages
19
Reaction score
16
Credits
52
Hello all, I'm new to Linux. I have installed LXLE in January, and have been getting used to it. I tried booting up recently and this is the text that shows up...


Scanning for Btrfs filesystems
/dev/sda5 contains a file system with errors, check forced.
Inodes that were a part of a corrupted orphan linked list found.

/dev/sda5: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
(i.e., without -a or -p options)
fsck exited with status code 4
The root filesystem on /dev/sda5 requires a manual fsck

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1.4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) _



I have entered 'help' and tried most of the commands but haven't gotten any results. Does anyone have any suggestions on what to do? I am running Linux LXLE alongside Windows Vista on a Dell Inspiron 1545 laptop.

Thanks!
 


jglen490

Well-Known Member
Joined
Mar 10, 2020
Messages
736
Reaction score
505
Credits
4,106
I would enter sudo fsck /dev/sda5 and see what it does. Normally /dev/sda5 must be unmounted when running fsck against it. You may need to boot using a Live installer on a USB drive, opening a terminal in the Live session and then run the fsck.

You may start getting errors, maybe even a lot of errors, that will require a response (such as entering a y). You can either respond with "y" to each one, or enter an "a" and it will assume "y" for all responses. And again, there may be a few errors, or a TON of errors.

Once fsck completes, run it again, until you get a clean reply. You should be good once fsck shows the filesytem to be clean.
 
OP
Buzzz

Buzzz

New Member
Joined
Mar 25, 2020
Messages
19
Reaction score
16
Credits
52
Thank you jglen490! I followed your instructions and it worked. My system booted again as good as before. Kudos to you sir!
 

jglen490

Well-Known Member
Joined
Mar 10, 2020
Messages
736
Reaction score
505
Credits
4,106
You're welcome! Happy computing.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top