Ubuntu / no sound / sound card seen but no codec / (proc/asound/card0 empty)

NestorCayce

New Member
Dear All,

I've installed Ubuntu 19.04 for my kids on old barebone Shuttle SD37P2 (Vendor doc says that Audio is ALC882)
(just added an SDD so it's more comfortable).

Already wasted few hours to troubleshoot my no sound issue...
Could an external USB card be an option ? (any cheap model to recommend ?)

Thanks for your support / info below:

The only audio card that seems to be properly installed is the HDMi one (but I've no speakers on my monitor)
/proc/asound/card0 => folder is empty
/proc/asound/card1 => contains info related to HDMI


Alsa report: Report Alsa (visible at the bottom=> snd_hda_intel 0000:00:1b.0: no codecs found!)

From hardware info (integrated chip on the motherboard is well detected, as well as the HDMi):

Code:
hwinfo --sound
14: PCI 1b.0: 0403 Audio device                                 
 [Created at pci.386]
 Unique ID: u1Nb.dvotA5wWJK1
 SysFS ID: /devices/pci0000:00/0000:00:1b.0
 SysFS BusID: 0000:00:1b.0
 Hardware Class: sound
 Model: "Intel NM10/ICH7 Family High Definition Audio Controller"
 Vendor: pci 0x8086 "Intel Corporation"
 Device: pci 0x27d8 "NM10/ICH7 Family High Definition Audio Controller"
 Revision: 0x01
 Driver: "snd_hda_intel"
 Driver Modules: "snd_hda_intel"
 Memory Range: 0xfdff8000-0xfdffbfff (rw,non-prefetchable)
 IRQ: 24 (no events)
 Module Alias: "pci:v00008086d000027D8sv00000000sd00000000bc04sc03i00"
 Driver Info #0:
   Driver Status: snd_hda_intel is active
   Driver Activation Cmd: "modprobe snd_hda_intel"
 Config Status: cfg=new, avail=yes, need=no, active=unknown

21: PCI 200.1: 0403 Audio device
 [Created at pci.386]
 Unique ID: 2Oa+.j18tSRZEo21
 Parent ID: 3hqH.JVqAOgaj8O4
 SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:02:00.1
 SysFS BusID: 0000:02:00.1
 Hardware Class: sound
 Model: "ATI Juniper HDMI Audio [Radeon HD 5700 Series]"
 Vendor: pci 0x1002 "ATI Technologies Inc"
 Device: pci 0xaa58 "Juniper HDMI Audio [Radeon HD 5700 Series]"
 SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd"
 SubDevice: pci 0xaa58 
 Driver: "snd_hda_intel"
 Driver Modules: "snd_hda_intel"
 Memory Range: 0xfd8fc000-0xfd8fffff (rw,non-prefetchable)
 IRQ: 25 (231 events)
 Module Alias: "pci:v00001002d0000AA58sv00001458sd0000AA58bc04sc03i00"
 Driver Info #0:
   Driver Status: snd_hda_intel is active
   Driver Activation Cmd: "modprobe snd_hda_intel"
 Config Status: cfg=new, avail=yes, need=no, active=unknown
 Attached to: #19 (PCI bridge)
lspci gives:
Code:
lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Juniper HDMI Audio [Radeon HD 5700 Series]
Alsamixer fails with no files or folder... (sorry it's in french, I don't know the exact message in english)

Already tried with no luck:
Code:
sudo apt install ubuntu-restricted-extras
 


Peer

Active Member
Did u sett the sound-output-device to the one on the motherboard? U can do this pretty easily in the sound settings of Ubuntu. Another option would be to install pulseaudio instead if alsa.
 

NestorCayce

New Member
Did u sett the sound-output-device to the one on the motherboard? U can do this pretty easily in the sound settings of Ubuntu. Another option would be to install pulseaudio instead if alsa.
I've pulseaudio installed: it does not see the inboard audio chip; only HDMI.
As per my understanding Pusleaudio is over Alsa and 'consume' info from Asla. If Alsa says that there is no codec for one card, there is no chance that Pusleaudio can do better (nevertheless I'm not an expert and might be wrong).
 

JulienCC

Active Member
Hello !

As per my understanding Pusleaudio is over Alsa and 'consume' info from Asla. If Alsa says that there is no codec for one card, there is no chance that Pusleaudio can do better (nevertheless I'm not an expert and might be wrong).
This is more complex than that. Actually ALSA uses PulseAudio which uses ALSA... It was made to let old applications relying solely on ALSA being able to coexist with PulseAudio applications.

But in this case, if alsa can't seen the hardware, pulseaudio wont.

Did you check the BIOS for audio options ?
 

NestorCayce

New Member
Hello !



This is more complex than that. Actually ALSA uses PulseAudio which uses ALSA... It was made to let old applications relying solely on ALSA being able to coexist with PulseAudio applications.

But in this case, if alsa can't seen the hardware, pulseaudio wont.

Did you check the BIOS for audio options ?
Hi,

I can enable / disable the integrated audio chipset from the bios: I've tried with no luck.
I've also reinstalled Ubuntu (as I did many tests and wanted to be sure to not have messed up something).

I've also tried with a buetooth dongle and speaker: no luck (it can see the speaker, pair it but then it does not connect).
 

JulienCC

Active Member
I don't know about the bluetooth, but your intel audio chipset problem is most likely a driver problem.
Some manufacturers plug their audio codec in a special way. It might be the case here since this is a barebone of a quite old CPU platform.

Is there anything else displayed at boot, or in the output of : (actually dont do it, see message below)
Code:
# dmesg
 
Last edited:

JulienCC

Active Member
Try this :

Code:
# modprobe -r snd_hda_intel
# modprobe snd_hda_intel probe_mask=0x1ff
then let us see what happened in dmesg
Code:
# dmesg
Check if the card is now detected. This is a trick to force usage of a codec that didn't respond to probe. Some codecs are broken and won't respond anyway.
 

NestorCayce

New Member
Try this :

Code:
# modprobe -r snd_hda_intel
# modprobe snd_hda_intel probe_mask=0x1ff
then let us see what happened in dmesg
Code:
# dmesg
Check if the card is now detected. This is a trick to force usage of a codec that didn't respond to probe. Some codecs are broken and won't respond anyway.
Thanks Julien for help.

unfortunately I get an error message when I try to remove snd_hda_intel (modprobe: FATAL: Module snd_hda_intel is in use.)
I guess this is because the graphic card loads the same module for HDMi (refer to the alsa report): do you know how I can disable (removing would be the best) this HDMi sound card (having it disabled in Pavucontrol is not enough) ?

Do you think buying a cheap sound card would work?
 

JulienCC

Active Member
Try this instead of the first command :
Code:
rmmod -f snd_hda_intel
Dont forget to execute the second command after that.

If it doesnt work, add the following content to /etc/modprobe.d/audio_bypass _prob.conf :
Code:
options snd_hda_intel probe_mask=0x1ff
And reboot.

Yes an extra sound card could work. But choose a model that is well supported under Linux. It could be a workarround but dont worry we will find a solution
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
This is beyond my paygrade, likely - but it is a pity that you pair live 578.6 km apart via the A36 and A6?

Without giving away the regions where you live, there is a

Groupes d'utilisateurs locaux de Linux (GUL)

(for english speakers - LUG Linux User Group)

... close to the OP Nestor. I wonder if that may be of assistance should all else fail.

Good luck

Cheers

Wizard

& welcome to linux.org, Nestor :)
 

NestorCayce

New Member
Try this instead of the first command :
Code:
rmmod -f snd_hda_intel
Dont forget to execute the second command after that.

If it doesnt work, add the following content to /etc/modprobe.d/audio_bypass _prob.conf :
Code:
options snd_hda_intel probe_mask=0x1ff
And reboot.

Yes an extra sound card could work. But choose a model that is well supported under Linux. It could be a workarround but dont worry we will find a solution

Still no luck

rmmod -f snd_hda_intel
=>
rmmod: ERROR: ../libkmod/libkmod-module.c:793 kmod_module_remove_module() could not remove 'snd_hda_intel': Resource temporarily unavailable
rmmod: ERROR: could not remove module snd_hda_intel: Resource temporarily unavailable

I'm definitively not a linux expert but my strategy would be to prevent the snd_hda_intel from being loaded for the HDMI card then do all the tries for the "target" one. I just don't know how to tell alsa to ignore the HDMi as an audio card.


@wizardfromoz: no luck in the Ubuntu french forum where the only advice I got was to...browse the forum to find the solution (while I think it was quite visible from my post that I did already spend a fair amount of time googling, trying...). So...
 

JulienCC

Active Member
I'm definitively not a linux expert but my strategy would be to prevent the snd_hda_intel from being loaded for the HDMI card then do all the tries for the "target" one. I just don't know how to tell alsa to ignore the HDMi as an audio card.
Yes this could be an option but the second part of my previous message is a simpler way of doing it. What we are trying to achieve is to make the snd_hda_intel module to be loaded with an option. The rmmode/modprobe was supposed to be easier than adding options to modprobe.d conf file but it happened to be harder ><.

Did you try to add the option like I said ? To the /etc/modprobe.d conf file ?

ALSA provides generic configurations based on device type. It's not a per device configuration. It will be way easier to add the "options" directive in /etc/modprobe.d than finding a way to disable a specific device in ALSA conf.
 

NestorCayce

New Member
Did you try to add the option like I said ? To the /etc/modprobe.d conf file ?
I guess you meant in /etc/modprobe.d/alsa-base.conf ?

What I've tried is what is described here: https://doc.ubuntu-fr.org/audio_intel_hda
I tried with few models, like options snd-hda-intel model=targa-8ch-dig index=0.
I did not try all combinations / all models (did try with and without index)
I do not understand all the possible values (like for position_fix)
What surprises me is that in any case /proc/asound/card0 folder remains empty.

I added (today, in blacklist.conf) blacklist snd_hda_codec_hdmi => I see less hdmi entries in Pavucontrol but there is still one.



 

NestorCayce

New Member
Below is what I currently get from dmesg

[ 10.470272] [drm] radeon kernel modesetting enabled.
[ 10.470352] checking generic (d0000000 5b0000) vs hw (d0000000 10000000)
[ 10.470354] fb0: switching to radeondrmfb from VESA VGA
[ 10.470419] Console: switching to colour dummy device 80x25
[ 10.558377] [drm] initializing kernel modesetting (JUNIPER 0x1002:0x68BE 0x1458:0x21D5 0x00).
[ 10.558625] resource sanity check: requesting [mem 0x000c0000-0x000dffff], which spans more than pnp 00:04 [mem 0x000d0000-0x000d3fff]
[ 10.558631] caller pci_map_rom+0x71/0x1c0 mapping multiple BARs
[ 10.587158] snd_hda_intel 0000:02:00.1: Handle vga_switcheroo audio client
[ 10.594438] snd_hda_intel 0000:00:1b.0: no codecs found!
[ 10.594983] ATOM BIOS: GV
[ 10.595056] radeon 0000:02:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[ 10.595059] radeon 0000:02:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[ 10.595069] [drm] Detected VRAM RAM=1024M, BAR=256M
[ 10.595070] [drm] RAM width 128bits DDR
[ 10.612226] [TTM] Zone kernel: Available graphics memory: 1019082 kiB
[ 10.612229] [TTM] Initializing pool allocator
[ 10.612240] [TTM] Initializing DMA pool allocator
[ 10.612300] [drm] radeon: 1024M of VRAM memory ready
[ 10.612491] [drm] radeon: 1024M of GTT memory ready.
[ 10.612523] [drm] Loading JUNIPER Microcode
[ 10.630595] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/0000:02:00.1/sound/card1/input6
[ 10.644433] [drm] Internal thermal controller with fan control
[ 10.713414] coretemp coretemp.0: Using relative temperature scale!
[ 10.713705] coretemp coretemp.0: Using relative temperature scale!
[ 10.731886] intel_powerclamp: No package C-state available
[ 10.781360] intel_powerclamp: No package C-state available
[ 10.862829] [drm] radeon: dpm initialized
[ 10.869405] [drm] GART: num cpu pages 262144, num gpu pages 262144
[ 10.901541] [drm] PCIE GART of 1024M enabled (table at 0x000000000014C000).
 

Members online


Top