Ubuntu DNS bind9 problems

mmancina

New Member
Credits
0
Hi guys, I installed bind9 on my Ubuntu 16.04 machine.

But I've problems with resolving local domains. Extern like google.com works fine.

Here are my configuraton files and troubleshoots i've made.

Forward:
Code:
$TTL 2D
@       IN      SOA     localhost.mancina.home. root.mancina.home. (
                       22      ; Serial
                               8H      ; Refresh
                               2H      ; Retry
                               4W      ; Expire
                               3H )
@    IN    NS    localhost.mancina.home.
   IN    A    192.168.1.150

lenny    IN    A    192.168.1.150
homer    IN    A    192.168.1.110
Reverse

Code:
[email protected]:/etc/bind# cat db.mancina.home
$TTL 2D
@       IN      SOA     localhost.mancina.home. root.mancina.home. (
                       22      ; Serial
                               8H      ; Refresh
                               2H      ; Retry
                               4W      ; Expire
                               3H )
@    IN    NS    localhost.mancina.home.
   IN    A    192.168.1.150

lenny    IN    A    192.168.1.150
homer    IN    A    192.168.1.110

[email protected]:/etc/bind# cat db.1.168.192
$TTL 2D
@       IN      SOA     localhost.mancina.home. root.mancina.home. (
                       2      ; Serial
                               8H      ; Refresh
                               2H      ; Retry
                               4W      ; Expire
                               3H )

@       IN      NS      localhost.mancina.home.
150    IN    PTR    lenny.mancina.home.
110    IN    PTR    homer.mancina.home.
named.conf,local

Code:
[email protected]:/etc/bind# cat named.conf.local
//
// Do any local configuration here
//

// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";
logging {
   channel query.log {      
       file "/var/log/query.log";
       severity info;
   print-time yes;
       print-severity yes;
       print-category yes;
   };
   category queries { query.log; };
};
named.local.conf

Code:
zone "mancina.home" {
type master;
file "/etc/bind/db.mancina.home";
};

zone "1.168.192.in-addr.arpa" {
type master;
file "/etc/bind/db.1.168.192";
};
named.conf.options

Code:
[email protected]:/etc/bind# cat named.conf.options
options {
   directory "/var/cache/bind";
    forwarders {
        8.8.8.8    ;
    };
   dnssec-validation auto;

   auth-nxdomain no;    # conform to RFC1035
   listen-on-v6 { any; };
};
Code:
[email protected]:/etc/bind# named-checkzone db.mancina.home ./db.mancina.home
zone db.mancina.home/IN: loaded serial 22
OK
Code:
[email protected]:/etc/bind# dig lenny.home.local.

; <<>> DiG 9.10.3-P4-Ubuntu <<>> lenny.home.local.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40661
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;lenny.home.local.        IN    A

;; AUTHORITY SECTION:
.            10800    IN    SOA    a.root-servers.net. nstld.verisign-grs.com. 2017071301 1800 900 604800 86400

;; Query time: 33 msec
;; SERVER: 192.168.1.150#53(192.168.1.150)
;; WHEN: Thu Jul 13 20:12:13 CEST 2017
;; MSG SIZE  rcvd: 120
Code:
[email protected]:/etc/bind# nslookup lenny.home.local
Server:        192.168.1.150
Address:    192.168.1.150#53

** server can't find lenny.home.local: NXDOMAIN
Code:
[email protected]:/etc/bind# nslookup google.com
Server:        192.168.1.150
Address:    192.168.1.150#53

Non-authoritative answer:
Name:    google.com
Address: 216.58.205.110

I hope anyone can see an error in the conf or give me an advice what could be wrong.

TIA
Mattia
 


Lazydog

Member
Credits
0
My first guess would be it's because you don't have a "home.local" defined unless you have it configured in /etc/hosts then you wouldn't need bind. Looking at what you supplied I would think you are looking for "lenny.mancina.home".
 



Top