• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Ubuntu 22.04 WiFi driver not found: Mediatek mt7921e



I have similiar problem, what do i need to post i tried many things nothing seems to work. I have Asus Tuf Gaming A15 FA506IC. network driver mt7921e, it ocassionaly turns off and i need to reboot, i have a dual boot with W11.
'
03:00.0 Network controller [0280]: MEDIATEK Corp. MT7921 802.11ax PCI Express Wireless Network Adapter [14c3:7961]
Subsystem: AzureWave Device [1a3b:4680]
Kernel driver in use: mt7921e
Kernel modules: mt7921e
'
 
Have you tried disabling windows secure boot?
 
i didn't even had a firmware folder usr/lib used
  • dpkg -l | grep -E 'linux-firmware|wireless-regdb'

    sudo apt remove --purge wireless-regdb
  • sudo apt install --reinstall linux-firmware
    will see
 
so evereything went sideways after previous steps drivers were installed but nothing worked, wifi was disabled and bt also. drivers for screen also went missing. very bad combination, finally reinstalled ubuntu 22.04 and for now it works, and boot options that i installed GNU Grab i think finally apears at the start of PC
 

Members online

No members online now.

Latest posts

Top