Ubuntu 22.04 cannot connect to Eduroam


New Member
Oct 7, 2020
Reaction score
I've been using Arch Linux for a while now. I recently switched to 22.04 because I thought it was cool. However, I have a problem. My wireless works just fine. I've been using Eduroam here in dormitory for a while too. It seems that some Linux distros have a problem of identification with Eduroam network. Right now, I am at Adam Mickiewicz University.


This is how we are supposed to configure the network although the network certificate never works and saying "No CA certificate is required" seems to work on other distros.

eronis@eronis-MacBookAir:~$ cat /etc/modprobe.d/blacklist-bcm43.conf
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma
eronis@eronis-MacBookAir:~$ cat /etc/modprobe.d/blacklist.conf
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac

I have a Broadcom BCM43224 card for wireless.


Ubuntu has installed this driver automatically. I do not know what the issue is, but 21.10 used to work just fine with this Eduroam wifi. I do not know what's going on. My password is correct. I also have connected using the same steps on Arch already. Do you have any idea of what is going on?

Looks to me that "blacklist bcm43xx" should not be blacklisted since you have a BCM43224 card
Just a thought...

Those sort of systems require a certificate. I see you have one. Is it correct?

Also, their IT department has people who get paid just to help deal with this sort of issue. You're certainly not the first Linux user they've had in their system. So, I'd encourage you to reach out to them on Monday -when they have a full staff available.
Just a thought...

Those sort of systems require a certificate. I see you have one. Is it correct?

Also, their IT department has people who get paid just to help deal with this sort of issue. You're certainly not the first Linux user they've had in their system. So, I'd encourage you to reach out to them on Monday -when they have a full staff available.
I already filed a report yesterday. I hope they will respond on Monday. It's so frustrating. I've been using Linux since 2012, and it irritates me that I can't figure out what makes distro A able to connect when distro B cannot? I feel like an idiot right now. It just gets on my nerves :D
Last edited:
Funny enough, it doesn't have a configuration/installer for my university.

Adam Mickiewicz University
It seems you can still get your university listed from the FAQ.

What can I do to get my organisation listed?

Contact eduroam® administrators within your organisation and request that they add their organisation to the system. It will take at most one hour of their time to get things done.
Your bcm43xxx is blacklisted per your first post - Application blacklisting is the process of blocking some applications from having access to a network or system. See my post #2

I have an arch install that connects to University of Manchester eduroam just fine.

I have an ubuntu 22.04 install that does not. I have ran the eduroam-linux-TUoM-manchester.ac.uk.py install.

I tried then copying the
to the ubuntu install - still no dice. ca.pem same, settings same.

My ubuntu network controller: Qualcomm QCA9377 - I do not think this is related, as I can connect OK to a number of other SSIDs.

I'll update if I get it working.

I have the same problem here, I upgraded yesterday from Ubuntu 21.10 to Ubuntu 22.04 and my computer is not able to connect to eduroam anymore :(
I try to remove my previous configuration and reinstall with the Eduroam Configuration Assistant Tool, but it still doesn't works. It say that it doesn't recognize my login/password. But if I use a usb live with Ubuntu 21.10 I can still connect the computer to the network...

I have no idea what I could do to fix the problem. anyone have an idea?
Last edited:
Ubuntu 21.08

Hmm... I don't have any ideas, and again suggest you contact your uni's IT department as this is what they get paid for. But, for what it's worth, there's no such thing as Ubuntu 21.08.

They're versioned <YEAR>.<MONTH>, with releases in April and October - or 04 and 10. So, there's a 21.04 and a 21.10. Of those, only 21.10 is still supported - and the support for it will end shortly. It is known as an 'interim release' (as opposed to an LTS - 'long term support' release) and is supported for just 9 months. So, support for 21.10 will stop in June of 2022. If you're using 21.04, you're already out of support.

Note: None of that helps in this case, but it'll potentially get you back on the right track. Perhaps a current release (the new one is 22.04, and just came out a little while ago) will help get you sorted? If nothing else, it'll get you a version with long term support.
Did you see this:

There appears to be a workaround with some level of success.
Same here, unable to connect to eduroam since upgrade to 22.04 (at Catholic University of Louvain), I'll try the workaround of @KGIII and keep you in touch
I'll try the workaround of @KGIII
Welcome to the forums, if the work round doesn't work check you have the correct driver installed for your Wi-Fi card
check your network and drivers
terminal inxi -Nn

you may need to install inxi
Likely related:

The problem appears to be an upgrade to SSLv3, which deprecates SSL renegotiation. There's a workaround listed in the former link for Fedora, but I haven't yet been able to map it Ubuntu.
No matter what I did, Linux and this Eduroam always had an issue. If distro A managed to connect to it, the connection ended up unstable. For now, I'll use OSX on this laptop. It is the only OS I can use on this hardware that provides a stable connection with such network at the moment.

Members online

Latest posts