• We did not send an email asking for donations - please read this post.

Trying to open disk img file containing multiple EXT4, EXT3 and FAT32 partitions


New Member
Nov 27, 2021
Reaction score

I have made a full memory backup of my rooted Android phone and I would like to be able to mount the images of the Internal Memory and the SD Card in Ubuntu. The Internal Memory has many different partitons formatted in Linux compatible FS types. The SD Card is formatted in 2 partitions: one FAT32, one EXT4.

Trying to mount the images in DiskInternals Linux Reader yields some results:
When I try to mount the Internal Memory image, most of the mount points are correctly recognized, but the partitions inside the directory tree (deeper than root) are not mounted and result in empty folders.
When I try to mount the SD Card image, both partitions are readable.

However, the story changes in Ubuntu:
When I try to mount the Internal Memory image using the default Disk Image Mounter, Ubuntu adds it to the loop devices list, but does not mount it. On screen there is no displayed message.
When I try to mount the SD Card image using the default Disk Image Mounter, the FAT32 partition is correctly mounted and all the files are readable. The EXT4 partition is added to disks, shows up in Nautilus, but when opened, it displays a message saying the loop partition cannot be mounted read-only.

I tried extracting the userdata partition on its own, but Ubuntu still wouldn't mount it with no message displayed and Linux Reader still wouldn't make use of the deep mount points.

I tried analysing the disk image using fdisk and this is the output:
sudo fdisk -l sda.img

Disk sda.img: 29,81 GiB, 31989956608 bytes, 62480384 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start        End    Sectors Size Id Type
sda.img1            1 4294967295 4294967295   2T ee GPT

If Size 2T means 2TB, then that's obviously wrong since just above it says 29.81 GB.

I also tried analysing it with gdisk:
sudo gdisk -l sda.img

GPT fdisk (gdisk) version 1.0.5

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: not present

Creating new GPT entries in memory.
Disk sda.img: 62480384 sectors, 29.8 GiB
Sector size (logical): 512 bytes
Disk identifier (GUID): 182E51FA-C013-4218-A885-5520DA95AD11
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 62480350
Partitions will be aligned on 2048-sector boundaries
Total free space is 62480317 sectors (29.8 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name

No partitions listed, but MBR is protective, while no GPT is present? Makes no sense.

Trying to import this into GParted results in the program seeing an empty 32 GB disk image.

Is there any way I can open this file? DiskInternals Linux Reader can open the file somewhat, but as I said above, the partitions mounted inside the directory tree, not in root, are not visible, so a lot of data cannot be viewed using this program. The image must be readable by Ubuntu somehow, it can only be more native to such filesystems than Windows programs.

Any suggestions?
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online