Trouble Booting up Ubuntu

Deckwench

New Member
Credits
0
I'm finally dipping my toe into the ocean that is Linux, but things are not going swimmingly. Here's what's happening:

I have an eight year old Toshiba Satellite that's been in a closet for a year or two and I want to transform it into a Linux only machine. I DLed ubuntu-18.04-desktop-amd64.iso from the Ubuntu link I found hereabouts, moved it onto a thumbdrive. Did a cold start on the Toshiba, hit F12 and directed the setup to boot off the USB, which it could see and identified by name. As soon as I hit save and exit, Win7 proceeded to load.

After fussing around with the three different usb ports on the Toshiba I DLed a second copy of Ubuntu-- same name/source/size, using a different computer and copied it to another thumbdrive. No joy. I figured I'd burn a disk but NO! there's an error code on both the internal DVD and the double USB attachable DVD I plugged in.

I think Win7 is fighting me.

When I initially lit the Toshiba off it had to go through several restarts before it had enough juice to assemble the desktop. I was in and out of the room while it did this, and while my back was turned it did an update of some sort which which appeared to make some of the old settings incompatible with the some of the software. Both Chrome and MSIE were non-functional, and the whole DVD drive thing-- it's not the drivers-- seems to be changed from last use.

When I plug in the usb it makes all the proper sounds and blinkies, but not when I want to boot off of it. As soon as I save the boot to usb settings Win7 rolls in, too fast I think.

Got any ideas?

Fair winds
 


atanere

Well-Known Member
Credits
0
Hi again! I can't stay long tonight (12-hr day shifts the next couple of days)... but let's get started at least! BTW, Wizard is in Australia, so that can make a big difference in reply times.

First... did you just "copy" the Ubuntu .iso file to your USB flash drive? If so, that won't work at all because it does not make the flash drive bootable. If this is the case, you'll need to download a special program (several free ones available) that will correctly "burn" the .iso image to the USB.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,706
[Slightly edited by @atanere to bring this post over from another thread.]

Hello @Deckwench and welcome to linux.org :). Hope that's not the target computer in your picture, we might have some difficulties.

(Wizard appears in a puff of smoke, boat lurches, grabs for handrail, misses, falls overboard)

You'll need to give us the brand name and model of your computer (a Toshiba, you mentioned), so that we can Google up the specs, so we can see what's what and who's who, as my dear late mama used to say.

Also which Ubuntu, right down to the .iso name, eg ubuntu-18.4-desktop-amd64.iso or other? Did you download it from Ubuntu themselves or elsewhere? Did you perform an integrity check on the download (involves what are called hashsums or checksums)?

On that last question, there is a free tool you can download here for checking within Windows 7.

Use the SHA1sum or SHA256sum, MD5 is very passé (clunky, obsolete) nowadays.

If it is 18.04, you can get the sums to check from here.

Are you aware that, while the stick/pendrive may be bootable (and what tool did you use to burn it?), you need to enter your computers BIOS setup and alter the boot order temporarily or permanently to place the USB ahead of your hard drive?

Did you want to dualboot (install LInux alongside Windows) or to replace your Windows with LInux?

I don't use Windows myself, but if you can provide these answers, someone will be along soon to further assist.

Cheers

Chris Turner
wizardfromoz
 

atanere

Well-Known Member
Credits
0
OK, finishing up for me tonight.... I brought Wizard's post over as he and I would both encourage you to download the tool he linked to above so that you can "verify" your Linux downloads. It's not critical that you do this, but we highly encourage it so that we can all be sure that you received a complete and uncorrupted .iso file. Trying to install an operating system from a corrupted file is asking for trouble! :eek::D

I mentioned above about the difference between "copying" the .iso file to USB versus "burning" the image file... but I neglected to steer you to the free programs for this. There are many, actually, but here are a couple that both should work well in Windows 7:
https://etcher.io/
https://rufus.akeo.ie/

These programs will usually erase anything on the USB, so make sure that you don't have anything else important saved on it. To us they are fairly straightforward to use... but if you have trouble, let us know and we'll try to go through the steps with you. But your Linux USB won't boot unless you "burn" it with software such as this. When you get Linux installed, we'll guide you to other tools if you need to make more USB sticks. [EDIT: Etcher has a Linux version, so that might make this task a little more familiar later.]

We got that your laptop is Toshiba, but let us know the model number too. We will search out for specs or other info that might make a Linux install difficult and try to help find solutions, if needed. Let us know how much RAM it has. Ubuntu is somewhat of a heavy-duty Linux and it may not run well if your RAM is low. There are other Linux versions that we can recommend that may be better if that is the case.

Also, just as a bit of forewarning: the Ubuntu version that you downloaded has a rather "modern" desktop (called GNOME)... it is probably different than anything you've seen before. You may like it and think it's cool.... or maybe not. But Ubuntu has many different versions, and there are others besides Ubuntu as well that can provide a more traditional Windows-like desktop, if you'd prefer that. But by all means, start with what you have and see what you think. Once you get the hang of "verifying" the download and "burning" the USB.... you will find that it only takes about 20-30 minutes to actually install Linux on your computer. It's all this prep time that's a killer.

Cheers
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,706
...and I want to transform it into a Linux only machine.
Lady, you had me with that comment :). I work from a Linux-only household, burned my bridges (from Windows 7, which I might add I liked) 4 years ago. Haven't looked back. No identity theft, no depleted bank accounts, no malware, little to no spam ... and it's fun :p

Thanks Stan (@atanere ) for moving me ... my post. I/we hope @Will4 will come back to the other one, so we can help? :)

@Deckwench I was kidding about the computer, but I love it! 5.25" drive and all (in the pic), now those were floppies. Now I'll cease reminiscing and get down to your business.

three different usb ports
... is good, that can come in handy. Likewise the DVD drive, I take it it is a burner?

IMPORTANT

Before you go any further on the path to Linux:

  1. If you think that the updates that ran behind your back, so to think, adversely compromised some of your functions, can you check with Windows Restore to see if there is a Restore Point set automatically from which you can roll back?
  2. Check (if you have not already) for any personal data you wish to save from Windozey before you consider blowing it away. Murphy's Law suggests you might later find that you are missing something that was only on that computer ;). If that might take some time, you can always
  3. Dualboot, that is, install Ubuntu alongside Windows, which will generate a menu (called Grub) to choose which one to boot each time. I did this with this Toshiba Satellite S70t-A, circa 3 years old - shipped with Windows 8.1, hated the Metro Tiles look. Initially using Disk Management, could only shrink it by half (1TB to 500GB), then installed Linux, blew away the Windows and reclaimed the rest for Linux.
So if you let us know what Stan asked after, and what I asked for, and think about the options we offer, we'll see if we can get those fair winds blowing, eh?

Cheers

Chris Turner
wizardfromoz
 

Deckwench

New Member
Credits
0
I DLed Etcher and burned Ubuntu to the thumbdrive, but it now shows efi > boot > two tiny files. Can that possibly be correct? The Toshiba is still not booting off of if after I select it from Setup-- though I have not yet tried all the usb ports

Worse, the Bios no longer gives me Setup options. I got in once by hitting F2, but several tries using either F2 or F12 were ignored.

I'm about ready to try the Dual install the Wiz mentioned.
 

Deckwench

New Member
Credits
0
BTW, the purpose of this exercise is to see if I can find a word processor and spread sheet that my husband actually likes. He never liked Office and thought a Chromebook would be better. Now he's got a computer he hates that I don't grok at all.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,706
Afternoon all :)

@Deckwench if the main purpose is to get an alternative to MS Office, then I have this from another Post I made recently to another lady, Susan48:

BUT (I always have a but), if you are simply looking for an office suite, then Apache Open Office is a good one. I started using OO just after it was released, in the early "Noughties", and stopped using MS Office. Didn't miss it, used OO for 11 years or more then in late 2014 started using LibreOffice.

https://www.libreoffice.org/download/download/

LibreOffice was forked from OO, and is also available for Windows at the above link.
and

Just a heads up Susan, if you tread the "let's try Linux" path again, and want to 'port your Open Office.

Most of the major Linux players ship with LibreOffice pre-installed, and with LO having forked from OO, they are very similar and share a lot of the same dependencies. So on Linux, you can only have one or the other, because of conflicts.

But I would recommend you can use OO on your Windozey, try LO if you install Linux, see which one you prefer, and then we can cross the compatibility bridge when we come to it.

BTW documents written with one should be seamless with the other, so no dramas there, I believe.
Apache Open Office can be downloaded from

https://www.openoffice.org/download/

... just choose the "Windows (EXE)" option.

These programs are FOSS - Free and Open Source Software - and they are cross-platform, Windows, Mac, Linux.

BTW - @Salah_Mickey welcome. :). And yes, Stan (@atanere ) mentioned Rufus above. Either one of these would have thrown up an error if there was an incomplete operation, so the stick should be bootable, which means the problem lies elsewhere.

As a comparative (but from within Linux, as I don't have Windows), I have burned an Ubuntu .iso to an 8GB USB2.0 stick, in two ways:
  1. 1st, using a Linux command call "dd" from the command line interface. Then reformatted the drive again (to FAT32 each time) and
  2. 2nd, used Etcher to flash the drive.
The results are identical, and from my Linux File Manager (equivalent of Windows Explorer), can be displayed



SCREENSHOT 1 - CONTENTS OF LIVE UBUNTU USB

There are 13 items, comprising 11 folders and two (2) files. These are likely the two files you referred to.

Linux provides support for viewing and working with Windows files and folders, but Windows does not choose to extend the same. Therefore much of Linux is invisible from a Windows environment.

By right-clicking in my empty space in the contents pane, I am able to examine "Properties", as seen below:



SCREENSHOT 2 - BURNED .iso CONSUMES ENTIRE USB DRIVE

You can see that the USB stick is actually chock-full of goodies (683 items), and despite these taking up only 1.9GB, the entire 8GB drive is allocated. This is not unlike when you burn a music DVD or video DVD.

So @Deckwench , it is quite possible you have a fully operational Live Ubuntu stick, and that

I think Win7 is fighting me.
... is correct, that or the computer?

I'm about ready to try the Dual install the Wiz mentioned.
... can't be done, at the moment. The option to install Linux alongside Windows is offered by Ubuntu's Ubiquity Installer. Without being able to boot from the Live stick, you can't make that choice.

Did you get an opportunity to check that Windows Restore option I offered?

Cheers

Wizard
 

atanere

Well-Known Member
Credits
0
That Wizard... he's quick on the trigger with that magic wand of his! :D I was just going to say almost all of the same stuff, except he said it much better, and provided pictures! I made a new bootable USB tonight with Etcher and it came out exactly the same as his... so yours should be bootable too. You still may not be getting the Boot Menu just right, or there is a chance that your USB ports have problems. That would be pretty unusual though, so I'm hoping that you are just missing a step somewhere in this boot process.

Also as Wizard noted... it seems like your only goal may be to get a new Office product and maybe not to make the switch to Linux at all. There are many fine Office software programs available (for free) that will run in Windows. You'll have to let us know for sure what your goals are. Your old Toshiba will probably run nicely with Linux if you want to go that route, but how will it will run will depend at least a little bit on the amount of RAM, as I mentioned above.

OK, I'm done. Wizard covered everything pretty well at this point.

Cheers
 

Deckwench

New Member
Credits
0
screenshot2.jpg

Well look at that. So it's there but the Toshiba won't boot from it. Should I be moving files around or renaming?

I could not make heads or tails out of burning with Rufus.

I'm flashing another usb on Etcher to see if it comes up differently.

Wiz I will attempt the Windows fix if the bugger still doesn't boot after I think I have an actually bootable disk.

Thanks for the Word processor links. Will absorb all that later.

atanere, did you mention other Ubuntu DLs that might be better for a computer that will have very little on it-- word processor, spreadsheet, minimal photo editing?

Second Etcher flash was apparently identical to the first.

I go try booting again.
 

atanere

Well-Known Member
Credits
0
I just went to Windows 7 to give Etcher a test... interesting! It only shows like yours... the efi folder with the small files inside. But it does boot up my computer! When I take the same flash drive into Linux, it shows all the files like Wizard and I had earlier. So at the moment I'm just guessing that Window is somehow hiding them. But it does still boot.... so you may have some other issue. Just for fun, if you have another computer, try booting it up on the USB. (Be sure to only select "Try Ubuntu" and not "Install" or you know... trouble!)
 

atanere

Well-Known Member
Credits
0
Sorry, but I've got to run... almost midnight here and I've got one more early day shift tomorrow. Glad you've got your first Linux boot going now! Look around and play with it awhile. I think I said before that this is a rather "modern" style of desktop, and you may or may not like it as it takes a little to get used to it. There are many other choices available, so this is just the beginning (unless you like this one a lot).

Cheers
 

Deckwench

New Member
Credits
0
Thanks, atanere!

The Toshiba's in another room happily installing away. This time I held F2 down immediately after punching the start button and it dropped me into Setup. I selected USB, then F10 to exit. Then I punched F12 and hit enter on the usb option, which had not saved and it booted.

I've looked over the included software and it all looks grand.

One little sidebar, though: almost every time I log into the forum it tells me my password is incorrect. But it's not. No caps or cirrylic letters, but I hit the Forgot Password link and put in the same password once again. Is this like a ritual for newbies?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,706
Now, now, be kind :), you're not holding your mouth the right way. What Browser are you using, IE? It should be able to save your password, unless it is the one you also use for banking, &c.

I love that dancing banana BTW, I've saved it :rolleyes:

Did you opt to replace Windows with Linux, or to run it alongside Windows (dualboot)?

I'm out of here for my evening, but I'll look forward to the next installment. (install, get it? o_O)

Wizard
 


Members online


Top