Touchpad stops responding in MX Linux


Deleted member 140690

I had a perfecty working MX Linux setup on a small Laptop.
Today when the power cable was disconnected, the touch pad
stopped responding, the keyboard works, am able to touch the power button,
this brings up the menu for logging out shutting down etc, and I chose reboot,
the same thing happens again after about Five minutes, it does not matter which
program an in, this does not happen while plugged into the power, it did not happen
yesterday while I ran on battery either, the only thing I did was tick the box to remember
the session again when logging in, I undone this, tried a few reboots and full shutdowns
withe the session box un ticked.

Any idea what to look for, where to look, seems to be a synaptics touchpad.

I'm a bit unclear. Only having problems with the touchpad, when your laptop is unplugged? Or are you having other hardware issues as well?

You didn't run any updates or make any changes other than "remember session?"

What happens if you boot to a live image? Does your touchpad stop working?
What DE are you using? MX uses Fluxbox by default. Did you try a different DE?
It sounds like a power management issue to me? I don't know enough about MX to really chime in.
Good morning.
Let's start with a very basic step, switch the machine on then hold the power button down for 60 seconds, this should purge the capacitors and re-boot the BIOS, just in case it's developed a BIOS management error
Actually, it doesn't - it is Xfce, but Fluxbox is there in the mix.

See here


My mistake. They have Xfce, KDE and Fluxbox editions.
It sounds like a power management issue to me? I don't know enough about MX to really chime in.
This is what I was thinking. But I don't see how "save session" would have anything to do with it.
But I don't see how "save session" would have anything to do with it.

If I'm understanding the OP properly, it doesn't - that'd just be coincidental.
Well am on battery power now after a fresh install of MX Linux.
Initially the built in software notifier in the panel said up to date.
But when I ran sudo apt update and sudo apt --list upgradable I
got a list of items that I could update.
Can anyone tell from the list below if there is anything on it that
could break my touchpad / freeze my onscreen pointer like before.
$ sudo apt update
Hit:1 bullseye InRelease
Hit:2 bullseye-updates InRelease
Hit:3 bullseye-security InRelease
Hit:4 bullseye InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
36 packages can be upgraded. Run 'apt list --upgradable' to see them.
$ sudo apt list --upgradable
Listing... Done
apt-notifier/mx,mx 22.05.02mx21 all [upgradable from: 22.01.01mx21]
firefox/mx 100.0~mozillabinaries-1mx21+1 amd64 [upgradable from: 99.0~mozillabinaries-1mx21+1]
formatusb/mx 22.04 amd64 [upgradable from: 21.05.04]
gir1.2-javascriptcoregtk-4.0/stable-security 2.36.0-3~deb11u1 amd64 [upgradable from: 2.34.6-1~deb11u1]
gir1.2-webkit2-4.0/stable-security 2.36.0-3~deb11u1 amd64 [upgradable from: 2.34.6-1~deb11u1]
gzip/stable-security 1.10-4+deb11u1 amd64 [upgradable from: 1.10-4]
libavcodec58/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libavfilter7/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libavformat58/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libavresample4/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libavutil56/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libjavascriptcoregtk-4.0-18/stable-security 2.36.0-3~deb11u1 amd64 [upgradable from: 2.34.6-1~deb11u1]
liblzma5/stable-security 5.2.5-2.1~deb11u1 amd64 [upgradable from: 5.2.5-2]
libpostproc55/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libswresample3/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libswscale5/stable-security 7:4.3.4-0+deb11u1 amd64 [upgradable from: 7:4.3.3-0+deb11u1]
libwebkit2gtk-4.0-37/stable-security 2.36.0-3~deb11u1 amd64 [upgradable from: 2.34.6-1~deb11u1]
linux-compiler-gcc-10-x86/stable-security 5.10.113-1 amd64 [upgradable from: 5.10.106-1]
linux-headers-amd64/stable-security 5.10.113-1 amd64 [upgradable from: 5.10.106-1]
linux-image-amd64/stable-security 5.10.113-1 amd64 [upgradable from: 5.10.106-1]
linux-kbuild-5.10/stable-security 5.10.113-1 amd64 [upgradable from: 5.10.106-1]
linux-libc-dev/stable-security 5.10.113-1 amd64 [upgradable from: 5.10.106-1]
lo-main-helper/mx,mx 22.04.04mx21 all [upgradable from: 22.04.01mx21]
mx-apps/mx,mx 22.05.01mx21 all [upgradable from: 22.01.01mx21]
mx-cleanup/mx 22.5 amd64 [upgradable from: 20.8]
mx-installer/mx 22.5 amd64 [upgradable from: 22.4.01]
mx-live-usb-maker/mx 22.4 amd64 [upgradable from: 22.1.01]
mx-network-assistant/mx 22.4.02 amd64 [upgradable from: 20.8]
mx-packageinstaller-pkglist/mx,mx 22.04.04mx21 all [upgradable from: 22.04.01mx21]
mx-packageinstaller/mx 22.4.3 amd64 [upgradable from: 22.4]
mx-repo-list/mx,mx 22.5 all [upgradable from: 22.3]
mx-snapshot/mx 22.4.01 amd64 [upgradable from: 22.3.01]
openjdk-11-jre-headless/stable-security 11.0.15+10-1~deb11u1 amd64 [upgradable from: 11.0.14+9-1~deb11u1]
openjdk-11-jre/stable-security 11.0.15+10-1~deb11u1 amd64 [upgradable from: 11.0.14+9-1~deb11u1]
rtl8812au-dkms/mx,mx all [upgradable from: 4.2.2-1~mx21+1]
xz-utils/stable-security 5.2.5-2.1~deb11u1 amd64 [upgradable from: 5.2.5-2]
$ ^C
I think I have used the right command below to list the repos my
system reaches out to, are there any I should remove, I really only
want to run the stable releases.

$ sudo apt-cache policy
Package files:
100 /var/lib/dpkg/status
release a=now
500 bullseye/non-free i386 Packages
release v=21.0,o=MX repository,a=mx,n=bullseye,l=MX repository,c=non-free,b=i386
500 bullseye/non-free amd64 Packages
release v=21.0,o=MX repository,a=mx,n=bullseye,l=MX repository,c=non-free,b=amd64
500 bullseye/main i386 Packages
release v=21.0,o=MX repository,a=mx,n=bullseye,l=MX repository,c=main,b=i386
500 bullseye/main amd64 Packages
release v=21.0,o=MX repository,a=mx,n=bullseye,l=MX repository,c=main,b=amd64
500 bullseye-security/main i386 Packages
release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=i386
500 bullseye-security/main amd64 Packages
release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
500 bullseye/non-free i386 Packages
release v=11.3,o=Debian,a=stable,n=bullseye,l=Debian,c=non-free,b=i386
500 bullseye/non-free amd64 Packages
release v=11.3,o=Debian,a=stable,n=bullseye,l=Debian,c=non-free,b=amd64
500 bullseye/contrib i386 Packages
release v=11.3,o=Debian,a=stable,n=bullseye,l=Debian,c=contrib,b=i386
500 bullseye/contrib amd64 Packages
release v=11.3,o=Debian,a=stable,n=bullseye,l=Debian,c=contrib,b=amd64
500 bullseye/main i386 Packages
release v=11.3,o=Debian,a=stable,n=bullseye,l=Debian,c=main,b=i386
500 bullseye/main amd64 Packages
release v=11.3,o=Debian,a=stable,n=bullseye,l=Debian,c=main,b=amd64
500 bullseye-updates/main i386 Packages
release v=11-updates,o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=main,b=i386
500 bullseye-updates/main amd64 Packages
release v=11-updates,o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=main,b=amd64
Pinned packages:
$ ^C
And now my pointer has frooze on the screen, I only ran sudo apt update,
but did not do sudo apt upgrade, nothing was installed, so what ever is causing
my pointer to freeze is still doing it.
Am going to change browser now to see if that helps as I added a youtube
and an add blocker to firefox, using a browser I have not modified should
rule out the two add blockers being the culprit.
which build of MX did you install?
This is from the MX Linux site, it redirects to sourceforge,
I downloaded the first package on the list, for computers
a few years old, 64 bit as below.

Three different desktop options are available

Xfce (our flagship desktop)

  • MX-21.1_x64, with
  • Three different desktop options are available

    Xfce (our flagship desktop)

    • MX-21.1_x64, with a standard 64 bit kernel and hardware support from Debian Stable. Suitable if your PC is a few years old.
  • a standard 64 bit kernel and hardware support from Debian Stable. Suitable if your PC is a few years old.
Looking at my repos from MX Tools repo manager shows
my repos to be bullseye, should they not be newer than this.
No buster is still a current stable release
have you checked both the BIOS and the MX power settings,
also look at open Settings, choose Mouse and Touchpad as the first device.
And now there is an ahs repo in the mix, this is odd as I used the reset repo list
with the restore original apt sources button in resp manager, shoud this ahs
repo be there, I downloaded an ISO that did not mention this ahs repo, so how
did it get there, this is becoming a mixed bag here, is this ahs repo not for very
new packages that may have bugs, if so why include it in the stable download
for older computers.

Last edited by a moderator:
Where is option to chose touchpad and mouse as the first device.
I don't see anything in the Bios that alters power state, or input
devices, just boot order, password, and allow full USB install,
its either full or Partial, I disabled safe boot and fast boot, cant't
see that having any bearing on what is happening with the frozen mouse.
Am using Brave now, and so far no frozen pointer, I will keep on doing so
for a few days, then try Fiefox again which has those two blocking extentions
added, there is none added to Brave.
Last edited by a moderator:
sudo apt update now shows two packages for update, I think they are wifi drivers,

rtl8812au-dkms/mx,mx all [upgradable from: 4.2.2-1~mx21+1]
rtl8814au-dkms/mx,mx all [upgradable from:]

then when I try to update them, I get the message telling me they were not updated
and held back, I don't understand this either, my past experience with Linux has
been that updates were installed, never held back.
Anyway I am off for tonight, will see how this issue goes and
report back, thanks to all who posted, keep safe wherever you are.

Members online