• Important: We recently upgraded our forum software - please let us know if you run into any issues.

Toshiba Satellite seems Linux proof

Kyler Sorensen

New Member
Granted this would only be my 2nd Linux install but I have tried everything. I am trying to install Lubuntu on an acer satellite C55-B5100. Going through the installer when It comes to setting up partitions, I choose to erase everything and install Lubuntu (I have also tried other configuration as well). I am not trying to duel boot. I want this to be the sole OS. I tried Ubuntu Mate too just to see if that made a difference, it did not. I can run both distros live off of a USB. I have tried multiple attempts to install but each time it gets to the end of the install it fails. It says "grub2-efi-amd64-signed" failed to install. I have googled and read dozens of accounts of people that get a similar error. I've read that people have solved this issue by connecting to the internet and by not connecting to the internet. I have tried installing a boot repair after the failed install. I have tried every setting in the bios. If there are any more ideas on what I can try that would be great. But, I am gathering that it could be something on the hard drive that could be preventing this to finish installing. Is that possible and if so would a new hard drive solve this problem.
Thanks for entertaining my post. I was introduced to Linux about 5 years ago but at the time I was not too interested. I thought it seemed cool but I had other interests. Fast forward to today and I don't know anyone that has even heard of Linux, so I am grateful that I found this forum. Thanks again.
 


Kyler Sorensen

New Member
Well, I think I have disabled secure boot. Every time I go back in it has reverted back to enabled. I even make sure to exit and save. So I am not sure how long or if all, it is disabled. Same with all the other settings in the bios. They all have reverted back the next time I go to the bios page.

Thank you for your suggestion. I will try Manjaro and see if that changes anything.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
It ain't over until the fat lady sings, Kyler. :) I have had an Acer (no longer in use) running 40 Linux Distros on it. Different flavours, different Families.

(Wizard appears in a puff of smoke)

What OS is on there, currently - Windows, if so which version? Or a Linux, if so which?

Out for my evening soon, DownUnder

BTW G'day and welcome to linux.org :). Manners, gentlemen :D

Cheers

Chris Turner
wizardfromoz
 

Kyler Sorensen

New Member
Noob here (surprise), I just realized I titled the thread wrong. The PC in question is a Toshiba Satellite. Thanks for the responses. The computer had windows 10 installed. My first attempt at installing lubuntu erased windows. Following Peer's advice I installed Manjaro yesterday. The installation succeed but there is still an issue booting, as of right now, nothing will boot on its own. I have to boot from the usb drive.
To the question. "Does your bios support UEFI boot mode?" I believe it does. There is an option to change it on the setup page that comes up after pressing F12 apon start-up.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I just realized I titled the thread wrong.
Fixed for you, Kyler :), I had wondered ... I have a Toshiba Satellite too, has nearly 50 Linux on it. o_O

My first attempt at installing lubuntu erased windows.
:oops: Hope you had any personal data safeguarded? What has likely happened is that during the installation you have been presented with a screen that offered options such as -

Erase Disk and install Lubuntu

Install Lubuntu alongside Windows

(grayed out, perhaps) LVM (Logical Volume Management)

(grayed out, perhaps) Encrypt Home partition and

Something Else

You have likely chosen the first one.

On Manjaro, do you know which DE (Desktop Environment) you choose to download? It might be eg MATE, Cinnamon, Xfce, Deepin or a few others. The name will be incorporated into the file name of the downloaded .iso

Wiz
 
Last edited:

atanere

Moderator
Gold Supporter
will replacing the hard drive make this easier?
No, I think your trouble is simply between your BIOS/UEFI settings and your choice of Linux distro. Some distros can use UEFI and Secure Boot, some can use UEFI but NOT Secure Boot, and some cannot use UEFI or Secure Boot at all.

Your comment in Post #3 above makes me question whether your are able to save your BIOS/UEFI settings. These settings can vary a lot between different manufacturers because unfortunately they do not all follow the UEFI standards the same way. In some systems, you have to set a BIOS/UEFI password to be able to make the changes take effect, such as disabling Secure Boot. After successfully changing the settings, the password can be removed. In some systems (like my HP laptop)... after disabling Secure Boot and saving the change.... the next boot cycle require a 4-digit number to be entered or else it will not disable Secure Boot. I don't know if your system needs a step like these, it's just an example of how the different systems behave differently.

The only hard drive issue is whether the partition table will be set to GPT (new method for UEFI) or to MBR (old method for BIOS). The distro you install should take care of this for you during the installation. So my guess is that your BIOS/UEFI settings are not saved to the settings needed to match your distro.... and a new hard drive will not change this.

Basically, I think you need to keep fiddling with your BIOS/UEFI settings and/or trying different distros. I have had good luck with Linux Mint installing with any combination of BIOS/UEFI settings, but I can't promise you'll have the same success. Telling your distro to "use the entire drive" as you are doing is also the best choice because there should be no confusion on where and how the GRUB bootloader is installed. GRUB installs differently between BIOS/MBR and UEFI/GPT systems, and that seems to be what the error is telling you.

Good luck!
 

dos2unix

Member
The partition table type, doesn't matter that much. (Again as others have it may depend on what your UEFI/BIOS supports).
But I can tell you from experience, I have installed efi boot files on DOS partitioned disks, and I have installed biosboot on GPT partitioned disks.
So you can't always use the partition table type as a definitive way to be sure.

Many modern BIOS/UEFI's let you assign which device boots which way.
For example, you could have a netboot/PXEboot that boots under legacy BIOS, and a hard drive that boots under UEFI.
To make things even more confusing, you can even do things like kickstart under legacy BIOS, but actually install a efi boot system.
That way when the system boots from the hard drive, it will still boot into efi mode, even though you installed it in BIOS mode. :)

Dual boot mode (BIOS/UEFI) usb distro drives are generally a good way to tell what your system is setup for.
Most are smart enough to either install a /biosboot partition (legacy BIOS, max size = 2MB),
..or a /boot/efi (UEFI, max size = 200MB) parition. efi has it's own fstype.
 

Members online


Latest posts

Top