tools for iso2usb


Well-Known Member
available tools for getting on iso onto a usb stick and in a state that it can be booted both from Linux or using Windows

a work in progress...

1) ventoy

├── KNOPPIX_V8.6-2019-08-08-EN.iso
├── System Volume Information
├── bionicpup64-8.0-uefi.iso
├── bodhi-5.1.0-64.iso
├── linuxmint-19.3-mate-64bit.iso
├── linuxmint-19.3-xfce-64bit.iso
├── lubuntu-18.04-alternate-i386.iso
├── rescatux-0.73.iso
└── slackware64-current-install-dvd.iso

the above is a"tree" view of whats on my 14+ gig usb stick . It might surprise some that there is a bunch of iso's and not only that that the iso's are in tact and in the same state as they were when downloaded .

How did i arrive at the above and whats going on ?

Well its the ventoy system

first lets see how to get it and use it from Linux

get download (latest release is 1.0.12) :

get the tar.gz and navigate to where it is(probsbly /home/usr/downloads) :

open terminal

//go to downloads

bash-5.0$ cd /home/andrew/Downloads
bash-5.0$ ls --color

//move it to somewhere convenient maybe Desktop

mv ventoy-1.0.12-linux.tar.gz /home/andrew/Desktop/

//navigate to Desktop
bash-5.0$ cd ~/Desktop

//see if its there

$ ls --color southend.jpg
ZAP_2.9.0 ventoy-1.0.12-linux.tar.gz

//now we unpack the tar.gz

$ tar -xzf ventoy-1.0.12-linux.tar.gz

with the new release we will now get :

├── boot
├── tool
└── ventoy

now we navigate inside currently we are at :

bash-5.0$ pwd

$ cd ventoy-1.0.12
//confirm contents
bash-5.0$ ls --color boot tool ventoy

Now we are going to use to format a usb stick. First detach everything from pc that might confuse; connect usb and get name:

$ su ->password->#

# fdisk -l
i got /dev/sda1
and ..
Disk /dev/sdb: 3.75 GiB, 4007624704 bytes, 7827392 sectors
Disk model: DataTraveler G2

here application of common sense is needed. disks normally start with sda , then sdb, sdc etc usually with hd's first. So my usb stick of circa 4gig called /dev/sdb is the one is need.

the code to run as root will be
# sh -i /dev/sdb

//but first we need to give it permission to run so before that we do

# chmod +x

you will get output such as data will be lost ,will eraze etc ..

when finished the label for the usb will change to "ventoy" also when you look inside its just a blank space.. what happened ? well the script did 2 things it set up 2 partitions ; one you can not see but does the heavy lifting when used and the blank area where you can drag and drop linux.iso

..go back to start and have another look at my 14 gig stick. When i power down hit
F9 to get boot menu i will see ventoy splash ,listing all iso's. By up and down keyboard arrows i can select any to boot. When i do that the stuff unseen in partition 2 does the magic
Last edited:

70 Tango Charlie

Well-Known Member

Hi Cap,
I have downloaded Ventoy and extracted it to my desktop.
Now I am not sure what to do next.

70 Tango Charlie

Well-Known Member
I owe you a beer! Next time we meet!
What you have posted is a mouthful. I'll follow steps and let you know when success has struck.
captain-sensible said:
for unzipping ventoy-1.0.08b1-linux.tar.gz

its going to be:

tar -vxzf ventoy-1.0.08b1-linux.tar.gz

then you will see : ventoy-1.0.08b1

where ventoy-1.0.08b1 is a directory with contents :

├── boot
├── tool
└── ventoy

go inside :

cd ventoy-1.0.08b1

see whats there:
bash-5.0$ ls --color boot tool ventoy

now you need to take off everything from your PC that might confuse you .

Attach a usb that you are going to use for ventoy.

check what it is to reference later:

for you :

sudo fdisk -l

for me : su -> root

# fdisk -l

mine shows:

Device Start End Sectors Size Type
/dev/sda1 2048 206847 204800 100M EFI System
/dev/sda2 206848 6313983 6107136 2.9G Linux swap
/dev/sda3 6313984 122140671 115826688 55.2G Linux filesystem

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 7866367 7864320 3.8G b W95 FAT32

so applying a bit of common sense sda1,sda2.sda3 is my main pc slackware (is best) install and sdb1 is a usb stick

now where am i ?

bash-5.0# pwd
// still inside ventoy (good)

first give permission for ventoy script tro run
for you :
sudo chmod a+x

//for me:
# chmod a+x

now we run it:

for you if your stick from fdisk was called /dev/sdb1

sudo sh -i /dev/sdb

//note the actual stick is sdb and not sdb1 ; sdb1 is a partition we want to install to usb not a partition on it.

for me :
# sh -i /dev/sdb
Click to expand...

Hi Cap,
Well, so far so good. I got as far as these screenshots show. My stick is sdd.


So, at this point I ran the umount command thus:


As you can see, it still shows as mounted. Now where do I go from here?

Thanks for your help.


70 Tango Charlie

Well-Known Member
First, I owe Dok an apology for jumping in without an invite first. I owe him a beer!

Now on to answering Cap;
Mouse over, right click results in nothing about mount.

On df -aTH here's a screenshot:


Looks like the one yours shows. Perhaps it is being auto-mounted.

Here are all the specs on my cp:


Mate 19.3 Tricia

Thanks. OG

70 Tango Charlie

Well-Known Member
If anyone else has this problem, follow Caps' instructions.
Problem solved. Thanks.

70 Tango Charlie

Well-Known Member
I will put it all together and post it after Wiz has moved my stuff into a new thread.
And, I now owe Wiz a beer for all he does to cover for this Old Guys' wrong moves.



Well-Known Member
i guess its all moved ..

One advantage of Ventoy, is that with say a 14 gig stick you can have several iso and boot any one of them. I significant jump to another level would be if persistence was available; then you would be able to install extra software to the live OS ,which would not disappear.

In release 1.0.12 there is now a script which basically creates an ".img" file where changes are stored. IN running the script i got errors so played with manually creating a 1gig .img .

The .img file in ventoy docs is persistence.img so i used:

fallocate -l 1G pesistence.img

i then mounted that to /dev/loop0

formated with gparted to ext4 and labelled file system "casper-rw"

docs say use .json .

i used :

"control" : [

"persistence" : [
"image": "Linux/linuxmint-19.3-xfce-64bit.iso",
"backend": "/Data/persisitence.img"


ventoy.json is being picked up but i just can not get option of persisitence with linuxmint-19.3-xfce-64bit.iso if anyone can get it working please let me know !

70 Tango Charlie

Well-Known Member
Hi Cap,
I can report now on what happened with trying to get Ventoy to work.
I decided to try downloading and installing on my 'experimental laptop' to see if there was any difference. There was.
I followed your instructions from start to finish and it all worked out fine on my laptop.
That was an affirmation of your instructions.

It turns out that there are some other problems with my main cp. Don't know exactly what they are, but I think it has something to do with some internal hardware.
It was getting close to the time to get a new cp anyhow, so I will just keep that old HP around for parts or whatever {maybe let the wife use it to play her games}.
When I get the new one in a few days, I will try to install and run Ventoy on it. {I'll give the specs on it when I get it set up}.
I'll be back when the new cp arrives.


Well-Known Member
apart from knoppix which has most stuff installed as default unless the aim is to install an OS most other OS as live are not useful due to the fact that anything you install will disappear at shutdown.

I managed to get Ventoy working with persistence with bionic pup 8, MX linux and
linuxmint-19.3-cinnamon-64bit.iso. persistence is afforded via a ventoy.json file and a 1 gig .img with file system casper-rw . if anybody wants the tree of usb structure and json let me know

Members online

No members online now.