Terminal not accept passwords

CptCharis

Well-Known Member
Hello guys, Hope all of you have a great day!!!

Since I updated to "Tessa" I have spot out this two issues:

1. I can't minimize any window (what ever I will do windows closing) this is the minor one problem

2. My terminal is not accepting any password exept sudo ( i.e I can't ssh ) this is the major problem

Do anybody else is facing this kind of issues?
 


Condobloke

Well-Known Member
G'day Capta, just for clarity, you are referring to Linux Mint 19.1 (tessa)...?

I would wait for Tina....19.2.

19.1 appears to have quite a few 'weird' problems such as you are experiencing

Is it too late/inconvenient to reinstall...?......was the download verified ?.....has it updated since installation ?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day Capta, is that Tessa MATE, Cinnamon, or Xfce?

Wiz
 

CptCharis

Well-Known Member
Good evening guys !!!
Yes is tessa 19.1 Mate, verified download and many times updated so far.
Yes sir it's difficult to re-install for the moment. ( I have to go back home )
 

Condobloke

Well-Known Member

atanere

Well-Known Member
Hi Captain! This article might help you solve the window minimizing problem.

You say that sudo works and accepts your password, so please describe more how you use ssh, or how you enter a password that is not working correctly.

Cheers
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Capta can you give us the output of

Code:
sudo cat /etc/shadow
Don't worry, your passwords will not be compromised, they are encrypted.

Wiz
 

CptCharis

Well-Known Member
Good morning guys

Dear @atanere, problem No 1 solved thanks your response. I really appreciate.
Dear @wizardfromoz here below output of my /etc/shadow

Code:
root:!:17898:0:99999:7:::
daemon:*:17882:0:99999:7:::
bin:*:17882:0:99999:7:::
sys:*:17882:0:99999:7:::
sync:*:17882:0:99999:7:::
games:*:17882:0:99999:7:::
man:*:17882:0:99999:7:::
lp:*:17882:0:99999:7:::
mail:*:17882:0:99999:7:::
news:*:17882:0:99999:7:::
uucp:*:17882:0:99999:7:::
proxy:*:17882:0:99999:7:::
www-data:*:17882:0:99999:7:::
backup:*:17882:0:99999:7:::
list:*:17882:0:99999:7:::
irc:*:17882:0:99999:7:::
gnats:*:17882:0:99999:7:::
nobody:*:17882:0:99999:7:::
systemd-network:*:17882:0:99999:7:::
systemd-resolve:*:17882:0:99999:7:::
syslog:*:17882:0:99999:7:::
messagebus:*:17882:0:99999:7:::
_apt:*:17882:0:99999:7:::
uuidd:*:17882:0:99999:7:::
cups-pk-helper:*:17882:0:99999:7:::
kernoops:*:17882:0:99999:7:::
rtkit:*:17882:0:99999:7:::
avahi-autoipd:*:17882:0:99999:7:::
usbmux:*:17882:0:99999:7:::
ntp:*:17882:0:99999:7:::
lightdm:*:17882:0:99999:7:::
dnsmasq:*:17882:0:99999:7:::
saned:*:17882:0:99999:7:::
nm-openvpn:*:17882:0:99999:7:::
avahi:*:17882:0:99999:7:::
colord:*:17882:0:99999:7:::
speech-dispatcher:!:17882:0:99999:7:::
pulse:*:17882:0:99999:7:::
hplip:*:17882:0:99999:7:::
geoclue:*:17882:0:99999:7:::
cptcharis:$6$0fs8rhP0$eV1zQCww41fWCdECWMkSxru2ERj4D5x3xZUCJ4qHTyIsC9q5mmbZYgwXCTlmqfpsQ4jv31RpTmji5yAZQrne8/:17898:0:99999:7:::
mysql:!:17995:0:99999:7:::
Dear @Condobloke I have timeshift snapshots available but I keep this solution as the final one, since I recently download python virtual environment and is not included on my latest snapshoot.

@atanere back to you sir, I recently install ubuntu server in my virtualbox and trying to ssh into this installation, I realized that typing my passwd, no typing allowed at all.
the same also when I download and Install update of VPN
 

atanere

Well-Known Member
So... it is really the Ubuntu server in VirtualBox that is prompting for (and not accepting) the password... is that correct?

Just as a simple thought, but have you tried to carefully type the password and hit Enter when you are prompted? Many Linux command line functions do not show the ****** feedback when you enter passwords. Linux Mint only just started showing the star characters recently, so I'm just wild-guessing that you may have become used to seeing them.

But I also "wild-guess" at a lot of things too! :eek::confused::D

Cheers
 

CptCharis

Well-Known Member
So... it is really the Ubuntu server in VirtualBox that is prompting for (and not accepting) the password... is that correct?
Yeap you are correct! I didn't think that.

Just as a simple thought, but have you tried to carefully type the password and hit Enter when you are prompted? Many Linux command line functions do not show the ****** feedback when you enter passwords. Linux Mint only just started showing the star characters recently, so I'm just wild-guessing that you may have become used to seeing them.

But I also "wild-guess" at a lot of things too! :eek::confused::D

Cheers
Ok let's say that this is correct and I'm not typing correct my passwd. But if I'm correct when ssd you have to type your own passwd correct? and not server's passwd ? which in my case is the same one?
 

atanere

Well-Known Member
@Rob and others will know more about ssh than me. :confused::eek::D

But for some more of my wild-guessing.... (and "assuming" which is often a bad idea)....

1. I assume you have the connection working between the Ubuntu virtual server and whatever you are connecting from (either the same computer, or via your own network, or internet).

2. I assume you have the ssh daemon running on the server.

3. I don't think you can log in as root via ssh (others may correct me). So it seems like it is important that your server has a user account already established with sudo and ssh permissions. This user account is unique to the Ubuntu server though... it is not your primary login on the host computer, though perhaps there is no problem using the same username on both.... but just that Ubuntu must have the user added too.

Well, I'd better quit guessing and looking so foolish! :confused::eek::D

It's been a long day and more beer is needed. :D:D:D

Cheers
 

CptCharis

Well-Known Member
@atanere Probably your are right.
I have a user account in Ubuntu server, is prerequisite during installation but I haven't check that ssh daemon is active (usually in Ubuntu is active by default) and I haven't check sudo and ssh permissions.
I will revert.
Thanks !!!!
 

CptCharis

Well-Known Member
Dear @atanere and all of you guys, good morning!
I checked all of the aboves and I couldn't find something wrong, so I decided to make a fresh install of Ubuntu server into my virtualbox.
After new installation problem solved. I can't explain it, something went wrong during previous installation.
Anyway, now everything is ok.
Of course problem was ubuntu server and not MINT terminal.
 

atanere

Well-Known Member
Happy to hear that you solved it, Captain! (Even if you aren't sure what the solution was! :D)

That is certainly one of the great things about VirtualBox or other virtualization systems.... it's so easy to start fresh and tinker with different systems, different settings, different configurations, etc.

Cheers
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Legend :D
 

Members online


Latest posts

Top