Swapped drives

E

Edwin Humphries

Guest
Hi all, I have a weird issue:

I have 2 refurbished laptops: an ASUS N61J and a Toshiba Satellite L850.
I got the ASUS setup and working fine a while ago with Linux-Mint 17.1 x64, then acquired the Toshiba which has more grunt. Got it setup OK, but realised that it had a smaller HDD than the ASUS. So I swapped the drives over. Now the Toshiba, with the larger drive, boots up fine; however the ASUS, with the smaller drive, doesn't boot at all. It doesn't even display the "insert boot disk" prompt. I can boot up to Live Mint DVD if the HDD isn't in, and when it's booted, I can connect it through a USB-SATA connector, and see the contents.

I tried deleting all the partitions via the USB interface, reinserted the HDD into the SATA port on the laptop, but no change.

Can anyone shed some light on this, and suggest a fix?
 


A

atanere

Guest
Have you looked in the BIOS Setup? I would think that BIOS scans automatically, but maybe it is hung up there... possibly still looking for the old hard drive.
 
E

Edwin Humphries

Guest
Yeah checked that out - even deleted the hard drive as a possible boot source, but when connected via the SATA port, it still didn't connect. At the moment, I'm trying to clone a Windows install to the drive, so I can see if that boots, even partially. If so, then I should be able to install Linux over the top of it.
 
E

Edwin Humphries

Guest
And that doesn't seem to work either: using Clonezilla results in a "Failed to find this partition in this system" error.
 
A

atanere

Guest
Weird, indeed. Have you put the original drive back in? It almost sounds like the disk controller has failed... unless the old drive still works.
 
E

Edwin Humphries

Guest
I eventually ended up cloning the Windows drive using OSFclone, which went OK. But the laptop still won't boot, either from the drive or from a DVD with the drive installed. When I installed the source drive for the cloning, it booted fine, either directly off the drive or from a DVD. So the drive works, the controller works. o_O
 
A

atanere

Guest
Still pondering your problem, but short on solutions. It's a tough one, for sure.

You might review spec sheets on the laptop and on the hard drives. You don't say how old this equipment is, and I haven't looked up specifics on the laptop models. But since basic hardware all seem to function as it should, you are down to compatibility between that particular laptop and that particular hard drive. The original hard drive is clearly compatible. So what is the difference between them, besides capacity?

For example, even though jumpers are rarely used on SATA drives, there are cases where they exist and they need to be set properly. This quote "On SATA-II drives, a jumper is sometimes used to set the drive into SATA-I mode for compatibility with older controllers." and this quote, "Some SATA drives have jumpers to enable/disable 3Gb/s functionality or other backwards compatibility items." hint as a possible solution for you, but they are only a guess. (Source: http://superuser.com/questions/56270/why-does-a-sata-hard-drive-have-jumpers)

If your laptop is fairly recent, with UEFI firmware instead of the old BIOS, there could be issues with that maybe. UEFI vs BIOS is usually a problem with using different operating systems, but your issue still seems more like hardware detection... not even ready to look for an operating systerm yet. But if you have UEFI, I would certainly try to "enable legacy mode" (maybe called CSM) and I would disable "secure boot" to see if there is any effect.
 
E

Edwin Humphries

Guest
Good thoughts atenere, thank you.

The drive has no jumpers, so I couldn't switch it back to SATA-1 mode. The BIOS did have UEFI enabled, which I disabled; however, there was no "Secure Boot" option. But with UEFI disabled, the result was the same, so still no joy, I'm afraid.
 
A

atanere

Guest
OK, if you have UEFI then I don't think the SATA version is an issue... your Asus laptop is fairly late-model. I have had many long fights with UEFI, but in spite of that I am not an expert with it. It is a pain... a royal pain with some computers.

UEFI is actually a "replacement" for BIOS. Its not something you can disable. But every manufacturer can implement it differently; there is no standard. The "wording" you found may have said something like "disable UEFI," but it really doesn't work like that. You may have disabled Secure Boot, or you may have enabled "legacy mode" (sometimes called CSM), or you may have done both. You can read volumes about UEFI if you're so inclined.

We still don't know that UEFI is the cause of your problem though. It may be, or it may not. For all the grief I have had with it, I love to blame it for anything! You can explore the UEFI Setup and try various things relating to the hard drive and/or the boot process, and you might hit the magic combination. But whatever your settings, if it booted on the original hard drive with Mint, then it should boot with the other hard drive with Mint also. Mint is pretty UEFI capable, usually.

It may seem strange, but you might try another distro. Even though Mint works well usually, I have run into problems with a finicky HP laptop with UEFI where Mint did not install and work as is should. At that time, I found OpenSUSE worked the best. Also, besides DVD installs, you might try USB installs too. There are some funny little differences between DVD and USB sometimes also.

It's still a compatibility issue, right? If you are set on making this hard drive work (and since there are no jumpers), the only things you can change are with the laptop: either the UEFI settings, or the operating system. You'll have to play with it awhile longer to figure it out.
 


Staff online

Members online


Top