storage extranl failure at start up

apokrell

New Member
Credits
26
Hello everyone.
It is my 1st publication and I would like to be clear in the description of the problem
I am a user of linuxmint 21 and before linux 20,
I personally use it for audio applications, especially to use it as a server where only the roonserver is installed, which is an audio application.
the concrete problem is
I have 3 usb 3. 0 disks connected to the server and when you always start one of the three it re-indexes it completely and randomly, that is, any of the three disks, this did not happen to me with windows x example.
It is an msi gamer board with 8th generation intyel core i7 16 gb of ram and 220 gb solid disk
It is only used for that, audio srver with roonserver installed
If I leave it running 24 hours the server also disappears a disk and it is only fixed by restarting
That would be for now, sorry if I did something wrong or did not write correctly,
I hope someone can get this and refer me if it corresponds
Atte
wilfredo sanchez
 


Fanboi

Active Member
Credits
3,665
Not 100% sure what you mean, but some pointers:

If you want the disks to stay in the same place, label the partitions (use gparted or something easy). Then use LABEL=<the name you gave it> instead of the UUID in your /etc/fstab file. Never use /dev/sdX because it can be enumerated differently on boot (I've had odd occasions of my primary disk being /dev/sdb instead of sda). Whenever you plug in attachable storage, it will be enumerated/indexed on-the-fly, which is why fstab is useful; it ensures mountpoints are static, whereas removeable storage is usually mounted at /media/<id>/ or /media/<username>/<id>/ and enumerated as the next /dev/sdX device (IDK if you can a udev rule for this, I've never tried).

If disks are "disappearing" after s certain uptime, it may be a firmware issue with the external case. I had to eventually remove my external and place it in my PC as an internal because not even my BIOS picked it up unless I unplugged it and plugged it in again (try this instead of rebooting, it may narrow down the cause).

I hope I understood your question properly. Good luck and let us know your results or any other questions.
 

apokrell

New Member
Credits
26
the disks appear to be in th sistem all the time , in the screen i can see my 3 exxternal disks, only roon(my playback software do not recognize it sometimes and they are indexed after start up ,
in the case i can try your solution but as a newbee will need more step by step command line .
I have a friend wirth the same linux distro and he never had this kind of problem, the diffence between our systems is the motherboard and processor, but is the same linuxmint
 

Fanboi

Active Member
Credits
3,665
Well, if you want to manually ensure they are always in the same place:
* Always backup data first
* Assuming your user ID is 1000 (default)
* Assuming typical Debian/Ubuntu filesystem
* Assuming all of your filesystems are ext4
...If not adjust accordingly.
* I may use "disk" and "partition" interchangeably because AFAIK, all these disks are a single partition.

1. Stop "roon" and all its components. I don't know anything about "roon" but I suggest you clear its config probably ~/.roon or ~/.config/roon

2. For each drive, open Gparted and choose "Label Partition" and give it a name. For this example, I'm naming them hdd1, hdd2, hdd3. Be sure to check the filesystem each is using as you will need to know later.

3. Now, we need mount points. In the terminal:
Code:
# mkdir /media/hdd1 /media/hdd2 /media/hdd3
# chown 1000:1000 /media/hdd1 /media/hdd2 /media/hdd3
4. Manually unmount each of your three disks.

5. Now, as root, you need to edit the /etc/fstab file. Use your favourite text editor, but be sure to use one that retains plain text formatting. You can even use nano in a maximized terminal.
Add the following to the bottom of /etc/fstab
Code:
LABEL=hdd1    /media/hdd1/    ext4    defaults,user,exec    0    0
LABEL=hdd2    /media/hdd2/    ext4    defaults,user,exec    0    0
LABEL=hdd3    /media/hdd3/    ext4    defaults,user,exec    0    0
Notes:
I personally don't like the /media/username/point for persistent mounts. I used the "exec" flag in case you have anything (games, scripts, etc.) that you run from those disks. If not, "exec" is not needed. IDK if the "user" flag is needed since it depends on the system and if the drives are internal/external and many other things.

6. You should be able to mount them immediately as fstab changes are detected straight away. Your file manager should respect fstab. If you want to check, us the lsblk command after mounting the disks and you'll see the mount point for each partition. From that point on, those partitions will always be mounted in the same place.

Hope I understood what you meant and that this works. Let us know if you get any permission problems.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top