• Important: We recently upgraded our forum software - please let us know if you run into any issues.

Steam Install

Okiepro

New Member
I have Mint 17.2 and am trying to install Steam for my grandson. It seem to download and install, but won't open. This may be over my head...
 


Condobloke

Well-Known Member
G'day Okiepro, and Welcome to Linux.org

Have a look HERE



(have you already clicked on menu and then on 'Software Manager'...and then typed in 'steam' to see if it is already listed there ?)
 

Okiepro

New Member
Yes, Software manager has steam-installer and steam:1386. I tried both of those and a steam listing is added to Games on the menu, but nothing happens when I click on it...
 

Condobloke

Well-Known Member
click menu.....type synaptic...open synaptic package

click on 'search'

type in steam

Right click steam, and select 'mark for complete removal'
Click on Apply at the top of that window

When finished, search for steam again. and this time mark it for 'Installation'
then 'Apply'

better result ??
 
Last edited:

Okiepro

New Member
The application still does not do anything.
After complete removal with synaptic package manager, the steam launcher is still listed. Is that the spot I should reinstall?
 

Condobloke

Well-Known Member
Below is a screenshot of my synaptic screen with steam installed.

I have no 'steam launcher'.... do you know where it came from?....downloaded from the 'net ?....



and another pic after uninstalling it.....



(When I install there is a note shown that some Steam files are not purged....these are steams working files. I am quite content to leave them alone)

At this point there is no sign of steam in the menu at all.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
I suspect the OP may be referring to steam-devices as being a launcher, but bear in mind too that he is operating from 17.2 'Rebecca' and its content may be a little different.

(Wizard appears in a puff of smoke, having found his manners in a small pocket handkerchief in the 3rd drawer of his filing cabinet)

Welcome to linux.org @Okiepro :)

First, for your benefit - are you aware that End of Life (ie support) for Rebecca is around mid-April coming? You may wish to consider your options to upgrade.

Brian (@Condobloke ) - you may wish to reconsider, re

(When I install there is a note shown that some Steam files are not purged....these are steams working files. I am quite content to leave them alone)
Removal of Steam via Synaptic leaves over 1.4 GB in files generated.

Having just followed the same path as you, my notes show as follows (click to expand):

OP is on LM 17.2 ‘Rebecca’

Brian is on LM 18.3 ‘Sylvia’ Cinnamon.

I have an instance of the same Distro onboard. (18.3)

In our Software Manager, we have access to Steam 1.0.0.52 through package

steam:i386

Once installed, that works, but note that there is a long pause between when Steam has completed getting its updates and when a popup appears saying that certain tasks are being performed and then, and only then, Steam launches.

By this time, it has appeared in our Synaptic Package Manager as well.

Removal of Steam is not as simple as just opting for

remove steam completely

Nor is it a matter of leaving behind a small number of dependencies.

As part of the install, Steam generates 1.4GB of packages, housed in a hidden folder .steam in

/home/user … where user is your username.

Then there is a visible folder Steam containing logs.

Also two (2) hidden files

.steampath

and

.steampid

I have not taken the time to generate a code string that will remove all traces, so I have simply, in my own case, proceeded as follows.

At Terminal (a # reflects my comments, not a command to be typed)

Code:
sudo rm -R ~/.steam
# gets rid of the 1.4 GB in the hidden folder, and the folder

sudo rm -R Steam
# gets rid of the Logs (visible) and their folder.

sudo rm ~/.steam*
# gets rid of the hidden files starting with steam
There may be some more yet for housekeeping, if so, I will report back.

@Okiepro - do you know what games the grandkids play? ie that they are definitely available under Steam?

I'm off to do some voodoo and I'll be back when I can.

Chris Turner
wizardfromoz
 

Condobloke

Well-Known Member
I was aware that the retained files were around 2 gb.

I will reinstall Steam....it comes in handy when kids come with visitors and need a diversion...saves them spoiling Belle any more than she already is.

My immediate reaction is for Okiepro to update to LM 18.3....could be a quick(ish) fix ?...then again kernel differences may cause drama....maybe better to burn 18.3 to a usb and try it out first ?

Surely there is a simpler way.

@Okiepro ...have you tried the install from my link in post # 2 ? (Follow any extra housekeeping instructions from Wiz before you try that)
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Just a clean bill heads up on the Steam, looks like what I said above covers it.

I'll go to their website and see what the story is with their version.

Wiz
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
OK, so from the site -

Top reference for me to download doesn't do anything, but there is an install Steam a little further down I had not noticed before, and its smart tip refers to a .deb

So I saved that to Downloads, double-clicked, and GDebi installed it for me. Launches OK.

AND (taking a change from BUT)

Synaptic shows as follows:




SCREENSHOT 1 - WIZARD'S SYNAPTIC VIEW OF STEAM INSTALLED FROM THEIR WEBSITE

So this is the launcher that the OP (Original Poster, that's you @Okiepro :)) is referring to!

Note, too, that it is v1.0.0.59, cf 1.0.0.52 available through the Software Manager, so the newer version is likely preferable, ie from the website.

At face value, it seems to install to the same points as I listed prior, so removal and housekeeping should be the same?

Okie - whether or not you choose to upgrade your Mint, you might want to make the acquaintance of Timeshift - it ships installed with LM 18.3 and onwards, and was backported to 18.2 and 18.1, not sure about 18.0.

I have a Tutorial on it here

https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/

and you can ask me any questions over there. It is better than Windows Restore.

When we introduce software such as Steam, from "outside", it is a good idea to have your system safeguarded so you can roll back if things go wrong, and Timeshift can do just that :D

Cheers

Wizard
 

Members online


Latest posts


Top