Steam: Game is not available on your current platform LM 21.1 Cinnamon

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
3,707
Reaction score
1,986
Credits
22,085
Thought I'd give Steam a go and play some games on my Asus Tuf Gaming Rig and have some fun for a change.

After installing Steam from Mint's Software Manager and logging in to my Steam account I keep getting this message over and over again.
"Game is not available on your current platform"

In an effort to help myself I read this page:
It says: Steam and its games are currently only supported on Ubuntu with Unity, Gnome, or KDE desktops.


What use is Steam in the Software Manager then if I can't use it?
Am I missing something?
 


Yeah it should just work, quite strange error message since LM 21.1 is still supported. What happens when you try installing it as a Flatpak, first remove the one you install from the software manager first?
Code:
flatpak install com.valvesoftware.Steam
And then launch it? F
 
Using the Mint Software store version of Steam on Mint 21.1 without issues.

Does it happen with one game or all games?

Does anything change if in View > Settings > Steam Play you enable Steam Play for all other titles?

The May 2023 Steam Survey lists Linux Mint 21.1 64 bit as having 0.08% market share, so Steam not being able to detect Mint as the error message suggests seems really weird.
 
Last edited by a moderator:
Yeah it should just work, quite strange error message since LM 21.1 is still supported. What happens when you try installing it as a Flatpak, first remove the one you install from the software manager first?
Code:
flatpak install com.valvesoftware.Steam
And then launch it? F
Sorry for the delay.
I was out of pocket the last few days.

After removing Steam (LM pkg) and installing Steam (Flathub) the GUI launched.
However, I don't get how to download a game and the GUI in the upper left hand corner is so small I can't read it.

Any ideas?
 

Attachments

  • Steam Flathub.png
    Steam Flathub.png
    721.8 KB · Views: 137
  • Steam Work.png
    Steam Work.png
    2.3 MB · Views: 492
  • Steam Missing.png
    Steam Missing.png
    69.2 KB · Views: 106
  • Game.png
    Game.png
    1.6 MB · Views: 361
However, I don't get how to download a game and the GUI in the upper left hand corner is so small I can't read it.
You still have to enable Steam Play under Settings -> Steam Play and then check "Enable Steam Play for all other titles" As for that message about steam-devices you can ignore it if you are don't use a controller on your system. If you do you can just clone "https://github.com/ValveSoftware/steam-devices" somewhere on your system and then copy the 60-steam-* to /etc/udev/rules.d and then reboot your system.
 
You still have to enable Steam Play under Settings -> Steam Play and then check "Enable Steam Play for all other titles" As for that message about steam-devices you can ignore it if you are don't use a controller on your system. If you do you can just clone "https://github.com/ValveSoftware/steam-devices" somewhere on your system and then copy the 60-steam-* to /etc/udev/rules.d and then reboot your system.
Ok, thanks- after checking Steam Play and enabling Steam Play, Steam rebooted and I can select games now.

How do I change the size of the GUI?
 
Ok, thanks- after checking Steam Play and enabling Steam Play, Steam rebooted and I can select games now.

How do I change the size of the GUI?
What do you mean size of the Steam client? Like any other window, by click on top right where you see an icon of two windows. After that you can can just resize the Steam client how you want using your mouse like any other program.
 
What do you mean size of the Steam client? Like any other window, by click on top right where you see an icon of two windows. After that you can can just resize the Steam client how you want using your mouse like any other program.
The Steam client show's games in the center of the monitor however; in the screenshot I took, If I try to select the square to open Steam at it's largest view it doesn't work.

I'm using a magnifying glass to see the Settings and etc.
 

Attachments

  • Mouse.png
    Mouse.png
    1.1 MB · Views: 134
In Settings I ticked the box so that Steam will start in big screen mode and enlarge text and icons based on monitor size.

It says in order for it to take effect Steam has to restart. However, when I click ok Steam didn't restart.

Do I need to reboot the system?
 
The Steam client show's games in the center of the monitor however; in the screenshot I took, If I try to select the square to open Steam at it's largest view it doesn't work.

I'm using a magnifying glass to see the Settings and etc.
Mine looks like this. I don't see the problem so you must have worse eyesight than me?
Screenshot from 2023-06-04 19-00-02.png
 
Last edited:
In Settings I ticked the box so that Steam will start in big screen mode and enlarge text and icons based on monitor size.

It says in order for it to take effect Steam has to restart. However, when I click ok Steam didn't restart.

Do I need to reboot the system?
Are you talking about "Big Picture Mode"? That's not really for pc gaming but if you stream Steam to your tv to get a console experience. I tried it, I just go to View -> Big Picture Mode and then the Steam client restarts into Big Picture mode.
 
Are you talking about "Big Picture Mode"? That's not really for pc gaming but if you stream Steam to your tv to get a console experience. I tried it, I just go to View -> Big Picture Mode and then the Steam client restarts into Big Picture mode.
No, not streaming.
Here's another screenshot so you can see how tiny the font is in the Steam Settings Manager.

Figured out how to resize the Steam GUI. However, when exiting Steam it leaves my system in a 'unresponsive state'.
To remedy that I held down CTRL + Alt + F2 and tried to run 'startx'. That failed twice. See message in code tags.

Code:
waiting for x server to shut down server terminated successfully
Connection to x-server lost

Do you have these issues as well?
 

Attachments

  • Steam & Settings.png
    Steam & Settings.png
    1.6 MB · Views: 532
Here's another screenshot so you can see how tiny the font is in the Steam Settings Manager.
Here's how it looks for me.
Screenshot from 2023-06-04 19-49-38.png

To remedy that I held down CTRL + Alt + F2 and tried to run 'startx'. That failed twice. See message in code tags.

Code:
waiting for x server to shut down server terminated successfully
Connection to x-server lost

Do you have these issues awell?
No I don't have any of the issues you describe and I didn't do anything special to have Steam working the way it does for me.
Try this by running the following.
Code:
flatpak override --user --env=GDK_SCALE=2 com.valvesoftware.Steam
Then restart Steam and see if it looks any bigger. Also it will be worth installing Flatseal to manage settings for Flatpaks through a gui.
 
Glad to see that it's working for you f33dm3bits.

The only way I get the interface like you do is to select: big screen mode.
Big screen mode comes with a price on my rig. As I said before exiting Steam puts my Linux Mint 21.1 system into a unresponsive state.

Thanks for telling me about Flatseal.

Rebooting......bb
 
Ran this from the command-line:
Code:
flatpak override --user --env=GDK_SCALE=2 com.valvesoftware.Steam

Upon restarting Steam it crashed!
 
Easiest way to undo it is through Flatseal, open Flatseal, select Steam and then find the environment setting with that value and remove it.
 
Easiest way to undo it is through Flatseal, open Flatseal, select Steam and then find the environment setting with that value and remove it.
The funny thing is I haven't installed Flatseal as of yet. Have to walk away for a few minutes.
 
It seems to a closes issue and that's probably for the native deb package. If you don't like using Flatpak for the Steam client you can always remove and then install the normal one using apt and try to figure out. What Mint flavor do you have installed?
 
It seems to a closes issue and that's probably for the native deb package. If you don't like using Flatpak for the Steam client you can always remove and then install the normal one using apt and try to figure out. What Mint flavor do you have installed?
The Flatpak was fine now it's crashing w/o Flatseal installed.
Linux Mint 21.1 Cinnamon:-

Tending to the steaks on the grill--
 

Members online


Top