Start Job

transadd

New Member
Credits
41
Due to a failed disk I have relocated my Gecko to another disk with fewer partitions. Originally my swap partition was on sda8 but now is on sda3. My fstab file is correct and the system boots and works correctly but while booting spends 90 seconds looking for swap on sda8 NOTE /dev/sda8 nor its UUID appear in the fstab.

Which file in the system do I need to change to avoid this delay?

Regards John
 


wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
18,283
G'day John from DownUnder and welcome to linux.org :)

In addition to what @KGIII has asked for -

1. Gecko Leap or Gecko Tumbleweeds?
2. Can you copy and paste the content for /etc/fstab up to here? On your Reply Pane toolbar look for the smiley emoticon, and right of that is a dropdown Menu featuring Code - press that and paste the text to it.
3. How long have you been using Gecko?

Cheers

Chris Turner
wizardfromoz
 

transadd

New Member
Credits
41
Code:
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
#system on sda2
LABEL=gecko_lxqt                           /              ext4  noatime         0  1
# swap was on /dev/sda8 during installation now on /dev/sda3
/dev/sda3                  swap            swap           defaults          0    0
G'day John from DownUnder and welcome to linux.org :)

In addition to what @KGIII has asked for -

1. Gecko Leap or Gecko Tumbleweeds?
2. Can you copy and paste the content for /etc/fstab up to here? On your Reply Pane toolbar look for the smiley emoticon, and right of that is a dropdown Menu featuring Code - press that and paste the text to it.
3. How long have you been using Gecko?

Cheers

Chris Turner
wizardfromoz
Thanks for your reply, retired and in lockdown for 12 months, time is not an issue but here are the things you asked for

1. Gecko Leap
2. I have also tried by using sda3 UUID this also gave a 90 second delay
UUID=e59d6e6b-20bb-4173-b22e-f381d6bbd09c swap swap defaults 0 0
instead of /dev/sda3
In grub
kernel parameters resume=/dev/sda3
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3 mitigations=auto"
3. 6 months

The 3 other distro's on the same computer with similar fstab have had no problem with the change.

Regards and stay safe john
 

transadd

New Member
Credits
41
Did your previous installation have hibernation enabled? If so, check grub to see if it has a reference to the old UUID. That's about the only thing I can think of.
Thanks for reply I have never used hibernation I have replied to wizardfromoz with details
Regards and stay safe john
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Credits
18,283
...and John can you tell us which are the other 3 distros?

Cheers

Wiz
Avagudweegend
 

transadd

New Member
Credits
41
...and John can you tell us which are the other 3 distros?

Cheers

Wiz
Avagudweegend
Hi again
On booting up this morning no delay appeared, no idea how it happened.
Possibly one of the updates changed something.
Not really solved but should I mark as such, if so how should I do this.

Thanks for all input
Regards John
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top