SSH, PING, and TRACEROUTE problem

DrCarmack

New Member
Joined
Nov 13, 2021
Messages
2
Reaction score
0
Credits
23
Hi, everything worked fine couple days ago,
now i cant ssh nor ping a device on my home network. i can't even ssh local host, then it says connection refused, also traceroute doesen't work either.
everything was fine last week, what could happen? how can i solve this problem? i think the problem is in my network settings or router? anyone have any ideas
i also cant ssh into tryhackme's device, which also worked last week
i only updated and upgraded kali


OpenSSH_8.7p1 Debian-1, OpenSSL 1.1.1l 24 Aug 2021
debug2: resolve_canonicalize: hostname 92.168.100.8 is address
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/home/administrator/.ssh/known_hosts'
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/home/administrator/.ssh/known_hosts2'
debug3: ssh_connect_direct: entering
debug1: Connecting to 92.168.100.8 [92.168.100.8] port 22.
debug3: set_sock_tos: set socket 3 IP_TOS 0x10
 


dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,073
Reaction score
745
Credits
5,574
Two or three things stick out there.

1. I suspect you were really trying to get to 192.168.100.8 instead of 92.168.100.8 .
2. It looks like you've lost DNS. what is the output of...
cat /etc/resolv.conf
3. It appears you've made a softlink from a home directory of one user to another user "administrator".
This isn't really a good idea. So for example if you ssh as [email protected]
it's going to want to write to joeblows home directory .ssh/known_hosts
If you link that directory back to administrator it's going to write the key in his directory but
not the user ssh'ing.
 
OP
D

DrCarmack

New Member
Joined
Nov 13, 2021
Messages
2
Reaction score
0
Credits
23
Yes , its just a typo, i ment 192 still not working.
So what do i do exactly to fix it?
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,073
Reaction score
745
Credits
5,574
Yes , its just a typo, i ment 192 still not working.
So what do i do exactly to fix it?

Did you give output of...

cat /etc/resolv.conf

I would remove the link to the administrator home directory.

Are you using DHCP?
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top