Sound...?....what Sound !

OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,516
Reaction score
3,941
Credits
25,375
Pulseaudio is a drama.

I have reverted the bios changes made, but still have no sound at all

Took the system back via Timeshift...still nothing. Pulse audio still has an error message....

MiH3Es3.png


yes, I should have left well alone !

sigh .....
 


D

Deleted member 58530

Guest
Have you uninstalled pulse audio.

sudo apt remove pavucontrol

sudo apt purge pavucontrol

sudo apt autoremove

Then restart computer.

After restart go into control panel and under hardware locate test sound and see if speakers or headphones work.

The above commands should uninstall pulse audio and it's configuration settings.

I don't know if timeshift allows you to go back any further as in a last known working state.


If you are using firejail take a look at this, just something to check.

https://sites.google.com/site/easylinuxtipsproject/sound


You might try reinstalling pulse audio and see what happens if you have no sound.

Kinda head scratchen at the moment.



This is for LM 19 although may give some ideas.

https://forums.linuxmint.com/viewtopic.php?f=49&t=277721
 
Last edited by a moderator:
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,516
Reaction score
3,941
Credits
25,375
Solved the pulseaudio problem, by opening 'Home'....then finding pulse under .config I simply deleted the entire folder....then reinstalled pulseaudio (pavucontrol)

I now have pulse,...I now have volume. Everywhere.Video, music, youtube etc etc

I am gonna have another go at the headphone thing now.......this time I will stop when i get the rear connection going.

EDit spelling.
 
Last edited:
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,516
Reaction score
3,941
Credits
25,375
Ok....headphones are officially...Working !! Easy...piece of cake !

I find it strange that the first attempt a day or so ago (which worked),,....if I wanted to switch from speakers to headphones...I had to stop whatever was playing...open sound settings and click on the appropriate output, and then start the music/video again.

On this attempt, i simply have to open sound settings and click on the appropriate output, and bingo !!!....no need to stop whatever is playing.

What sent the whole thing wacko, yesterday ? On the end of the wires coming from the front connector, there are two connectors as shown in post #13......one is named HD, the other AC97.
When I have connected the AC97 to the header on the motherboard, this has caused pulse audio to crap itself, and it also wiped out part of the config file in pulse audio as well.

I live and learn.
 
Last edited:

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,207
Reaction score
6,118
Credits
24,208
You pair make for a good team :) Cool!

I'm just sitting back and watching and learning, and having a yarn with Manjaro users, lol.

Brian, Brian, Brian ... who was it who says "I am sticking with my Linux Mint 18.3 and not going to update to 19 'Tara' until I get back to Australia, so I don't bugger up things before I leave"?

And then, this Thread, lol.

Chalk it up to our continued adventures with Linux, and wait until I fall flat on my face with my next adventure, eh?

Cheers all, good work

Wizard
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,516
Reaction score
3,941
Credits
25,375
;)
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,516
Reaction score
3,941
Credits
25,375
And.....just to polish the whole thing off.....All this drama screwed the 'setting' I had put in place as per THIS TOPIC

In other words when the pc is rebooted or restarted, the volume kicks off at a high level.....which can be somewhat disturbing at 2 or 3 AM.....

the solution ?.....(read this in conjunction with the topic linked above )

.I discover after reinstalling PulseAudio, that the default.pa is longer found under .config

Instead.....
open file system, then click on etc Inside here, right click on pulse and open as root.
Then double click default.pa

Scroll to the bottom and type in set-sink-volume alsa_output.usb-Logitech_Z_Cin__ma-00.analog-stereo 4096

(
4096 will ensure your volume is super quiet at startup or reboot.....you can increase the number if you wish)

Then click on File and Save. Close everything and Reboot

Conclusion
. Volume now kicks off at a low level...can hardly hear it. Perfect.
 
Last edited:

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,207
Reaction score
6,118
Credits
24,208
MATE I am SO going to come to you and Poorguy if I have sound probs.

b_Zo_Rud6_-_Imgur.gif


Avagudweegend

Wizard
 
OP
Condobloke

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,516
Reaction score
3,941
Credits
25,375
eh ?....whats that?...cant hear you...
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top