Solving a persistent audio issue

Rustic123

New Member
Good day. I would like to alert the Linux community to an audio issue that's been bothering me for years which I finally got fixed. Based on my googling expeditions I know that hundreds of other people are having this same issue which seems to be going unsolved.

I would like to get the problem solved, either with a hard fix, or simply a set of instructions for anyone searching for the answer like I was. I am using ubuntu 16.04, but I believe this issue also exists for ubuntu 18

The issue has to do with the way pulseaudio behaves after a fresh install. Here are some of the symptoms I experienced:
1) Computer doesn't recognize sound drivers. "Dummy output" in the sound settings
2) Corrupted sound quality, volume is very low as well
3) Audio control panel is messed up, so is Alsa. Pavucontrol doesn't seem to help.
4) Raising and lowering the volume is bugged, volume will suddenly get louder as it's turned down
5) After some of the fixes offered online, the sound will crackle annoyingly whenever the volume is changed

To fix these issues, I tried a huge host of solutions. Many of them made the problem worse and I was forced to reinstall ubuntu to fix things. A few of them partially fixed the problem but left other things unaddressed.

First of all, I have:
-- a Dell laptop
-- an Intel soundcard
-- an Intel audio driver

Here are the steps I performed to get the audio working after a fresh install. I'm not sure which of the things I did were necessary, but I'm sure the people here are smarter than me in this regard.

Step 1 is to install all updates.
Step 2 is to edit some configuration files. I'm not sure this is necessary, but since my audio is working I won't question it.

/usr/share/speech-dispatcher/conf/speechd.conf
/etc/speech-dispatcher/speechd.conf

At the end of both of these configuration files, there is a line reading "#DisableAutoSpawn", simply remove the hashtag so it reads "DisableAutoSpawn"

/etc/modprobe.d/alsa-base.conf

add the line:
options snd-hda-intel model=generic
at the end.

Step 3: Uninstall then reinstall pulseaudio

sudo apt-get autoremove pulseaudio
rm -r ~/.config/pulse
reboot
sudo apt install --reinstall alsa-base alsa-utils pulseaudio linux-sound-base libasound2
pulseaudio -k
sudo alsa force-reload
pulseaudio --start
reboot

When you reboot, the computer will not recognize the soundcard. To fix this issue, simply go into the BIOS, uncheck "enable audio", apply the settings, then recheck "enable audio" and once again apply the settings. Click exit. The audiocard will be recognized. Also, leave your headphones unplugged for the reboot, only plug them in at the password screen, otherwise the audio will be messed up.

To check if the audiocard is recognized, there are these two commands:
lspci -v | grep -A6 Audio
aplay -l

Now, install the audioplugin:
sudo apt install --reinstall xfce4-pulseaudio-plugin
sudo apt-get install indicator-sound
killall unity-panel-service
killall gnome-panel

For some reason, I didn't have the unity control center installed, which is why my sound settings panel was messed up. Install that next.
sudo apt install unity-control-center

All of the issues should be solved, but you still need to leave your headphones unplugged during a reboot, and when the computer suspends it messes up the audio. To fix these issues, you need to install additional alsa tools:

sudo apt-get install build-essential linux-headers-`uname -r` alsa-base alsa-firmware-loaders alsa-oss alsa-source alsa-tools alsa-tools-gui alsa-utils alsamixergui

Now the solution is complete, and audio works perfectly.

This may seem laughably simple to a seasoned Linux veteran like I'm sure many of the people here are. But for someone with no experience like me it bothered me for years. Some of the solutions offered online are really crazy and only make things worse. I would like to disseminate this out so that nobody goes through this again.

If there is a way for this to be addressed in the scheduled updates, that would be great. Or if this solution can just be disseminated so it's easily available for those struggling with pulseaudio. I'm not sure if this will work on all machines, but it worked for me.
 
Last edited:


Rustic123

New Member
Hello all. I am trying to link my forum post here. I made an account to post the link but it won't let me answer the question because I don't have enough reputation apparently. Can someone else post the link?

 



Members online



Top