Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

[solved] Where to add MX record / DNS system, parent and slave zones

Discussion in 'Web Server' started by postcd, Mar 19, 2018.

  1. postcd

    postcd New Member

    Joined:
    Jul 8, 2017
    Messages:
    17
    Likes Received:
    1
    Hello,

    i am sending an e-mail out of my server via PHP mail function and the mail filtering system used by my server provider (externally, out of my reach) is complaining about sender address being [email protected]


    (log in to hide this advertisement)
    Exim fail log: "You do not have sufficient privileges to send mail to this address. Please authenticate and try again."

    I do not know what is the exact reason that it do not like that sender address. Filtering provider told me the FROM address is the issue.

    (the hostname.domain.tld is FQDN, has PTR record, fully resolve to IP and vice versa)

    When i check that e-mail address at http://proxy2.de/email-validation.php it says "The domain hostname.domain.tld has no MX record."

    But i do not know where i need to create MX record. I already have it on Cloudflare (parent) and also on slave: my server. The domain.tld is hosted on different server than one from which i am sending e-mail, but hostname.domain.tld A record point to right IP (one from which e-mail is sent).

    level 1 - domain (namesilo)
    level 2 - cloudflare DNS zone
    - hostname.domain.tld goes to IP 1.2.3.4
    - domain.tld A record goes to 6.7.8.9
    - mail.domain.tld is 1.2.3.4

    Should i be creating MX at cloudflare, at 1.2.3.4 or at 6.7.8.9 ?

    e-mail [email protected] is sent from 1.2.3.4
    Server is Dovecot 2.2.33.2

    mxtoolbox says "Reverse DNS does not match SMTP Banner" as a warning, but i do not know why it should be big problem.

    Do you have any idea if i can anyhow tweak my DNS configuration so the filtering system managed by my provider is satisfied?
     
    #1 postcd, Mar 19, 2018
    Last edited: Mar 19, 2018
  2. Rob

    Rob Administrator
    Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    193
    Likes Received:
    598
    If you do a 'whois' on your domain name you'll be able to tell where to place the MX record - at the bottom of the results, it'll say 'Name Server: blah.com'..

    To check what the current setting for the MX record is, you can use dig:

    Code:
    dig blah.com mx
     
  3. postcd

    postcd New Member

    Joined:
    Jul 8, 2017
    Messages:
    17
    Likes Received:
    1
    The whois was showing cloudflare nameservers. I have added MX record you suggested, i did it on Cloudflare.

    hostname 119 IN MX 0 hostname.domain.tld.

    dig hostname.domain.tld MX
    And problem at http://proxy2.de/email-validation.php disappeared.

    But issue was not solved, what solved it was that in my control panel (WHM from cPanel) was enabled following option:
    that option was rejecting e-mails to system e-mail accounts like [email protected] and the mentioned mail filtering system used by my server provider (*.antispamcloud.com) require that sender is allowed to accept incoming e-mail.

    Thank you for help
     

Share This Page