[SOLVED] Unity Hub login problem


New Member
May 2, 2021
Reaction score
When trying to log into UnityHub, it opens a tab blank tab in browser.
Same result goes for having logged into Unity in a seperate tab in browser. Also, same result when using an older build from the Unity Archive.

I use Firefox as my default browser.

This is the URL of the blank tab I get confronted with:

a lot of linux users have the same issue.

"No.12" ...... https://forum.unity.com/threads/sign-in-link-broken.1182610/#post-7700452

Skade88 said:
I am having an issue running the INSTALL.sh installer script. Any pro tips on how to resolve this issue?

sh ./INSTALL.sh
This script will only run if the UnityHub.AppImage is at the same location as this script
This will wipe any existing Unity Hub installations, are you willing to proceed? [N|y]: ./INSTALL.sh: 11: read: arg count

It does not give me a chance to respond to the N|y question and instead crashes.

I am on Ubuntu 20.04.3 LTS
Click to expand...
Same issue, I am on Ubuntu 21.04 LTS

Caused because UnityHub is not registered to handle unityhub:// links

I've found a workaround that works with latest Hub:
- Lauch the UnityHub AppImage, click Sign In
- Enter the credentials
- In the blank webpage you are redirected to, right-click -> show source. Copy the address starting with unityhub://
- close the UnityHub, open a terminal in the folder containing it, and start as a command :
./UnityHub.AppImage unityhub://<the-url-you-have-copied>

And Unity Hub should start properly with you being logged in!
Last edited: Dec 1, 2021
dereavy, Dec 1, 2021
I happened the same problem I researched but I did not serve any solution raised , finally I found with the problem when I started session opened the browser firefox, out of curiosity I copied the link to another browser in brave , I asked my credentials again, and finally I worked, I leave this solution in case it serves anyone, I go with ubuntu 22.04.3 LTS

Members online