SOLVED: UBUNTU 24.04 LTS Installation Problem...

On this page :

there is a here's How....Disable and remove co-pilot for all users....there is a download button conatins a reg file to run to achieve the disabling etc...


keep the link....there is also another section below showing how to reverse that

clarify please..
is this on your 2010 machine?are you trying to install Ubuntu to the machine's hard drive? Do you run W11 live from the pen-drive or have you installed it to the hard-drive.
Yes it's a 2010 machine. I have Windows 11 with a legit serial number installed on my machine. I'm trying to install Ubuntu on the same machine to run on dual boot. The problem is when I try installing Ubuntu.
B2B [back to basics]
what hapens when you switch off the machine, insert the Ubuntu USB, and open the short boot menu [usualy by jugging F12 as you switch on]
Dose the usb pen-drive show in the list?
if yes highlight and right click ,select open [or double click on the line for the usb]
dose Ubuntu load to Ram in test mode?
I insert the USB Flash Drive and boots from it to install UBUNTU normally. UBUNTU runs in test mode via USB but the problem happens when I try to install it. I even tried not to update before installation and it gives me the error and can't continue with the installation.

I attached the given error during installation.


  • IMG_20240530_230537.jpg
    5 MB · Views: 46
  • IMG_20240607_005613.jpg
    3.3 MB · Views: 51
According to your 2nd screenshot in 1st post this looks like driver issue, there is says index 9 is out of range for UCHAR[1]
I suppose UCHAR[1] is used to store boolean values, 0 and 1 because C language has no boolean type support so developers got around this with UCHAR[1]

But the GPU driver which is being installed expect larger array.
It's hard to say for sure whether this is due to old hardware.
Ok so i will make a suggestion [you may not like it] try another distribution Mint-LMDE, Parrot Home,Debian stable with driver pack , Mx-Linux all run ok on this 2010 Lappy [no windows on it though]

[but i still think it probably a clash with the windows' installation]
I will try to install the previous version of Ubuntu 22.04.4 LTS as I hadn't any issues on this pc in the past. I don't know if it's a compatiblity issue with my hardware but I installed it on an older laptop to try it out and it worked.

Just want to ask you another thing or an opinion. Which is easier to use Fedora or Debian? I'm no linux expert. Just want to replace Windows as my OS, even for the future.
My experience is with linux Mint and LMDE 6

Linux mint is based in Ububtu

LMDE6 is based on Debian

Linux Mint is in front, but not by a great deal
I have Linux Mint installed on a laptop. I think I will give it a try with dual boot, if it's possible. I used Zorin OS too.
Debian based distros have more forum support Fedora is based on RHEL [red hat] Yes I have rin both myself but as a personal opinion I prefer Debian based distros [I am nor a gamer so most of my kit is middle age to very old] which gives me less problems,
but at the and of the day it a what YOU like the look and feel of and works on your Kit
Just a little update. Finally I solved the issue I had with UBUNTU 24.04 LTS and installed it without a problem. The problem was a bug caused by the Logitech C270 USB Web Cam during installation. I forgot to remove it before the installation.

Want to thank all of you for your help, I really appreciate it.
It's probably some glitch somewhere regarding that installer. I mean I've installed numerous Ubuntu on a large range of hardware never had an issue. Not just Ubuntu itself but also it's derivatives.

But yeah, for now just don't "upgrade the installer" while actually installing the distro. Worked for me with Ubuntu MATE @ bare metal.
Excuse me. I have same problem like Kveldulv82.
My setup is bootable usb with Ubuntu 24.04 (iso image download from official Ubuntu, usb created by rufus).
With this usb, I have installed completely in my Dell laptop with no problem and works well. But it doesnt works in my Desktop, i got notification "cannot find TOCBLOCK, database maybe corrupt." before go into setup, and get stopped after that. I tried to disabled secure boot, unplugged all removable devices (just leave a mice) and it still appears. Anyone help me!

My desktop has:
Intel core i3 10100F
MSI B365m Mortar
VGA: Geforce GTX 1650
RAM: Gskill 16GB 2133
SSD 1: Windows 10
SSD 2: Apacer (empty and ready for install)


  • 2ebbcb899b24387a61353.jpg
    370.1 KB · Views: 40
  • 9c51a57cf5d1568f0fc04.jpg
    365.6 KB · Views: 32
  • 55f9b2cfe262413c1873.jpg
    150.7 KB · Views: 38
Last edited:
. I tried to disabled secure boot,
Welcome to the forums, in what way did you try to disable secure boot? And did you disable windows quick-start [fast-boot]?
If secure boot is not in the UEFI security settings then it may be soft wired as a part of the windows' installation, to check this follow instructions in this article
Thanks for reply. Here my desktop, Secure Boot is off. I have disabled Fast-boot too, does it matter ?


  • z5574217298731_10e7ce1a9801db8db7f42b4fb9c99461.jpg
    392.4 KB · Views: 35
  • z5574217299080_a7ba73c739bee53468957781bcca1d01.jpg
    678.4 KB · Views: 36
does it matter
Most Linux distributions still do not work with secure boot, and defiantly yes when it comes to windows quick-start. For when you have it enabled it acts like a deep sleep you think you have turned your machine off, you haven't, your last set up is cached in the ram and when you switch on it is this setting Windows boots from. bypassing the HDD boot sequence.
There are some pictures from failed install. I can't Next at the 3rd picture


  • z5574218810327_0d8eda1e197e1ab718e6cee67c598a7b.jpg
    152.6 KB · Views: 40
  • z5574218810981_a180d19ad9a8956fedd79befa48cecaf.jpg
    260 KB · Views: 39
  • z5574218811763_4fabe6cf4348b5ce9b47ddfa275c2b13.jpg
    243 KB · Views: 41

Members online

Latest posts