[SOLVED] Tried to install a different video driver, now Steam doesn't work

f33dm3bits

Gold Member
Gold Supporter
Credits
9,106
But even after deleting that file, nothing changes about the problem.
Seriously could be a hardware issue guys.
Also Nvidia actually did have a system for blacklisting Nouveau, and I can actually undo this and it doesn't make a difference.

Edit: Also when I look at /var/log/Xorg.0.log
Code:
...
[   100.192] (EE) No devices detected.
[   100.192] (EE)
Fatal server error:
[   100.192] (EE) no screens found(EE)
[   100.192] (EE)
Please consult the X.Org Foundation Support
         at http://wiki.x.org
for help.
[   100.192] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   100.192] (EE)
[   100.255] (EE) Server terminated with error (1). Closing log file.
I'm typing this out exactly as it shows on screen so there may be typos.
What nvidia card do you have and can you share the output of lspci(You can just take a picture of the output if that's easier for you)? If you think it's a hardware issue, try booting from a usb drive into a live environment of another distribution and see what happens. Also if it's a hardware issue if the nvidia card is the only graphics card your laptop then you probably wouldn't get anything on the screen when you turn it on.
 
Last edited:


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
9,921
Not much help here, perhaps, but a good idea for the future, when installing/changing/deleting drivers - graphics, printer, whatever - is to have installed Timeshift and run a full snapshot, and then run incremental snapshots between moves.

Then you can rollback from any point.

Good luck

Wizard
 

WisePassion

New Member
Credits
265
Here's a pic of lspci output, sorry I can't do better. The blurred part is a part of USB controller info (irrelevant).
Actually I can't send images via a phone. When I try I can select an image but nothing happens.
EDIT from after Xorg works: here is my LSPCI since I can log in on desktop now.
Code:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>
        Kernel driver in use: skl_uncore

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07) (prog-if 00 [VGA controller])
        DeviceName:  Onboard IGD
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0, IRQ 127
        Memory at d4000000 (64-bit, non-prefetchable) [size=16M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
        Subsystem: Dell Device 0809
        Flags: fast devsel, IRQ 16
        Memory at d51a8000 (64-bit, non-prefetchable) [size=32K]
        Capabilities: <access denied>
        Kernel driver in use: proc_thermal
        Kernel modules: processor_thermal_device

00:13.0 Non-VGA unclassified device: Intel Corporation Sunrise Point-LP Integrated Sensor Hub (rev 21)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0, IRQ 20
        Memory at d51bd000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: intel_ish_ipc
        Kernel modules: intel_ish_ipc

00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21) (prog-if 30 [XHCI])
        Subsystem: Dell Device 0809
        Flags: bus master, medium devsel, latency 0, IRQ 125
        Memory at d5190000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci

00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
        Subsystem: Dell Device 0809
        Flags: fast devsel, IRQ 18
        Memory at d51bc000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: intel_pch_thermal
        Kernel modules: intel_pch_thermal

00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d51bb000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: intel-lpss
        Kernel modules: intel_lpss_pci

00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0, IRQ 126
        Memory at d51ba000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: mei_me
        Kernel modules: mei_me

00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
        Subsystem: Dell Device 0809
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 124
        Memory at d51a0000 (32-bit, non-prefetchable) [size=32K]
        Memory at d51b9000 (32-bit, non-prefetchable) [size=256]
        I/O ports at f090 [size=8]
        I/O ports at f080 [size=4]
        I/O ports at f060 [size=32]
        Memory at d5100000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: ahci

00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 122
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000e000-0000efff [size=4K]
        Memory behind bridge: c0000000-d30fffff [size=305M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 123
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: d5000000-d50fffff [size=1M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:1f.0 ISA bridge: Intel Corporation Sunrise Point LPC Controller/eSPI Controller (rev 21)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0

00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
        Subsystem: Dell Device 0809
        Flags: fast devsel
        Memory at d51b4000 (32-bit, non-prefetchable) [disabled] [size=16K]

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 32, IRQ 129
        Memory at d51b0000 (64-bit, non-prefetchable) [size=16K]
        Memory at d5180000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel, snd_soc_skl

00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
        Subsystem: Dell Device 0809
        Flags: medium devsel, IRQ 16
        Memory at d51b8000 (64-bit, non-prefetchable) [size=256]
        I/O ports at f040 [size=32]
        Kernel driver in use: i801_smbus
        Kernel modules: i2c_i801

01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
        Subsystem: Dell Device 0809
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at d3000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 79)
        Subsystem: Intel Corporation Device 4410
        Flags: bus master, fast devsel, latency 0, IRQ 128
        Memory at d5000000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
 
Last edited:

WisePassion

New Member
Credits
265
So using Neofetch I can get a more basic interpretation of my GPU model:
Code:
GPU: NVIDIA GeForce MX150
GPU: Intel UHD Graphics 620
Plus I now know how to verify that my computer is running the Nvidia drivers, so it actually seems plausible that this is a driver misconfiguration. Xorg just says what x.org calls very general information, meaning it is unlikely we can fix this on the Xorg server level.
And yes, both of those lines are on Neofetch, pretty sure my computer has dual graphics, back when I ran Mint I used the graphical nvidia-settings and it allowed me to switch between integrated/GeForce graphics. However I don't think I've used the integrated graphics on Arch, recently I installed some Intel driver packages based on some Wiki page and I noticed that on Neofetch.
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
9,106
What does your xorg.conf look like now?
 

WisePassion

New Member
Credits
265
Here is the Device section:
Code:
Section "Device"
Identifier "Device0" #exact
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection
Any other sections you need?

EDIT from after Xorg works: I deleted Xorg.conf to fix the problem but I still saved it:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 455.45.01


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 
Last edited:

JasKinasis

Well-Known Member
Credits
5,067
I don't want to derail this thread, but I can see that @WisePassion has two graphics cards. An NVidia and an Intel card. So this is an Optimus system.
Has Optimus been set up, to allow you to switch between the integrated intel graphics card and the NVidia one?

If not, I will refer you to this page:

That's the page for the latest NVidia driver that supports the OPs card.

In particular take a look at the "Additional information" section.
I think alongside the driver, you might also need to set up Optimus.
That might solve the problem and allow steam to run.
 

WisePassion

New Member
Credits
265
SOOO another funny story...

I fixed Xorg. The solution was simple, deleting the file /etc/X11/xorg.conf; Xorg actually works fine without it.

The reason I think this problem was caused is the Nvidia driver creating xorg.conf upon configuration, which broke my system.

I am so happy, just having access to my desktop again after a week without it!

But as for Steam? We are back where we started.

Code:
Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
/home/lonefox256/.local/share/Steam/ubuntu12_32/steam
[2020-12-01 16:41:02] Startup - updater built Nov 20 2020 21:48:51
[2020-12-01 16:41:02] Opted in to client beta 'publicbeta' via beta file
You are in the 'publicbeta' client beta.
Installing breakpad exception handler for appid(steam)/version(1605919008)
[2020-12-01 16:41:04] Loading cached metrics from disk (/home/lonefox256/.local/share/Steam/package/steam_client_metrics.bin)
[2020-12-01 16:41:04] Using the following download hosts for Public, Realm steamglobal
[2020-12-01 16:41:04] 1. http://media4.steampowered.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
Installing breakpad exception handler for appid(steam)/version(1605919008)
[2020-12-01 16:41:04] Verifying installation...
[2020-12-01 16:41:04] Verification complete
Loaded SDL version 2.0.13-6215953
STEAM_RUNTIME_HEAVY: ./steam-runtime-heavy
Installing breakpad exception handler for appid(steam)/version(1605919008)
[1201/164114.303927:INFO:crash_reporting.cc(247)] Crash reporting enabled for process: browser
[1201/164114.691981:WARNING:crash_reporting.cc(286)] Failed to set crash key: UserID with value: 0
[1201/164114.692059:WARNING:crash_reporting.cc(286)] Failed to set crash key: BuildID with value: 1605908830
[1201/164114.692065:WARNING:crash_reporting.cc(286)] Failed to set crash key: SteamUniverse with value: Public
[1201/164114.692069:WARNING:crash_reporting.cc(286)] Failed to set crash key: Vendor with value: Valve
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
CAppInfoCacheReadFromDiskThread took 215 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Warning: failed to set thread priority: set failed for 8: -1: setpriority() failed
Warning: failed to set thread priority: set failed for priority 8
Warning: support for elevated priorities is most likely unavailable, suppressing future warnings
Warning: failed to set thread priority: set failed for 8: -1: setpriority() failed
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
PulseAudio connect failed (used only for Mic Volume Control) with error: Access denied
[1201/164119.072212:WARNING:crash_reporting.cc(286)] Failed to set crash key: UserID with value: 0
[1201/164119.072291:WARNING:crash_reporting.cc(286)] Failed to set crash key: BuildID with value: 1605908830
[1201/164119.072296:WARNING:crash_reporting.cc(286)] Failed to set crash key: SteamUniverse with value: Public
[1201/164119.072301:WARNING:crash_reporting.cc(286)] Failed to set crash key: Vendor with value: Valve
[1201/164119.072998:INFO:crash_reporting.cc(247)] Crash reporting enabled for process: gpu-process
[1201/164120.319140:ERROR:sandbox_linux.cc(372)] InitializeSandbox() called with multiple threads in process gpu-process.
CApplicationManagerPopulateThread took 7401 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Proceed to auto login
[1201/164123.722236:WARNING:crash_reporting.cc(286)] Failed to set crash key: UserID with value: 0
[1201/164123.722316:WARNING:crash_reporting.cc(286)] Failed to set crash key: BuildID with value: 1605908830
[1201/164123.722322:WARNING:crash_reporting.cc(286)] Failed to set crash key: SteamUniverse with value: Public
[1201/164123.722326:WARNING:crash_reporting.cc(286)] Failed to set crash key: Vendor with value: Valve
[1201/164123.837372:INFO:crash_reporting.cc(247)] Crash reporting enabled for process: utility

** (steam:1918): WARNING **: 16:41:23.915: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files
Installing breakpad exception handler for appid(steam)/version(1605919008)
Exiting workitem thread
[2020-12-01 16:41:31] Shutdown
 

WisePassion

New Member
Credits
265
Ok look at this. Now Steam prints this log and instantly returns to the shell prompt.
Code:
Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
/home/lonefox256/.local/share/Steam/ubuntu12_32/steam
This made me think for a second that Steam was about to run, but nothing happens after that. I look at htop and sure enough Steam is not there.
 

WisePassion

New Member
Credits
265
Another utterly hilarious story:
Code:
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Proceed to auto login

** (steam:1034): WARNING **: 20:23:39.482: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freed
[1201/202342.149176:WARNING:crash_reporting.cc(286)] Failed to set crash key: UserID with value: 0
[1201/202342.149277:WARNING:crash_reporting.cc(286)] Failed to set crash key: BuildID with value: 1605908830
[1201/202342.149283:WARNING:crash_reporting.cc(286)] Failed to set crash key: SteamUniverse with value: Public
[1201/202342.149288:WARNING:crash_reporting.cc(286)] Failed to set crash key: Vendor with value: Valve
[1201/202342.150087:INFO:crash_reporting.cc(247)] Crash reporting enabled for process: gpu-process
[1201/202342.899492:ERROR:sandbox_linux.cc(372)] InitializeSandbox() called with multiple threads in process gpu-process.
[1201/202344.259146:WARNING:crash_reporting.cc(286)] Failed to set crash key: UserID with value: 0
[1201/202344.259236:WARNING:crash_reporting.cc(286)] Failed to set crash key: BuildID with value: 1605908830
[1201/202344.259242:WARNING:crash_reporting.cc(286)] Failed to set crash key: SteamUniverse with value: Public
[1201/202344.259247:WARNING:crash_reporting.cc(286)] Failed to set crash key: Vendor with value: Valve
[1201/202344.273404:INFO:crash_reporting.cc(247)] Crash reporting enabled for process: utility
INTEL-MESA: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

Opted-in Controller Mask for AppId 0: 0
Installing breakpad exception handler for appid(steam)/version(1605919008)

(steam:1034): Gtk-WARNING **: 20:23:50.470: gtk_disable_setlocale() must be called before gtk_init()
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
roaming config store loaded successfully - 5736 bytes.
migrating temporary roaming config store
BRefreshApplicationsInLibrary 1: 141ms
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
src/steamUI/SteamApp.cpp (639) : Assertion Failed: m_eReleaseState == k_EAppReleaseState_Unknown
src/steamUI/SteamApp.cpp (639) : Assertion Failed: m_eReleaseState == k_EAppReleaseState_Unknown
Installing breakpad exception handler for appid(steam)/version(1605919008)
assert_20201201202356_27.dmp[1156]: Uploading dump (out-of-process)
/tmp/dumps/assert_20201201202356_27.dmp
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
[1201/202400.765006:INFO:crash_reporting.cc(270)] Crash reporting enabled for process: renderer
Installing breakpad exception handler for appid(steam)/version(1605919008)
assert_20201201202356_27.dmp[1156]: Finished uploading minidump (out-of-process): success = yes
assert_20201201202356_27.dmp[1156]: response: CrashID=bp-4f4bbf71-a976-4ac5-958c-3db9f2201201
assert_20201201202356_27.dmp[1156]: file ''/tmp/dumps/assert_20201201202356_27.dmp'', upload yes: ''CrashID=bp-4f4bbf71-a976
[1201/202403.676279:INFO:crash_reporting.cc(270)] Crash reporting enabled for process: renderer
[1201/202405.128834:INFO:crash_reporting.cc(270)] Crash reporting enabled for process: renderer
Installing breakpad exception handler for appid(steam)/version(1605919008)
Failed to init SteamVR because it isn't installed
Installing breakpad exception handler for appid(steam)/version(1605919008)
Installing breakpad exception handler for appid(steam)/version(1605919008)
ExecCommandLine: "'/home/lonefox256/.local/share/Steam/ubuntu12_32/steam'"
System startup time: 49.88 seconds
[1201/202415.087466:INFO:crash_reporting.cc(270)] Crash reporting enabled for process: renderer
[1201/202415.094949:INFO:crash_reporting.cc(270)] Crash reporting enabled for process: renderer
[1201/202415.101949:INFO:crash_reporting.cc(270)] Crash reporting enabled for process: renderer
Installing breakpad exception handler for appid(steam)/version(1605919008)
ExecCommandLine: "gameid/265930'"
[1201/202417.456924:ERROR:object_proxy.cc(632)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[1201/202417.457046:WARNING:property.cc(145)] DaemonVersion: GetAndBlock: failed.
[1201/202417.457891:ERROR:object_proxy.cc(632)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
[1201/202417.458800:ERROR:object_proxy.cc(632)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
BuildCompleteAppOverviewChange: 107
RegisterForAppOverview 1: 6ms
RegisterForAppOverview 2: 6ms
I don't know how to easiest replicate this solution for a visitor. I basically tweaked random stuff until something happens. The last thing I remember doing is re-running through Chris Titus Tech's "Ultimate Linux Gaming Guide" and making sure all of the Arch packages were installed on my system. I'm pretty sure at least a few of them weren't, and that is the most likely solution to my problem. Just missing dependencies.

Welp, there goes what would have been the time of my "life".

Also this isn't the full logs. Unfortunately I didn't think to print these logs to a file, and my terminal emulator wasn't configured to scroll up, so I just took all of the logs that I could find. Anything before the first line should be semi-predictable compared to the error logs I had before.

Thanks........
 

f33dm3bits

Gold Member
Gold Supporter
Credits
9,106
EDIT from after Xorg works: I deleted Xorg.conf to fix the problem but I still saved it:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 455.45.01


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Xorg also reads /usr/share/X11/xorg.conf.d which also contains an nvidia configuration if you have the the nvidia driver installed so that's why it's still working. There must have been something off in xorg.conf causing your display not to be seen by your display manager. Glad you got it fixed, you could also still try running nvida-xconfig which will generate a new working xorg configuration based on the current hardware in your system.
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
9,106
Another utterly hilarious story:
I don't know how to easiest replicate this solution for a visitor. I basically tweaked random stuff until something happens. The last thing I remember doing is re-running through Chris Titus Tech's "Ultimate Linux Gaming Guide" and making sure all of the Arch packages were installed on my system. I'm pretty sure at least a few of them weren't, and that is the most likely solution to my problem. Just missing dependencies.

Welp, there goes what would have been the time of my "life".

Also this isn't the full logs. Unfortunately I didn't think to print these logs to a file, and my terminal emulator wasn't configured to scroll up, so I just took all of the logs that I could find. Anything before the first line should be semi-predictable compared to the error logs I had before.

Thanks........
I had it once that steam wouldn't run for me, I got the same sort of output which isn't really helpful. I then started steam using gdb(GNU Debugger), as already mentioned in post #6, and that gave me more to work with and I was able to fix it and there also an Arch wiki page dedicated to debugging Steam. Glad you got it working!
 

Members online


Top