[SOLVED] please help! libkmod error on boot

lucasmarx

New Member
Credits
67
for the pas couple of days I'm booting on linux mint 20.1 and getting this error:

Code:
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/alsa-base.conf line 44: ignoring bad line starting with options
 libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/alsa-base.conf line 44: ignoring bad line starting with options
and after a few seconds goes to a terminal screen asking for user and password. I've logged and accessed the folder in question but wasn't able to alter it(even with sudo), it was as read only.

This is what I tried so far: 1 - I've booted a usb with live mint on it, accessed the folder with sudo and tried deleting the 44th line, restarted and nothing changed. 2 - Booted with usb again, deleted the alsa-base.conf and restarted and got the error again (now without the line 44 part). 3 - Booted with usb, copied the /etc/modprobe.d/alsa-base.conf from the live etc folder and pasted on my linux etc folder and got the same error(with the line 44 part)

Can someone help me with this, please I've posted in like 4 different forums and didn't got a single reply?

Here`s the alsa-base.conf content:

Code:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
 


f33dm3bits

Gold Member
Gold Supporter
Credits
21,037
Can you post a screenshot of where you are seeing this? If you are trying to remove or change something while booted from the live usb media and then reboot it it goes back the way it was is because the live media isn't persistent. You have to go through the Linux Mint installer to install the OS and then reboot, after you have rebooted you are running on an actual installed system. Then you can login and changes you make to folders or files will be persistent.
 
Last edited:

lucasmarx

New Member
Credits
67
I can't because it doesn't even load the system, only a command line, I took a picture with my phone but it appears right after the mint logo shows up.
WhatsApp Image 2021-06-22 at 12.05.05.jpeg


I'm only using the live media to access my installed file system, and delete the file on the linux that was alredy installed, that doesn't work as well?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
21,037
Do you know which partition is your / partition, if so try doing this.
1. Boot into Live mode
2. Mount your / partition, for example: sudo mount /dev/sda1 /mnt
3. Chroot into your installation: sudo chroot /mnt
4. Change directory to modprobe.d: cd /etc/modprobe.d
5. Make a new directory for disabling configurations: sudo mkdir disabled
6. sudo mv alsa-base.conf disasbled
7. exit out of chroot by exiting the terminal.
8. Reboot your system so that it boots from hard disk.
9. What happens now?
 

lucasmarx

New Member
Credits
67
Do you know which partition is your / partition, if so try doing this.
1. Boot into Live mode
2. Mount your / partition, for example: sudo mount /dev/sda1 /mnt
3. Chroot into your installation: sudo chroot /mnt
4. Change directory to modprobe.d: cd /etc/modprobe.d
5. Make a new directory for disabling configurations: sudo mkdir disabled
6. sudo mv alsa-base.conf disasbled
7. exit out of chroot by exiting the terminal.
8. Reboot your system so that it boots from hard disk.
9. What happens now?
I did it but it was still not working. I used 'dmesg' and it showed an bad line on my fstab file, I've changed it and now it's working. The problem wasn't the alsa-base.conf file all along :rolleyes: but now it's solved.
Thank you so much foryour help.
 

brickwizard

Well-Known Member
Credits
3,635
but now it's solved.
Thank you so much foryour help.
If your happy .. please amend the title of your first post to include "Solved"
thanks
 

f33dm3bits

Gold Member
Gold Supporter
Credits
21,037
I did it but it was still not working. I used 'dmesg' and it showed an bad line on my fstab file, I've changed it and now it's working. The problem wasn't the alsa-base.conf file all along :rolleyes: but now it's solved.
Thank you so much foryour help.
The whole point of disabling alsa-base.conf was to see if the problem still existed or not when it was disable, which you figured out yourself since you found the problem using dmesg. Glad you gold it solved and was able to help you on you way to a solution.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top