[SOLVED] Oblivion stuttering issue, random fps drops

benjamix97

New Member
Joined
Nov 8, 2020
Messages
8
Reaction score
2
Credits
93
Hi guys!

I am trying to play the game on my laptop.
On Windows it worked fine, but now I'm having issues on my Ubuntu 18.04.5 LTS. (proton version 4.2-9)

The laptop is Lenovo ideapad 100-15ibd:
Intel(R) Core(TM) i3-5005U CPU @ 2.00GHz
4GiB RAM
GeForce 920M

I tried every possible solution I could find on the internet:
1) protontricks quartz
2) using a different proton version
3) updating nvidia drivers
4) some gamemoderun %command% that didn't even let me start the game

5) i tried these CPU tweaks:
bUseThreadedBlood=1 (default 0)
bUseThreadedMorpher=1 (default 0)
bUseThreadedTempEffects=1 (default 0)
bUseThreadedParticleSystem=1 (default 0)
bUseBackgroundPathing=1 (default 0)
bUseBackgroundFileLoader=1 (default 0)
iNumHavokThreads=3 (default 1)
iThreads=10 (default 3)

6) I tried turning off: texture, specular and diffuse
7) i tried the lowest possible graphics settings

The only thing that kinda worked was turning of the sound and music completely (bSound=0), but I am playing the game in german in order to practice my german so it's kind of pointless if I can't hear anything, and the game still lagged a bit anyway

Does anyone know what I could do?
I really love this game, but I can't play it with these random fps drops that last a couple of seconds

Thanks in advance!


I only have the Unofficial Oblivion Patch activated besides the Master File


EDIT: Issue resolved by switching to Intel HD graphics card and turning off the nvidia drivers
 
Last edited:


Ok I tried some stuff that kinda helped:

1) scaling governor, I set the CPU to performance (it was on powersaver before)
2) in the NVIDIA settings I chose Prefer Maximum Performance
3) I added a PROTON_FORCE_LARGE_ADDRESS_AWARE=1 command since I have 4 GB RAM
4) I lowered the graphics settings (lowest possible) and I'm using the 640x480 resolution

Now I get around 100 FPS, but I still get the fps drops, especially in combat
It is now playable, but I would still really prefer not to have them
Any ideas?
 
All the comments on protondb say that they had it running fine with proton 4.11-13. Also in order to use the gamemode command it has to be installed and have you tried proton-ge?
 
All the comments on protondb say that they had it running fine with proton 4.11-13. Also in order to use the gamemode command it has to be installed and have you tried proton-ge?

Ok, I did not know I had to install gamemode. I installed it now and I guess it works because it started the game with the "gamemoderun %command", but it did not fix my issue. Even with the worst graphics possible, it still gets random fps drops...

I will look into the proton-ge now, thank you for your reply!
 
All the comments on protondb say that they had it running fine with proton 4.11-13. Also in order to use the gamemode command it has to be installed and have you tried proton-ge?

Ok I have tried proton-ge, version 5.9 didn't let me choose a graphics card (there weren't any to choose) and the game just crashed on start

Version 4-11-GE just lagged all the time...

I guess it is just me :D
 
Try adding this to your game launch options
Code:
PROTON_NO_ESYNC=1 %command%
Also check the Improving Performance page.
 
This may sound counterintuitive, but have you tried the opensource drivers?

(After trying the above tips.)
 
Try adding this to your game launch options
Code:
PROTON_NO_ESYNC=1 %command%
Also check the Improving Performance page.
Sorry about the double post, I thought the first didn't work because I couldn't see it.

PROTON_NO_ESYNC=1 %command% this seemed to work with ultra-low graphics and without gamemoderun, I didn't get any fps drops during combat, I will now try to use better graphics and I'll let you guys know if it worked, thanks a lot for your help!

This may sound counterintuitive, but have you tried the opensource drivers?

(After trying the above tips.)

Is this what you mean?
 
And I read somewhere that when you have a low fps to check if libmpg123 is installed. If not try installing it:
sudo apt install libmpg123-0:i386
@KGIII The nouveau driver isn't good enough for gaming, for gaming you need the nvidia proprietary driver which the OP already has installed.

And I came across this github issue might be worth following for updates.
 
Is this what you mean?

It is indeed. You shouldn't need to 'install' it in any sense of the word. Usually, just removing the proprietary drivers and rebooting does the trick. As you're using Ubuntu, you can also just select it in the additional drivers settings.

@f33dm3bits asserts that it's not good enough for gaming, so you should probably defer to him. I'm positive that he games more than I. My understanding is that it's okay so long as you don't need Vulcan support, but it may be dated.
 
When you tried the gamemoderun command did you have gamemoded running?
Check by doing:
systemctl --user status gamemoded
If not enable and start it:
systemctl --user enable gamemoded
systemctl --user start gamemoded
Then check if it's running again, if it's running trying launching the game with gamemode launch option again:
gamemoderun %command%
Also I just remembered you need both packages so also the 32 bit version: gamemode and gamemode-lib32.
 
When you tried the gamemoderun command did you have gamemoded running?
Check by doing:

If not enable and start it:

Then check if it's running again, if it's running trying launching the game with gamemode launch option again:

Also I just remembered you need both packages so also the 32 bit version: gamemode and gamemode-lib32.

I didn't have gamemode running so I did that too now, thank you.

However, I managed to solve my issue in the dumbest way possible:
I turned off the nvidia driver and switched to my integrated Intel HD graphics card.
I get a pleasant 30FPS experience now (medium settings).

So I'm guessing the problem was with the nvidia drivers (thanks KGIII)

And thanks f33dm3bits again!
 

Attachments

  • 2020-11-09-005030_1366x768_scrot.png
    2020-11-09-005030_1366x768_scrot.png
    1.4 MB · Views: 451
Why would you want to game with an integrated Intel graphics card? You will get better performance if you use the nvidia graphics card with the nvidia driver. Can't you do it the other way around switch off the intel card and leave the nvidia card on, there should be an option in your bios for that. I think the options are hybrid(nvidia), discrete(intel) or mixed, try playing around with that it may be the other way around. If that isn't an option in your bios I would try to see if there is a way to switch off the intel graphics card and leave the nvidia graphics card enabled. I was saying the nouveau driver is worthless when it comes to gaming with nvidia cards because nvidia hasn't opensourced their drivers.
 
Why would you want to game with an integrated Intel graphics card? You will get better performance if you use the nvidia graphics card with the nvidia driver. Can't you do it the other way around switch off the intel card and leave the nvida card on, there should be an option in your bios for that. I think the options are hybrid(nvidia), discrete(intel) or mixed, try playing around with that it may be the other way around. I was saying the nouveau driver is worthless when it comes to gaming with nvidia cards because nvidia hasn't opensourced their drivers.

Well, I don't really care much about performance as long as it is not unbearable (which it was until now). As I said, I'm playing the game for the story and to practice a foreign language as much as possible. All I care about is that I don't have to wait every couple of seconds to move my character again because of the random FPS drops.

The Intel card was turned off until now and I had to restart my system in order to switch that. I spent the last 2 days trying to figure this out and I am content with the result. But, you have been so kind and patient with me, so if you want, I can try tinkering with it tomorrow.
 
Personally I would throw my monitor out of the window if I had to game at 30 fps, now days I at least expect 50-60 fps.
 
I was doing something entirely different and I thought back to this thread. I was curious about how much framerate really mattered.

I came across this and figured I'd pass it along:


Short version:

You'll definitely see a difference between 30 and 60. You might see a difference between 60 and 90. Once you get up high enough, very few people will be able to see a difference.
 

Staff online

Members online


Top