[Solved] No speaker sound but wired headphone working! Help



Alexzee

Well-Known Member
Credits
7,773
I'd think that running Mint 20 the kernel should support a driver for your sound card.

Do you have PulseAudio in your sound settings?
IF so try controlling the sound through PulseAudio.

View attachment 9543View attachment 9544
[/QUOTE]
Under Volume Control> Configuration you may have to play with the settings in the drop down menu.
Also your Built In Audio is off try turning it on.

How old is your laptop and what make a model number is it?
 

Alexzee

Well-Known Member
Credits
7,773
IF you still don't have sound have a look in the BIOS under UEFI and see if the onboard sound is disabled like dos2unix suggested.
 

captain-sensible

Well-Known Member
Credits
12,756
When members here help me I always come back and let them know how things go.
It's just the right thing to do in my book.
if there was a sticky on front page ; it would be something like:

Welcome to Linux.org
The site is mainly populated with friendly volunteers.
Helpers are dotted in different places around the world in different time zones
Please be patient ; when you post some helpers won't have seen it yet due to time zone
We will try to help you but you need to play your part with a question supported by if possible specs and error output.
If by being here your problem got solved or this site gave you a spark of idea and you solved it yourself either way , don't just leave a thread dangling say your problem is solved. Give credit to helpers or how you solved it yourself
 

captain-sensible

Well-Known Member
Credits
12,756
@Jabirkt99 thanks for coming back


ok if your up for some some tests - we could explore it further. I noticed from one of your images that pavucontrol failed to install.

So first i would confirm mirror list is Ok:

output please either


Code:
cat   /etc/apt/sources.list.d
you can also try running

Code:
sudo apt edit-sources
@Alexzee - you know after running Slackware and now Arch i'm fuzzy on Debian derivative OS can you check that /etc/apt/sources.list.d is correct for where yo uedit for OS to get pkgs from repos please. Audio isn't one of my strong points
DO you have that Debian admin handbook , handy :^) ?
i'm not sure we got your actual OS so also you could output;

Code:
cat /etc/*-release
try re-installing ?
Code:
sudo apt remove --purge alsa-base pulseaudio
sudo apt install alsa-base pulseaudio
sudo alsa force-reload
reboot laptop


type at terminal :
alsamixer
hit return

Hit F6 to choose card -see what happens
 
Last edited:

Alexzee

Well-Known Member
Credits
7,773
Here is my sources list on my Debian 10 Buster laptop:

# deb cdrom:[Official Debian GNU/Linux Live 10.8.0 gnome 2021-02-06T12:51]/ buster main

#deb cdrom:[Official Debian GNU/Linux Live 10.8.0 gnome 2021-02-06T12:51]/ buster main

deb http://deb.debian.org/debian/ buster main non-free contrib
deb-src http://deb.debian.org/debian/ buster main non-free contrib

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

Linux Mint should have pulseaudio in it's repos.

Here's the direct link:

 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top